aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-02-18 09:29:27 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-02-18 09:29:27 +0000
commit19aaf574478ab9c483b6b9476d4f8229170ae810 (patch)
treee65f8a77264c1b72c9fa6593f5956201cdd7677d
parenta71cd2e00fa7df4dd164147945c097013c003e6c (diff)
downloadports-19aaf574478ab9c483b6b9476d4f8229170ae810.tar.gz
ports-19aaf574478ab9c483b6b9476d4f8229170ae810.zip
Notes
-rw-r--r--benchmarks/expedite/Makefile2
-rw-r--r--databases/pg_rman/Makefile2
-rw-r--r--devel/elixir-simple_bayes/Makefile2
-rw-r--r--devel/elixir-stemmer/Makefile2
-rw-r--r--emulators/mupen64plus-qt/Makefile2
-rw-r--r--graphics/code-eli/Makefile2
-rw-r--r--graphics/mitsuba/Makefile2
-rw-r--r--lang/rust-nightly/Makefile2
-rw-r--r--lang/x10/Makefile2
-rw-r--r--net-im/ring-daemon/Makefile2
-rw-r--r--net-im/ring-gnome/Makefile3
-rw-r--r--net-im/ring-libclient/Makefile3
-rw-r--r--security/clamfs/Makefile2
-rw-r--r--textproc/p5-HTML-CTPP2/Makefile2
-rw-r--r--textproc/rubygem-compass-rails/Makefile2
15 files changed, 32 insertions, 0 deletions
diff --git a/benchmarks/expedite/Makefile b/benchmarks/expedite/Makefile
index 6feaf0db1f56..95dda6cddbdd 100644
--- a/benchmarks/expedite/Makefile
+++ b/benchmarks/expedite/Makefile
@@ -31,5 +31,7 @@ SDL_CONFIGURE_ENABLE= software-sdl
X11_CONFIGURE_ENABLE= software-x11 xrender-x11
BROKEN= Do not build with devel/efl 1.19.x
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
.include <bsd.port.mk>
diff --git a/databases/pg_rman/Makefile b/databases/pg_rman/Makefile
index 2e50497fe96b..405dc2afd0c8 100644
--- a/databases/pg_rman/Makefile
+++ b/databases/pg_rman/Makefile
@@ -10,6 +10,8 @@ COMMENT= Online backup and restore tool for PostgreSQL
LICENSE= BSD3CLAUSE
BROKEN= checksum and size mismatch (using a branch and not a tag or commit hash)
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
USES= gettext-runtime gmake pgsql
USE_GITHUB= yes
diff --git a/devel/elixir-simple_bayes/Makefile b/devel/elixir-simple_bayes/Makefile
index 3d5f3b595a06..d3f1fe5bcd35 100644
--- a/devel/elixir-simple_bayes/Makefile
+++ b/devel/elixir-simple_bayes/Makefile
@@ -12,6 +12,8 @@ COMMENT= Naive Bayes machine learning implementation in Elixir
LICENSE= MIT
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
USES= elixir
USE_GITHUB= yes
diff --git a/devel/elixir-stemmer/Makefile b/devel/elixir-stemmer/Makefile
index 1b13eba13135..7889ea9cb41d 100644
--- a/devel/elixir-stemmer/Makefile
+++ b/devel/elixir-stemmer/Makefile
@@ -12,6 +12,8 @@ COMMENT= English stemming implementation in Elixir
LICENSE= MIT
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
USES= elixir
USE_GITHUB= yes
diff --git a/emulators/mupen64plus-qt/Makefile b/emulators/mupen64plus-qt/Makefile
index 0a7181c0b453..19e918efd913 100644
--- a/emulators/mupen64plus-qt/Makefile
+++ b/emulators/mupen64plus-qt/Makefile
@@ -10,6 +10,8 @@ COMMENT= Basic launcher for Mupen64Plus
LICENSE= BSD3CLAUSE
BROKEN= wrong dependencies, mupen64plus executable is not provided by emulators/mupen64plus
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
LIB_DEPENDS= libquazip.so:archivers/quazip
RUN_DEPENDS= mupen64plus:emulators/mupen64plus
diff --git a/graphics/code-eli/Makefile b/graphics/code-eli/Makefile
index 5d63e954e35c..325fb629567e 100644
--- a/graphics/code-eli/Makefile
+++ b/graphics/code-eli/Makefile
@@ -13,6 +13,8 @@ LICENSE= EPL
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN= Needs work to use math/eigen3 currently in ports
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
USE_GITHUB= yes
GH_PROJECT= Code-Eli
diff --git a/graphics/mitsuba/Makefile b/graphics/mitsuba/Makefile
index b7f54f817723..3a6c04aec624 100644
--- a/graphics/mitsuba/Makefile
+++ b/graphics/mitsuba/Makefile
@@ -14,6 +14,8 @@ COMMENT= Research-oriented physically based rendering system
LICENSE= GPLv3
BROKEN= fails to build with boost 1.65, see bug 220719
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libpng.so:graphics/png \
diff --git a/lang/rust-nightly/Makefile b/lang/rust-nightly/Makefile
index 4cec89c5cbd6..886eed0ef965 100644
--- a/lang/rust-nightly/Makefile
+++ b/lang/rust-nightly/Makefile
@@ -19,6 +19,8 @@ GH_TUPLE= rust-lang:rust:282fa87 \
rust-lang:rust-installer:4f99485:rust_installer/src/rust-installer
BROKEN= needs to be adapted after changes in lang/rust
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
CONFLICTS_BUILD= rust # see FIXME in `pre-fetch` in lang/rust/Makefile
CONFLICTS_INSTALL= rust
diff --git a/lang/x10/Makefile b/lang/x10/Makefile
index 5c814979f3b7..cc498a49fbd4 100644
--- a/lang/x10/Makefile
+++ b/lang/x10/Makefile
@@ -25,6 +25,8 @@ COMMENT= Object-oriented parallel programming language
LICENSE= EPL
BROKEN= Fails to build with modern compilers (cf. PR 219282)
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
USES= tar:bzip2
USE_JAVA= yes
diff --git a/net-im/ring-daemon/Makefile b/net-im/ring-daemon/Makefile
index 41cbc52f9824..2b50f20f297d 100644
--- a/net-im/ring-daemon/Makefile
+++ b/net-im/ring-daemon/Makefile
@@ -13,6 +13,8 @@ COMMENT= Daemon part of the Ring VoIP SIP phone and IM
LICENSE= GPLv3
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LIB_DEPENDS= libyaml-cpp.so:devel/yaml-cpp \
diff --git a/net-im/ring-gnome/Makefile b/net-im/ring-gnome/Makefile
index 957d0a7c2864..fd335fc0b91a 100644
--- a/net-im/ring-gnome/Makefile
+++ b/net-im/ring-gnome/Makefile
@@ -13,6 +13,9 @@ COMMENT= Gnome client of the Ring VoIP SIP phone and IM
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Depends on expiring and broken net-im/ring-daemon
+EXPIRATION_DATE= 2018-03-19
+
LIB_DEPENDS= libringclient.so:net-im/ring-libclient \
libqrencode.so:graphics/libqrencode \
libcogl-pango.so:graphics/cogl \
diff --git a/net-im/ring-libclient/Makefile b/net-im/ring-libclient/Makefile
index 5094d33ee04c..e8e57bb6a11a 100644
--- a/net-im/ring-libclient/Makefile
+++ b/net-im/ring-libclient/Makefile
@@ -12,6 +12,9 @@ COMMENT= Client library for the Ring VoIP SIP phone and IM
LICENSE= GPLv3
+DEPRECATED= Depends on expiring and broken net-im/ring-daemon
+EXPIRATION_DATE= 2018-03-19
+
LIB_DEPENDS= libring.so:net-im/ring-daemon
USE_GITHUB= yes
diff --git a/security/clamfs/Makefile b/security/clamfs/Makefile
index 942af69e3960..a56a77e4e77b 100644
--- a/security/clamfs/Makefile
+++ b/security/clamfs/Makefile
@@ -13,6 +13,8 @@ COMMENT= User-space fs with on-access antivirus scanning
LICENSE= GPLv2
BROKEN= fails to build with boost 1.65, see bug 220725
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
LIB_DEPENDS= libccgnu2.so:devel/commoncpp \
libPocoNet.so:devel/poco-ssl \
diff --git a/textproc/p5-HTML-CTPP2/Makefile b/textproc/p5-HTML-CTPP2/Makefile
index c0c6756688fa..2b844260ddca 100644
--- a/textproc/p5-HTML-CTPP2/Makefile
+++ b/textproc/p5-HTML-CTPP2/Makefile
@@ -16,6 +16,8 @@ BUILD_DEPENDS= ctpp2>=2.5.1:textproc/ctpp2
LIB_DEPENDS= libctpp2.so:textproc/ctpp2
BROKEN= Fails to build with Perl >= 5.22
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
USES= perl5
USE_PERL5= configure
diff --git a/textproc/rubygem-compass-rails/Makefile b/textproc/rubygem-compass-rails/Makefile
index 2e2cf6be05f7..f5f51f07b047 100644
--- a/textproc/rubygem-compass-rails/Makefile
+++ b/textproc/rubygem-compass-rails/Makefile
@@ -12,6 +12,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= conflicting run depends
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2018-03-19
RUN_DEPENDS= rubygem-compass>=1.0.0:textproc/rubygem-compass \
rubygem-sass-rails5>=0:textproc/rubygem-sass-rails5 \