aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-29 20:16:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-03-29 20:16:36 +0000
commit19b83b347d711ce19848fd9fb53e7fb7b4094052 (patch)
tree794462b842c72b7b39a859e47a597641b28c4c27
parenta870f6904ab322af299fefc5b110db62c444440a (diff)
downloadports-19b83b347d711ce19848fd9fb53e7fb7b4094052.tar.gz
ports-19b83b347d711ce19848fd9fb53e7fb7b4094052.zip
Notes
-rw-r--r--editors/morla/Makefile3
-rw-r--r--science/gchemutils/Makefile3
-rw-r--r--www/py-selenium/Makefile3
-rw-r--r--www/xpi-conkeror/Makefile1
-rw-r--r--x11-toolkits/swt-devel/Makefile3
5 files changed, 4 insertions, 9 deletions
diff --git a/editors/morla/Makefile b/editors/morla/Makefile
index 668a73ba974c..2481b5a61d9c 100644
--- a/editors/morla/Makefile
+++ b/editors/morla/Makefile
@@ -36,8 +36,7 @@ DESKTOP_ENTRIES="morla" \
"WebDevelopment;" \
true
-XULRUNNER_BROKEN=No gecko type specified (firefox, seamonkey, thunderbird)
-XULRUNNER_USES= gecko
+XULRUNNER_BROKEN= www/libxul is gone, consider using lang/spidermonkey*
XULRUNNER_CONFIGURE_ON= --with-javascript=xulrunner
XULRUNNER_CONFIGURE_OFF= --with-javascript=none
diff --git a/science/gchemutils/Makefile b/science/gchemutils/Makefile
index 6fa66a51b432..188f2127719e 100644
--- a/science/gchemutils/Makefile
+++ b/science/gchemutils/Makefile
@@ -48,8 +48,7 @@ OPTIONS_SUB= yes
GNUMERIC_DESC= Build gnumeric plugin
XUL_DESC= Build browser plugin (requires libxul)
-XUL_BROKEN= No gecko type specified (firefox, seamonkey, thunderbird)
-XUL_USES= gecko
+XUL_BROKEN= XULrunner and non-Flash plugins are no longer supported
XUL_CONFIGURE_ON=--enable-mozilla-plugin \
--with-mozilla-libdir=${PREFIX}/lib/xulrunner
XUL_CONFIGURE_OFF=--disable-mozilla-plugin
diff --git a/www/py-selenium/Makefile b/www/py-selenium/Makefile
index 53de73bb41c6..d9a59c3f4bd2 100644
--- a/www/py-selenium/Makefile
+++ b/www/py-selenium/Makefile
@@ -25,8 +25,7 @@ OPTIONS_DEFINE= FIREFOX CHROMIUM
FIREFOX_DESC= Install Firefox and geckodriver
CHROMIUM_DESC= Install Chromium
-FIREFOX_USES= gecko:firefox
-FIREFOX_RUN_DEPENDS= geckodriver:www/geckodriver
+FIREFOX_RUN_DEPENDS= firefox:www/firefox geckodriver:www/geckodriver
CHROMIUM_RUN_DEPENDS= chromedriver:www/chromium
# Don't install binary Firefox extension
diff --git a/www/xpi-conkeror/Makefile b/www/xpi-conkeror/Makefile
index c24d77669b3b..2abbc6dc06e6 100644
--- a/www/xpi-conkeror/Makefile
+++ b/www/xpi-conkeror/Makefile
@@ -16,7 +16,6 @@ LICENSE_COMB= multi
USES= desktop-file-utils tar:xz gmake
-FIREFOX_USES= gecko:firefox,32+
ALL_TARGET= # empty
BUILD_ID= ${ECHO_CMD} -n `whoami`@`hostname`_`date +%s`
diff --git a/x11-toolkits/swt-devel/Makefile b/x11-toolkits/swt-devel/Makefile
index 592bd71bee58..f581640e1e1e 100644
--- a/x11-toolkits/swt-devel/Makefile
+++ b/x11-toolkits/swt-devel/Makefile
@@ -59,8 +59,7 @@ MAKE_GNOME= make_gnome
.endif
.if ${PORT_OPTIONS:MMOZILLA}
-USES= gecko
-BROKEN= Does now work with newer libxul
+BROKEN= non-Flash plugins are no longer supported
PLIST_FILES+= lib/libswt-xulrunner-gtk-%%BUILD%%.so
MAKE_MOZILLA= make_xulrunner
.endif