aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-11-24 23:11:10 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-11-24 23:11:10 +0000
commit19c16e88dd4af62a1ca01ef04a6e2b5e71e44a6c (patch)
treed5aa0465890eb84efe24bd5e09bd582e4a96dfc3
parentd31c4b88e5b47148e0b9bb57370eed93f6a40dbb (diff)
downloadports-19c16e88dd4af62a1ca01ef04a6e2b5e71e44a6c.tar.gz
ports-19c16e88dd4af62a1ca01ef04a6e2b5e71e44a6c.zip
Notes
-rw-r--r--lang/gcc44/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 12df9dca09b2..12ccbd95ee20 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -1,25 +1,25 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
# $FreeBSD$
-PORTNAME= gcc
+PORTNAME= gcc47
PORTVERSION= 4.4.7
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/gcc-${VERSIONSTRING}
+DISTNAME= gcc-${DISTVERSION}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.4
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- mpfr:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
DEPRECATED= Superseded by GCC 4.6, only kept for the sake of cad/salome
VERSIONSTRING= ${PORTVERSION}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
-LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 sparc64
USE_BINUTILS= yes
USES= bison gmake iconv perl5
@@ -78,7 +78,7 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/libgomp
pre-everything::
- @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
+ @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${CONFIGURE_TARGET} [${LANGUAGES}]"
pre-configure:
cd ${SRCDIR} ; contrib/gcc_update --touch