aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-18 16:03:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-18 16:03:17 +0000
commit1a54ce1cfeb5b9d8b8940f6d30da0d5ae0aac490 (patch)
treee24c5b744a1fa1fbc31fcd3605eb893c2614e6f9
parent5b9336260d9ef239418b5f5341c4628ba9f5e6f6 (diff)
downloadports-1a54ce1cfeb5b9d8b8940f6d30da0d5ae0aac490.tar.gz
ports-1a54ce1cfeb5b9d8b8940f6d30da0d5ae0aac490.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-gitdb2/Makefile22
-rw-r--r--devel/py-gitdb2/distinfo3
-rw-r--r--devel/py-gitdb2/pkg-descr7
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 08373fc15a54..182a583b5dea 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4322,6 +4322,7 @@
SUBDIR += py-gevent
SUBDIR += py-git-up
SUBDIR += py-gitdb
+ SUBDIR += py-gitdb2
SUBDIR += py-gitless
SUBDIR += py-gitosis
SUBDIR += py-gitpython
diff --git a/devel/py-gitdb2/Makefile b/devel/py-gitdb2/Makefile
new file mode 100644
index 000000000000..a7784d445557
--- /dev/null
+++ b/devel/py-gitdb2/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gitdb2
+PORTVERSION= 2.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Git Object Database
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}smmap2>=2.0.0:devel/py-smmap2
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-gitdb2/distinfo b/devel/py-gitdb2/distinfo
new file mode 100644
index 000000000000..c81bd1293cce
--- /dev/null
+++ b/devel/py-gitdb2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1495051521
+SHA256 (gitdb2-2.0.0.tar.gz) = b9f3209b401b8b4da5f94966c9c17650e66b7474ee5cd2dde5d983d1fba3ab66
+SIZE (gitdb2-2.0.0.tar.gz) = 392536
diff --git a/devel/py-gitdb2/pkg-descr b/devel/py-gitdb2/pkg-descr
new file mode 100644
index 000000000000..4ad0c693ea07
--- /dev/null
+++ b/devel/py-gitdb2/pkg-descr
@@ -0,0 +1,7 @@
+GitDB allows you to access bare git repositories for reading and writing. It
+aims at allowing full access to loose objects as well as packs with performance
+and scalability in mind. It operates exclusively on streams, allowing to handle
+large objects with a small memory footprint.
+
+WWW: https://pypi.python.org/pypi/gitdb2
+WWW: https://github.com/gitpython-developers/gitdb