aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-05-30 17:48:37 +0000
committerSteve Wills <swills@FreeBSD.org>2013-05-30 17:48:37 +0000
commit1b22f38101622a00a8e7302e1d0170cf6a36b219 (patch)
tree664966f75a1c7c770973754ce3e74dbd8cd27166
parentec470c35ea209e4649ac69426b447cf918c02536 (diff)
downloadports-1b22f38101622a00a8e7302e1d0170cf6a36b219.tar.gz
ports-1b22f38101622a00a8e7302e1d0170cf6a36b219.zip
- Update to 2.0.12
- rc script passes rclint - Add UPDATING entry PR: ports/179015 Submitted by: Mark Felder <feld@feld.me> (maintainer)
Notes
Notes: svn path=/head/; revision=319438
-rw-r--r--UPDATING7
-rw-r--r--irc/inspircd/Makefile17
-rw-r--r--irc/inspircd/distinfo4
-rw-r--r--irc/inspircd/files/inspircd.in77
-rw-r--r--irc/inspircd/pkg-plist82
5 files changed, 76 insertions, 111 deletions
diff --git a/UPDATING b/UPDATING
index f21fe5a0a730..f53487052b74 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,13 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20130530:
+ AFFECTS: users of irc/inspircd
+ AUTHOR: swills@FreeBSD.org
+
+ The irc/inspircd port has been updated to 2.0.12. Some of the config option
+ names in the rc script have been changed. Check the script for more detail.
+
20130527:
AFFECTS: users of lang/ruby18
AUTHOR: swills@FreeBSD.org
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index f41f7d433c38..7c6a036b652e 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= inspircd
-PORTVERSION= 2.0.10
-PORTREVISION= 1
+PORTVERSION= 2.0.12
CATEGORIES= irc
MAINTAINER= feld@feld.me
@@ -18,7 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= inspircd
GH_PROJECT= ${GH_ACCOUNT}
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= d1cc59f
+GH_COMMIT= 9b96fee
USE_RC_SUBR= ${PORTNAME}
MAKEFILE= BSDmakefile
@@ -31,7 +30,9 @@ INSPIRCD_RUN?= /var/run/${PORTNAME}
INSPIRCD_LOG?= /var/log/${PORTNAME}/ircd.log
SUB_LIST+= PORTNAME=${PORTNAME} \
INSPIRCD_LOG=${INSPIRCD_LOG} \
- INSPIRCD_RUN=${INSPIRCD_RUN}
+ INSPIRCD_RUN=${INSPIRCD_RUN} \
+ USERS=${USERS} \
+ GROUPS=${GROUPS}
# Configure script is written in perl
USE_PERL5_BUILD=yes
@@ -143,13 +144,5 @@ post-patch:
post-install:
@${STRIP_CMD} ${PREFIX}/lib/${PORTNAME}/modules/*.so
@${STRIP_CMD} ${PREFIX}/bin/${PORTNAME}
-.for FILE in inspircd.censor inspircd.conf inspircd.filter inspircd.helpop-full \
- inspircd.helpop inspircd.motd inspircd.quotes inspircd.rules links.conf modules.conf opers.conf
- @if ${TEST} -f ${ETCDIR}/${FILE} && \
- ${TEST} ! -f ${ETCDIR}/examples/${FILE}.example ; then \
- ${CP} -p ${ETCDIR}/examples/${FILE}.example \
- ${ETCDIR}/${FILE}; \
- fi
-.endfor
.include <bsd.port.mk>
diff --git a/irc/inspircd/distinfo b/irc/inspircd/distinfo
index 7c836df097b6..d75c409cf26a 100644
--- a/irc/inspircd/distinfo
+++ b/irc/inspircd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (inspircd-2.0.10.tar.gz) = bcaf5e499097548b8cee5fc0acbe47403974114a7a4dd8de9f0c9340340070a2
-SIZE (inspircd-2.0.10.tar.gz) = 739166
+SHA256 (inspircd-2.0.12.tar.gz) = fc200db5fb398b5e124c41b4efffcd7019729dac93120318aa0ee98fbc2e39f3
+SIZE (inspircd-2.0.12.tar.gz) = 740694
diff --git a/irc/inspircd/files/inspircd.in b/irc/inspircd/files/inspircd.in
index 9bae6619fba2..5bb1048d5ab6 100644
--- a/irc/inspircd/files/inspircd.in
+++ b/irc/inspircd/files/inspircd.in
@@ -2,72 +2,57 @@
#
# $FreeBSD$
#
-# PROVIDE: %%PORTNAME%%
+# PROVIDE: inspircd
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: shutdown
#
-# Add the following lines to /etc/rc.conf to enable %%PORTNAME%%:
+# Add the following lines to /etc/rc.conf to enable inspircd:
#
-# %%PORTNAME%%_enable="YES"
+# inspircd_enable="YES"
#
# Other rc.conf variables:
-# %%PORTNAME%%_flags="<set as needed>"
+# inspircd_flags="<set as needed>"
#
-# %%PORTNAME%%_config="%%ETCDIR%%/%%PORTNAME%%.conf"
+# inspircd_config="%%ETCDIR%%/inspircd.conf"
# -- path to config file
-# %%PORTNAME%%_pidfile="%%INSPIRCD_RUN%%/%%PORTNAME%%.pid"
+# inspircd_pidfile="%%INSPIRCD_RUN%%/inspircd.pid"
# -- location of pidfile: must match setting
-# in ${%%PORTNAME%%_conffile}
-# %%PORTNAME%%_logfile="%%INSPIRCD_LOG%%"
-# -- file %%PORTNAME%% writes logs to
+# in ${inspircd_conffile}
+# inspircd_logfile="%%INSPIRCD_LOG%%"
+# -- file inspircd writes logs to
#
. /etc/rc.subr
-name=%%PORTNAME%%
-rcvar=%%PORTNAME%%_enable
+name=inspircd
+rcvar=inspircd_enable
load_rc_config ${name}
-: ${%%PORTNAME%%_enable="NO"}
-: ${%%PORTNAME%%_config="%%ETCDIR%%/%%PORTNAME%%.conf"}
-: ${%%PORTNAME%%_pidfile="%%INSPIRCD_RUN%%/%%PORTNAME%%.pid"}
-: ${%%PORTNAME%%_user=ircd}
-: ${%%PORTNAME%%_group=ircd}
-: ${%%PORTNAME%%_logfile="%%INSPIRCD_LOG%%"}
+: ${inspircd_enable:=NO}
+: ${inspircd_config="%%ETCDIR%%/inspircd.conf"}
+: ${inspircd_pidfile="%%INSPIRCD_RUN%%/inspircd.pid"}
+: ${inspircd_user="%%USERS%%"}
+: ${inspircd_group="%%GROUPS%%"}
+: ${inspircd_logfile="%%INSPIRCD_LOG%%"}
+: ${inspircd_flags="${inspircd_flags} --logfile ${inspircd_logfile} --config ${inspircd_config}"}
-command=%%PREFIX%%/bin/%%PORTNAME%%
-pidfile=${%%PORTNAME%%_pidfile}
-required_files=${%%PORTNAME%%_config}
-start_precmd=%%PORTNAME%%_prestart
+command=%%PREFIX%%/bin/inspircd
+pidfile=${inspircd_pidfile}
+required_files=${inspircd_config}
+start_precmd=inspircd_prestart
-%%PORTNAME%%_prestart ()
+inspircd_prestart()
{
- piddir=$(dirname ${%%PORTNAME%%_pidfile})
- if [ ! -d ${piddir} ]; then
- mkdir -m 755 -p ${piddir}
- chown -R ${%%PORTNAME%%_user}:${%%PORTNAME%%_group} ${piddir}
- fi
- logdir=$(dirname ${%%PORTNAME%%_logfile})
- if [ ! -d ${logdir} ]; then
- mkdir -m 755 -p ${logdir}
- chown -R ${%%PORTNAME%%_user}:${%%PORTNAME%%_group} ${logdir}
- fi
+ piddir=$(dirname ${inspircd_pidfile})
+ if [ ! -d ${piddir} ]; then
+ install -m 755 -o ${inspircd_user} -g ${inspircd_group} ${piddir}
+ fi
+ logdir=$(dirname ${inspircd_logfile})
+ if [ ! -d ${logdir} ]; then
+ install -m 755 -o ${inspircd_user} -g ${inspircd_group} ${logdir}
+ fi
}
-case "${%%PORTNAME%%_flags}" in
- *--config\ *)
- echo "Warning \$%%PORTNAME%%_flags includes --config option." \
- "Please use \$%%PORTNAME%%_config instead."
- ;;
- *--logfile\ *)
- echo "Warning \$%%PORTNAME%%_flags includes --logfile option." \
- "Please use \$%%PORTNAME%%_logfile instead."
- ;;
- *)
- %%PORTNAME%%_flags="${%%PORTNAME%%_flags} --logfile ${%%PORTNAME%%_logfile} --config ${%%PORTNAME%%_config}"
- ;;
-esac
-
run_rc_command "$1"
diff --git a/irc/inspircd/pkg-plist b/irc/inspircd/pkg-plist
index 04adf502a86a..c60448889224 100644
--- a/irc/inspircd/pkg-plist
+++ b/irc/inspircd/pkg-plist
@@ -1,21 +1,22 @@
bin/inspircd
-etc/inspircd/examples/opers.conf.example
-etc/inspircd/examples/modules/modules.conf.unreal
-etc/inspircd/examples/modules/modules.conf.charybdis
-etc/inspircd/examples/modules.conf.example
-etc/inspircd/examples/links.conf.example
-etc/inspircd/examples/inspircd.rules.example
-etc/inspircd/examples/inspircd.quotes.example
-etc/inspircd/examples/inspircd.motd.example
-etc/inspircd/examples/inspircd.helpop.example
-etc/inspircd/examples/inspircd.helpop-full.example
-etc/inspircd/examples/inspircd.filter.example
-etc/inspircd/examples/inspircd.conf.example
-etc/inspircd/examples/inspircd.censor.example
-etc/inspircd/examples/aliases/neostats.conf.example
-etc/inspircd/examples/aliases/ircservices.conf.example
-etc/inspircd/examples/aliases/atheme.conf.example
-etc/inspircd/examples/aliases/anope.conf.example
+%%ETCDIR%%/examples/aliases/anope.conf.example
+%%ETCDIR%%/examples/aliases/atheme.conf.example
+%%ETCDIR%%/examples/aliases/ircservices.conf.example
+%%ETCDIR%%/examples/aliases/neostats.conf.example
+%%ETCDIR%%/examples/censor.conf.example
+%%ETCDIR%%/examples/filter.conf.example
+%%ETCDIR%%/examples/helpop-full.conf.example
+%%ETCDIR%%/examples/helpop.conf.example
+%%ETCDIR%%/examples/inspircd.conf.example
+%%ETCDIR%%/examples/links.conf.example
+%%ETCDIR%%/examples/modules.conf.example
+%%ETCDIR%%/examples/modules/charybdis.conf.example
+%%ETCDIR%%/examples/modules/unrealircd.conf.example
+%%ETCDIR%%/examples/motd.txt.example
+%%ETCDIR%%/examples/opermotd.txt.example
+%%ETCDIR%%/examples/opers.conf.example
+%%ETCDIR%%/examples/quotes.txt.example
+%%ETCDIR%%/examples/rules.txt.example
lib/inspircd/.gdbargs
lib/inspircd/inspircd
lib/inspircd/modules/cmd_admin.so
@@ -170,7 +171,6 @@ lib/inspircd/modules/m_permchannels.so
lib/inspircd/modules/m_randquote.so
lib/inspircd/modules/m_redirect.so
lib/inspircd/modules/m_regex_glob.so
-lib/inspircd/modules/m_regex_posix.so
lib/inspircd/modules/m_regonlycreate.so
lib/inspircd/modules/m_remove.so
lib/inspircd/modules/m_restrictchans.so
@@ -225,45 +225,25 @@ lib/inspircd/modules/m_userip.so
lib/inspircd/modules/m_vhost.so
lib/inspircd/modules/m_watch.so
lib/inspircd/modules/m_xline_db.so
-@dirrm etc/inspircd/examples/aliases
-@dirrm etc/inspircd/examples/modules
-@dirrm etc/inspircd/examples
+@dirrmtry etc/inspircd/examples/aliases
+@dirrmtry etc/inspircd/examples/modules
+@dirrmtry etc/inspircd/examples
+@dirrmtry etc/inspircd
@dirrm lib/inspircd/modules
@dirrm lib/inspircd/logs
@dirrm lib/inspircd/data
@dirrm lib/inspircd
-@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.censor.example %D/%%ETCDIR%%/inspircd.censor; then rm -f %D/%%ETCDIR%%/inspircd.censor; fi
-%%ETCDIR%%/examples/inspircd.censor.example
-@exec if [ ! -f %B/inspircd.censor ] ; then cp -p %D/%F %B/inspircd.censor; fi
+@unexec if cmp -s %D/%%ETCDIR%%/examples/censor.conf.example %D/%%ETCDIR%%/censor.conf; then rm -f %D/%%ETCDIR%%/censor.conf; fi
+@unexec if cmp -s %D/%%ETCDIR%%/examples/filter.conf.example %D/%%ETCDIR%%/filter.conf; then rm -f %D/%%ETCDIR%%/filter.conf; fi
+@unexec if cmp -s %D/%%ETCDIR%%/examples/helpop-full.conf.example %D/%%ETCDIR%%/helpop-full.conf; then rm -f %D/%%ETCDIR%%/helpop-full.conf; fi
+@unexec if cmp -s %D/%%ETCDIR%%/examples/helpop.conf.example %D/%%ETCDIR%%/helpop.conf; then rm -f %D/%%ETCDIR%%/helpop.conf; fi
@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.conf.example %D/%%ETCDIR%%/inspircd.conf; then rm -f %D/%%ETCDIR%%/inspircd.conf; fi
-%%ETCDIR%%/examples/inspircd.conf.example
-@exec if [ ! -f %B/inspircd.conf ] ; then cp -p %D/%F %B/inspircd.conf; fi
-@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.filter.example %D/%%ETCDIR%%/inspircd.filter; then rm -f %D/%%ETCDIR%%/inspircd.filter; fi
-%%ETCDIR%%/examples/inspircd.filter.example
-@exec if [ ! -f %B/inspircd.filter ] ; then cp -p %D/%F %B/inspircd.filter; fi
-@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.helpop.example %D/%%ETCDIR%%/inspircd.helpop; then rm -f %D/%%ETCDIR%%/inspircd.helpop; fi
-%%ETCDIR%%/examples/inspircd.helpop.example
-@exec if [ ! -f %B/inspircd.helpop ] ; then cp -p %D/%F %B/inspircd.helpop; fi
-@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.helpop-full.example %D/%%ETCDIR%%/inspircd.helpop-full; then rm -f %D/%%ETCDIR%%/inspircd.helpop-full; fi
-%%ETCDIR%%/examples/inspircd.helpop-full.example
-@exec if [ ! -f %B/inspircd.helpop-full ] ; then cp -p %D/%F %B/inspircd.helpop-full; fi
-@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.motd.example %D/%%ETCDIR%%/inspircd.motd; then rm -f %D/%%ETCDIR%%/inspircd.motd; fi
-%%ETCDIR%%/examples/inspircd.motd.example
-@exec if [ ! -f %B/inspircd.motd ] ; then cp -p %D/%F %B/inspircd.motd; fi
-@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.quotes.example %D/%%ETCDIR%%/inspircd.quotes; then rm -f %D/%%ETCDIR%%/inspircd.quotes; fi
-%%ETCDIR%%/examples/inspircd.quotes.example
-@exec if [ ! -f %B/inspircd.quotes ] ; then cp -p %D/%F %B/inspircd.quotes; fi
-@unexec if cmp -s %D/%%ETCDIR%%/examples/inspircd.rules.example %D/%%ETCDIR%%/inspircd.rules; then rm -f %D/%%ETCDIR%%/inspircd.rules; fi
-%%ETCDIR%%/examples/inspircd.rules.example
-@exec if [ ! -f %B/inspircd.rules ] ; then cp -p %D/%F %B/inspircd.rules; fi
@unexec if cmp -s %D/%%ETCDIR%%/examples/links.conf.example %D/%%ETCDIR%%/links.conf; then rm -f %D/%%ETCDIR%%/links.conf; fi
-%%ETCDIR%%/examples/links.conf.example
-@exec if [ ! -f %B/links.conf ] ; then cp -p %D/%F %B/links.conf; fi
@unexec if cmp -s %D/%%ETCDIR%%/examples/modules.conf.example %D/%%ETCDIR%%/modules.conf; then rm -f %D/%%ETCDIR%%/modules.conf; fi
-%%ETCDIR%%/examples/modules.conf.example
-@exec if [ ! -f %B/modules.conf ] ; then cp -p %D/%F %B/modules.conf; fi
+@unexec if cmp -s %D/%%ETCDIR%%/examples/motd.txt.example %D/%%ETCDIR%%/motd.txt; then rm -f %D/%%ETCDIR%%/motd.txt; fi
+@unexec if cmp -s %D/%%ETCDIR%%/examples/opermotd.txt.example %D/%%ETCDIR%%/opermotd.txt; then rm -f %D/%%ETCDIR%%/opermotd.txt; fi
@unexec if cmp -s %D/%%ETCDIR%%/examples/opers.conf.example %D/%%ETCDIR%%/opers.conf; then rm -f %D/%%ETCDIR%%/opers.conf; fi
-%%ETCDIR%%/examples/opers.conf.example
-@exec if [ ! -f %B/opers.conf ] ; then cp -p %D/%F %B/opers.conf; fi
-@dirrmtry %%ETCDIR%%
+@unexec if cmp -s %D/%%ETCDIR%%/examples/quotes.txt.example %D/%%ETCDIR%%/quotes.txt; then rm -f %D/%%ETCDIR%%/quotes.txt; fi
+@unexec if cmp -s %D/%%ETCDIR%%/examples/rules.txt.example %D/%%ETCDIR%%/rules.txt; then rm -f %D/%%ETCDIR%%/rules.txt; fi
@unexec echo "If permanently removing software, you may wish to remove the configuration directory by running \"rm -rf %%LOCALBASE%%/%%ETCDIR%%\""
+@exec for FILE in censor.conf filter.conf helpop-full.conf helpop.conf inspircd.conf links.conf modules.conf motd.txt opermotd.txt opers.conf quotes.txt rules.txt; do if [ ! -f %D/%%ETCDIR%%/${FILE} ]; then install %D/%%ETCDIR%%/examples/${FILE}.example %D/%%ETCDIR%%/${FILE}; fi; done