aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn-Mark Gurney <jmg@FreeBSD.org>2014-11-13 02:19:55 +0000
committerJohn-Mark Gurney <jmg@FreeBSD.org>2014-11-13 02:19:55 +0000
commit1b24dbfd6443381c02ca8bee1a74c958501278f7 (patch)
treed0d6031bcf8ffe4cb3b741cb678937fd510d7447
parentfddcea79ccd48d721a2a7a22e6d73468886c6bc1 (diff)
downloadports-1b24dbfd6443381c02ca8bee1a74c958501278f7.tar.gz
ports-1b24dbfd6443381c02ca8bee1a74c958501278f7.zip
add the tcpcrypt port... This provides an implementation of the
tcpcrypt protocol which tries to encrypt your tcp traffic w/o modification... www.tcpcrypt.org for more info.. Approved by: bdrewery
Notes
Notes: svn path=/head/; revision=372508
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--security/Makefile1
-rw-r--r--security/tcpcrypt/Makefile26
-rw-r--r--security/tcpcrypt/distinfo2
-rw-r--r--security/tcpcrypt/files/patch-unix.c17
-rw-r--r--security/tcpcrypt/pkg-descr11
-rw-r--r--security/tcpcrypt/pkg-plist10
8 files changed, 69 insertions, 0 deletions
diff --git a/GIDs b/GIDs
index 85aebeb3e39d..3fef0365e428 100644
--- a/GIDs
+++ b/GIDs
@@ -223,6 +223,7 @@ dotlrn:*:821:
polw:*:825:
statsd:*:826:
netdisco:*:840:
+tcpcryptd:*:841:
munin:*:842:
dahdi:*:843:asterisk
fossy:*:901:www
diff --git a/UIDs b/UIDs
index 0ca3fb1646f1..1f7c5093219f 100644
--- a/UIDs
+++ b/UIDs
@@ -229,6 +229,7 @@ dotlrn:*:821:821::0:0:.LRN Daemon User:/nonexistent:/usr/sbin/nologin
polw:*:825:825::0:0:Policyd-weight Cache Owner:/nonexistent:/sbin/nologin
statsd:*:826:826::0:0:Statsd Daemon:/nonexistent:/sbin/nologin
netdisco:*:840:840::0:0:netdisco daemon:/nonexistent:/usr/sbin/nologin
+tcpcryptd:*:841:841::0:0:tcpcrypt daemon:/nonexistent:/usr/sbin/nologin
munin:*:842:842::0:0:Munin:/var/munin:/usr/sbin/nologin
fossy:*:901:901::0:0:FOSSology user:/usr/local/share/fossology:/usr/local/bin/bash
scanlogd:*:902:902::0:0:scanlogd user:/nonexistent:/usr/sbin/nologin
diff --git a/security/Makefile b/security/Makefile
index 1dab1b6c551d..9f4bc6627ff5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -981,6 +981,7 @@
SUBDIR += switzerland
SUBDIR += symbion-sslproxy
SUBDIR += tclsasl
+ SUBDIR += tcpcrypt
SUBDIR += tinc
SUBDIR += tinyca
SUBDIR += tlswrap
diff --git a/security/tcpcrypt/Makefile b/security/tcpcrypt/Makefile
new file mode 100644
index 000000000000..41de10f6f63c
--- /dev/null
+++ b/security/tcpcrypt/Makefile
@@ -0,0 +1,26 @@
+# Created by: John-Mark Gurney <jmg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tcpcrypt
+DISTVERSION= 0.3.rc1
+CATEGORIES= security net
+
+MAINTAINER= jmg@FreeBSD.org
+COMMENT= TCPCrypt userland divert daemon
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= scslab
+GH_TAGNAME= v0.3-rc1
+GH_COMMIT= b110e7e
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= autoreconf libtool
+INSTALL_TARGET= install-strip
+
+USERS= tcpcryptd
+GROUPS= tcpcryptd
+
+.include <bsd.port.mk>
diff --git a/security/tcpcrypt/distinfo b/security/tcpcrypt/distinfo
new file mode 100644
index 000000000000..9a7559141ea8
--- /dev/null
+++ b/security/tcpcrypt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tcpcrypt-0.3.rc1.tar.gz) = da184da7b702cadeaec670f09e34af8d41be84d81ad253f4d977aaaa576da865
+SIZE (tcpcrypt-0.3.rc1.tar.gz) = 183047
diff --git a/security/tcpcrypt/files/patch-unix.c b/security/tcpcrypt/files/patch-unix.c
new file mode 100644
index 000000000000..c0a428315159
--- /dev/null
+++ b/security/tcpcrypt/files/patch-unix.c
@@ -0,0 +1,17 @@
+--- src/unix.c.orig 2014-09-10 16:22:26.000000000 -0700
++++ src/unix.c 2014-10-31 23:59:29.000000000 -0700
+@@ -57,7 +57,13 @@
+ s_in.sin_addr = ip->ip_dst;
+ s_in.sin_port = tcp->th_dport;
+
+-#if defined(__FreeBSD__) || defined(__DARWIN_UNIX03)
++#if defined(__FreeBSD__)
++#include <osreldate.h>
++#if __FreeBSD_version < 1000022
++ #define HO_LEN
++#endif
++#endif
++#ifdef __DARWIN_UNIX03
+ #define HO_LEN
+ #endif
+ #ifdef HO_LEN
diff --git a/security/tcpcrypt/pkg-descr b/security/tcpcrypt/pkg-descr
new file mode 100644
index 000000000000..c31af0022c18
--- /dev/null
+++ b/security/tcpcrypt/pkg-descr
@@ -0,0 +1,11 @@
+Tcpcrypt is a protocol that attempts to encrypt (almost) all of your
+network traffic. Unlike other security mechanisms, Tcpcrypt works out
+of the box: it requires no configuration, no changes to applications,
+and your network connections will continue to work even if the remote
+end does not support Tcpcrypt, in which case connections will
+gracefully fall back to standard clear-text TCP. Install Tcpcrypt and
+you'll feel no difference in your every day user experience, but yet
+your traffic will be more secure and you'll have made life much harder
+for hackers.
+
+WWW: http://www.tcpcrypt.org/
diff --git a/security/tcpcrypt/pkg-plist b/security/tcpcrypt/pkg-plist
new file mode 100644
index 000000000000..5c6d454c7174
--- /dev/null
+++ b/security/tcpcrypt/pkg-plist
@@ -0,0 +1,10 @@
+bin/tcnetstat
+bin/tcpcryptd
+include/tcpcrypt/socket_address.h
+include/tcpcrypt/tcpcrypt.h
+lib/libtcpcrypt.a
+lib/libtcpcrypt.so
+lib/libtcpcrypt.so.0
+lib/libtcpcrypt.so.0.0.0
+man/man8/tcnetstat.8.gz
+man/man8/tcpcryptd.8.gz