aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-12-31 08:31:38 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-12-31 08:31:38 +0000
commit1b3dcfd48f3358c08f68dae7955fa76aa2141354 (patch)
tree63e7766d046ff0882e128c09775269f45e28d1ef
parent3db3e940025b29de10df84e6fd4e5092c44f9b99 (diff)
downloadports-1b3dcfd48f3358c08f68dae7955fa76aa2141354.tar.gz
ports-1b3dcfd48f3358c08f68dae7955fa76aa2141354.zip
Notes
-rw-r--r--dns/bind9-dlz/Makefile261
-rw-r--r--dns/bind9-dlz/distinfo15
-rw-r--r--dns/bind9-dlz/files/configure.bind9-dlz85
-rw-r--r--dns/bind9-dlz/files/db42-bind922.patch39
-rw-r--r--dns/bind9-dlz/files/db42-bind931.patch47
-rw-r--r--dns/bind9-dlz/files/dlz_postgres_driver.c.diff21
-rw-r--r--dns/bind9-dlz/files/postgres.patch134
-rw-r--r--dns/bind9-dlz/pkg-descr6
-rw-r--r--dns/bind9-dlz/pkg-plist232
9 files changed, 0 insertions, 840 deletions
diff --git a/dns/bind9-dlz/Makefile b/dns/bind9-dlz/Makefile
deleted file mode 100644
index ef10ecf2199f..000000000000
--- a/dns/bind9-dlz/Makefile
+++ /dev/null
@@ -1,261 +0,0 @@
-# New ports collection makefile for: bind-dlz
-# Date Created: 08 Jun 2002
-# Whom: dirk.meyer@dinoex.sub.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= bind9
-PORTVERSION= ${ISCVERSION}+${DLZVERSION}
-PORTREVISION= 1
-CATEGORIES= dns ipv6
-MASTER_SITES= ${MASTER_SITE_ISC} \
- ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,dns/bind9/${ISCVERSION},} \
- ${MASTER_SITES_DLZ:S/$/:dlz/}
-MASTER_SITE_SUBDIR= bind9/${ISCVERSION} bind-dlz/:dlz
-PKGNAMESUFFIX?= -dlz${POSTGRESQL_SUFFIX}${MYSQL_SUFFIX}${BERKLEYDB_SUFFIX}${LDAP_SUFFIX}${PKGNAMESUFFIX2}
-DISTFILES= bind-${ISCVERSION}.tar.gz
-
-PATCH_SITES= ${MASTER_SITES} http://projects.navynet.it/DLZ/:it
-PATCH_SITE_SUBDIR= bind9/${ISCVERSION}
-PATCHFILES=
-PATCH_DIST_STRIP= -p1
-
-MAINTAINER= dinoex@FreeBSD.org
-COMMENT= The Berkeley Internet Name Daemon, with DLZ extensions
-
-FORBIDDEN= vulnerable to cache poisioning if recursive lookup enabled
-DEPRECATED= DLZ functions are now included in bind9.4
-EXPIRATION_DATE=2008-08-31
-
-CONFLICTS?= bind9-9.* bind9-sdb-ldap-* host-* skalibs-*
-MASTER_SITES_DLZ= ${MASTER_SITE_SOURCEFORGE}
-
-DLZVERSION= 0.7.0
-USE_SUBMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps --with-openssl \
- --with-randomdev=/dev/random
-PATCH_STRIP= -p1
-
-# use user config if possible
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
-.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
-.else
-.if defined(BATCH)
-# default package, can be configured in /etc/make.conf
-BINDDLZ_OPTIONS?= \"Threads\" \"OpenSSL\" \"PostgreSQL\" \"FileSystem\"
-.if ${BINDDLZ_OPTIONS:M*PostgreSQL*}
-WITH_POSTGRESQL_DRIVER=yes
-.endif
-.if ${BINDDLZ_OPTIONS:M*MySQL*}
-WITH_MYSQL_DRIVER=yes
-.endif
-.if ${BINDDLZ_OPTIONS:M*BerkleyDB*}
-WITH_BERKLEYDB_DRIVER=yes
-.endif
-.if ${BINDDLZ_OPTIONS:M*OpenLDAP*}
-WITH_LDAP=yes
-.endif
-.endif
-# make INDEX match
-NO_DESCRIBE=yes
-.endif
-
-.if defined(WITH_DLZ_OLD)
-ISCVERSION= 9.2.2
-DISTFILES+= DLZ-${DLZVERSION}${EXTRACT_SUFX}:dlz
-PATCHFILES+= patch.9.2.2-P1
-PLIST_SUB+= BIND922="" BIND931="@comment "
-EXTRA_PATCHES+= ${WRKDIR}/dlz.patch ${FILESDIR}/db42-bind922.patch
-.else
-ISCVERSION= 9.3.2
-PATCHFILES+= ctrix_dlz_${ISCVERSION}-1.patch.gz:it
-EXTRA_PATCHES+= ${FILESDIR}/db42-bind931.patch
-PLIST_SUB+= BIND931="" BIND922="@comment "
-.endif
-
-.if defined(WITH_POSTGRESQL_DRIVER)
-.if !defined(WITHOUT_POSTGRESQL_DRIVER)
-POSTGRESQL_SUFFIX= +postgres
-EXTRA_PATCHES+= ${FILESDIR}/postgres.patch
-USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-dlz-postgres
-.endif
-.endif
-
-.if defined(WITH_MYSQL_DRIVER)
-MYSQL_SUFFIX= +mysql
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-dlz-mysql
-.endif
-
-.if defined(WITH_LDAP)
-LDAP_SUFFIX= +ldap
-WITH_OPENLDAP_VER?= 23
-CONFIGURE_ARGS+= --with-dlz-ldap
-.endif
-
-.if defined(WITH_BERKLEYDB_DRIVER)
-WITH_BDB= yes
-.endif
-
-.if defined(WITH_BDB)
-BERKLEYDB_SUFFIX= +db4
-USE_BDB= yes
-IGNORE_WITH_BDB= 2 3 40
-OBSOLETE_BDB_VAR= BERKLEYDB_PORT BERKLEYDB_LIB
-BERKLEYDB_SUFFIX= +${BDB_INCLUDE_DIR:S,^${LOCALBASE}/include/,,}
-CONFIGURE_ARGS+= --with-dlz-bdb=${LOCALBASE}
-.endif
-
-.if defined(WITH_FILESYSTEM_DRIVER)
-.if !defined(WITHOUT_FILESYSTEM_DRIVER)
-CONFIGURE_ARGS+= --with-dlz-filesystem
-.endif
-.endif
-
-.if defined(WITH_STUB_DRIVER)
-CONFIGURE_ARGS+= --with-dlz-stub
-.endif
-
-.if defined(WITH_OPENSSL)
-.if !defined(WITHOUT_OPENSSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-.endif
-
-WRKSRC= ${WRKDIR}/bind-${ISCVERSION}
-PLIST= ${WRKDIR}/.PLIST.more
-PLIST_SUB+= EXTRA_DOCSDIR=${EXTRA_DOCSDIR}
-
-SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
- CURDIR2="${.CURDIR}" \
- MKDIR="${MKDIR}" \
- DISTNAME="${DISTNAME}" \
- BINDDLZ_OPTIONS="${BINDDLZ_OPTIONS}"
-
-DOCSDIR= ${PREFIX}/share/doc/bind9
-EXTRA_DOCSDIR= share/doc/bind9-dlz
-DOCS= README.txt bind_dlz.txt changelog.txt dlz.schema \
- dlz_interface.txt sdlz_helper.txt sdlz_interface.txt
-
-MAN1= dig.1 host.1
-MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
- lwres_buffer_back.3 lwres_buffer_clear.3 lwres_buffer_first.3 \
- lwres_buffer_forward.3 lwres_buffer_getmem.3 lwres_buffer_getuint16.3 \
- lwres_buffer_getuint32.3 lwres_buffer_getuint8.3 lwres_buffer_init.3 \
- lwres_buffer_invalidate.3 lwres_buffer_putmem.3 \
- lwres_buffer_putuint16.3 lwres_buffer_putuint32.3 \
- lwres_buffer_putuint8.3 lwres_buffer_subtract.3 lwres_conf_clear.3 \
- lwres_conf_get.3 lwres_conf_init.3 lwres_conf_parse.3 \
- lwres_conf_print.3 lwres_config.3 lwres_context.3 \
- lwres_context_allocmem.3 lwres_context_create.3 \
- lwres_context_destroy.3 lwres_context_freemem.3 \
- lwres_context_initserial.3 lwres_context_nextserial.3 \
- lwres_context_sendrecv.3 lwres_endhostent.3 lwres_endhostent_r.3 \
- lwres_freeaddrinfo.3 lwres_freehostent.3 lwres_gabn.3 \
- lwres_gabnrequest_free.3 lwres_gabnrequest_parse.3 \
- lwres_gabnrequest_render.3 lwres_gabnresponse_free.3 \
- lwres_gabnresponse_parse.3 lwres_gabnresponse_render.3 \
- lwres_gai_strerror.3 lwres_getaddrinfo.3 lwres_getaddrsbyname.3 \
- lwres_gethostbyaddr.3 lwres_gethostbyaddr_r.3 lwres_gethostbyname.3 \
- lwres_gethostbyname2.3 lwres_gethostbyname_r.3 lwres_gethostent.3 \
- lwres_gethostent_r.3 lwres_getipnode.3 lwres_getipnodebyaddr.3 \
- lwres_getipnodebyname.3 lwres_getnamebyaddr.3 lwres_getnameinfo.3 \
- lwres_getrrsetbyname.3 lwres_gnba.3 lwres_gnbarequest_free.3 \
- lwres_gnbarequest_parse.3 lwres_gnbarequest_render.3 \
- lwres_gnbaresponse_free.3 lwres_gnbaresponse_parse.3 \
- lwres_gnbaresponse_render.3 lwres_herror.3 lwres_hstrerror.3 \
- lwres_inetntop.3 lwres_lwpacket_parseheader.3 \
- lwres_lwpacket_renderheader.3 lwres_net_ntop.3 lwres_noop.3 \
- lwres_nooprequest_free.3 lwres_nooprequest_parse.3 \
- lwres_nooprequest_render.3 lwres_noopresponse_free.3 \
- lwres_noopresponse_parse.3 lwres_noopresponse_render.3 \
- lwres_packet.3 lwres_resutil.3 lwres_sethostent.3 \
- lwres_sethostent_r.3 lwres_string_parse.3
-.if defined(WITH_DLZ_OLD)
-MAN1= dig.1 host.1
-MAN5= rndc.conf.5
-MAN8= dnssec-keygen.8 dnssec-makekeyset.8 dnssec-signkey.8 dnssec-signzone.8 \
- lwresd.8 named-checkconf.8 named-checkzone.8 named.8 nsupdate.8 \
- rndc-confgen.8 rndc.8
-.else
-MAN1= dig.1 host.1 nslookup.1
-MAN5= named.conf.5 rndc.conf.5
-MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
- named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
-.endif
-
-pre-fetch:
- @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.bind9-dlz
-
-.if defined(WITH_BDB)
-post-patch:
- @${REINPLACE_CMD} -e 's#db-4.2#${BDB_LIB_NAME}#g' \
- -e 's#db42#${BDB_INCLUDE_DIR:S,^${LOCALBASE}/include/,,}#g' \
- ${WRKSRC}/configure
-.endif
-
-pre-configure:
-.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.8 \
- rndc/rndc.8
- ${REINPLACE_CMD} -e 's#/etc/named.conf#${PREFIX}/etc/named.conf#g' \
- -e 's#/etc/rndc.conf#${PREFIX}/etc/rndc.conf#g' \
- ${WRKSRC}/bin/${FILE}
-.endfor
- ${MV} -f ${WRKSRC}/bin/Makefile.in.orig ${WRKSRC}/bin/Makefile.in
- @${ECHO_CMD} "configure: ${CONFIGURE_ARGS}"
- ${REINPLACE_CMD} -e "s=-lnsl==" \
- -e 's=-pthread=${PTHREAD_LIBS}=' \
- ${WRKSRC}/configure
- ${CHMOD} +x ${WRKSRC}/configure
-
-pre-install:
- ${CAT} ${MASTERDIR}/pkg-plist >${PLIST}
-.if !defined(NOPORTDOCS)
-.if defined(WITH_DLZ_OLD)
-.for i in ${DOCS}
- @${ECHO_CMD} `${BASENAME} ${i}` | \
- ${SED} -e "s=^=%%EXTRA_DOCSDIR%%/=" >>${PLIST}
-.endfor
- @${ECHO_CMD} "@dirrm %%EXTRA_DOCSDIR%%" >>${PLIST}
-.endif
-.endif
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
- ${PREFIX}/etc/rndc.conf.sample
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/arm ${DOCSDIR}/misc
- ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM*html ${DOCSDIR}/arm
- ${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* ${DOCSDIR}/misc
- ${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
- ${WRKSRC}/README ${DOCSDIR}/
-.if defined(WITH_DLZ_OLD)
- ${MKDIR} ${PREFIX}/${EXTRA_DOCSDIR}
- @cd ${WRKDIR} && ${INSTALL_DATA} ${DOCS} ${PREFIX}/${EXTRA_DOCSDIR}/
-.endif
-.endif
-
-.if defined(WITH_BIND9_THREADS)
-CONFIGURE_ARGS+= --enable-threads
-.else
-CONFIGURE_ARGS+= --disable-threads
-.endif
-
-post-clean:
- @ ${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-
-.include <bsd.port.pre.mk>
-
-.if defined(NO_DESCRIBE)
-describe:
-.if defined(BATCH)
- @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.bind9-dlz
-.endif
- @cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} BATCH=yes ${.TARGET}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/dns/bind9-dlz/distinfo b/dns/bind9-dlz/distinfo
deleted file mode 100644
index 26ea5d3f4db3..000000000000
--- a/dns/bind9-dlz/distinfo
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 (bind-9.2.2.tar.gz) = 6ea7d64a0856893ab3eb541ab7bbc725
-SHA256 (bind-9.2.2.tar.gz) = afdcc5477c042e1cae38f1ba3f1ab248252348befce05e4accbb81b67a193886
-SIZE (bind-9.2.2.tar.gz) = 5054652
-MD5 (DLZ-0.7.0.tar.gz) = 2095ceb0be6f86d6ac7e0990a04d08de
-SHA256 (DLZ-0.7.0.tar.gz) = 44e425c12182a4986f390d66dc2e5be08b7f7cfca0f61abea17f7b00e09d354e
-SIZE (DLZ-0.7.0.tar.gz) = 249768
-MD5 (patch.9.2.2-P1) = 063edc41c756ffc6a1051d5f1937fa2c
-SHA256 (patch.9.2.2-P1) = 2d9b3e11d6dffde6a7a0954f88063f7793c21dd5d8bc69e671f56fd02af54321
-SIZE (patch.9.2.2-P1) = 40087
-MD5 (bind-9.3.2.tar.gz) = 55e709501a7780233c36e25ccd15ece2
-SHA256 (bind-9.3.2.tar.gz) = 4d4298abd85d06083a0643091dde05ffbe3db051439524dbe4a81c689735c694
-SIZE (bind-9.3.2.tar.gz) = 5302112
-MD5 (ctrix_dlz_9.3.2-1.patch.gz) = 385bf357af6a055980f65d7e153d8bc1
-SHA256 (ctrix_dlz_9.3.2-1.patch.gz) = df8a115b74280a972f6983e4c0393c3cd24516e10c8b2c3012865e402b1b18c8
-SIZE (ctrix_dlz_9.3.2-1.patch.gz) = 167339
diff --git a/dns/bind9-dlz/files/configure.bind9-dlz b/dns/bind9-dlz/files/configure.bind9-dlz
deleted file mode 100644
index 1258df33257f..000000000000
--- a/dns/bind9-dlz/files/configure.bind9-dlz
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-if [ -f ${WRKDIRPREFIX}${CURDIR2}/Makefile.inc ]; then
- exit
-fi
-
-if [ "${BINDDLZ_OPTIONS}" ]; then
- set ${BINDDLZ_OPTIONS}
-else
- dialog --title "configuration options" --clear \
- --checklist "\n\
-Please select desired options:" -1 -1 12 \
-OldDLZ "use old Bind9.2.2" OFF \
-OpenSSL "OpenSSL support" ON \
-Threads "Thread support" ON \
-PostgreSQL "PostgreSQL driver" ON \
-MySQL "MySQL driver" OFF \
-OpenLDAP "OpenLDAP backend" OFF \
-BerkleyDB "Berkley DB 4.1+ backend" OFF \
-FileSystem "Filesystem driver" ON \
-Stub "Stub driver" OFF \
-2> /tmp/checklist.tmp.$$
-
- retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
- fi
- rm -f /tmp/checklist.tmp.$$
-
- case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
- esac
-fi
-
-${MKDIR} ${WRKDIRPREFIX}${CURDIR2}
-exec > ${WRKDIRPREFIX}${CURDIR2}/Makefile.inc
-
-while [ "$1" ]; do
- case $1 in
- \"OldDLZ\")
- echo WITH_DLZ_OLD=YES
- ;;
- \"OpenSSL\")
- echo WITH_OPENSSL=YES
- ;;
- \"Threads\")
- echo WITH_BIND9_THREADS=YES
- ;;
- \"PostgreSQL\")
- echo WITH_POSTGRESQL_DRIVER=YES
- ;;
- \"MySQL\")
- echo WITH_MYSQL_DRIVER=YES
- ;;
- \"OpenLDAP\")
- echo WITH_LDAP=YES
- ;;
- \"BerkleyDB\")
- echo WITH_BDB=YES
- ;;
- \"FileSystem\")
- echo WITH_FILESYSTEM_DRIVER=YES
- ;;
- \"Stub\")
- echo WITH_STUB_DRIVER=YES
- ;;
- \"nothing\"|true)
- ;;
- *)
- echo "Invalid option(s): $*" > /dev/stderr
- rm -f ${WRKDIRPREFIX}${CURDIR2}/Makefile.inc
- exit 1
- ;;
- esac
- shift
-done
-exec > /dev/stderr
diff --git a/dns/bind9-dlz/files/db42-bind922.patch b/dns/bind9-dlz/files/db42-bind922.patch
deleted file mode 100644
index 536d84cbb8b9..000000000000
--- a/dns/bind9-dlz/files/db42-bind922.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- configure.orig Mon Nov 28 23:50:21 2005
-+++ configure Mon Nov 28 23:54:39 2005
-@@ -2441,7 +2441,7 @@
- DLZ_BDB_LIB="yes"
-
- # check other locations for includes.
-- bdb_incdirs="/ /db41/ /db4/ /db/"
-+ bdb_incdirs="/ /db42/ /db41/ /db4/ /db/"
- for d in $bdb_incdirs
- do
- if test -f $use_dlz_bdb/include${d}db.h
-@@ -2455,23 +2455,24 @@
- then
- echo "$ac_t""not found" 1>&6
- { echo "configure: error: Berkeley DB header was not found in $use_dlz_bdb/include, \
--$use_dlz_bdb/include/db41, $use_dlz_bdb/include/db4 or $use_dlz_bdb/include/db" 1>&2; exit 1; }
-+$use_dlz_bdb/include/db42 $use_dlz_bdb/include/db41, $use_dlz_bdb/include/db4 or $use_dlz_bdb/include/db" 1>&2; exit 1; }
- fi
-
- # look for libname other than libdb.so
-- bdb_libnames="db41 db-4.1 db"
-+ bdb_libnames="db-4.2 db41 db-4.1 db"
- for d in $bdb_libnames
- do
- if test -f $use_dlz_bdb/lib/lib${d}.so
- then
- DLZ_BDB_LIB="-l${d}"
-+ break
- fi
- done
-
- if test "$DLZ_BDB_LIB" = "yes"
- then
- echo "$ac_t""not found" 1>&6
-- { echo "configure: error: Berkeley DB library libdb41.so, libdb-4.1.so or libdb.so could not be found \
-+ { echo "configure: error: Berkeley DB library libdb-4.2.so libdb41.so, libdb-4.1.so or libdb.so could not be found \
- in $use_dlz_bdb/lib" 1>&2; exit 1; }
- fi
-
diff --git a/dns/bind9-dlz/files/db42-bind931.patch b/dns/bind9-dlz/files/db42-bind931.patch
deleted file mode 100644
index 330dfaee818e..000000000000
--- a/dns/bind9-dlz/files/db42-bind931.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- configure.orig Sat Nov 26 23:30:45 2005
-+++ configure Sat Nov 26 23:33:43 2005
-@@ -4919,7 +4919,7 @@
- DLZ_BDB_LIB="yes"
-
- # check other locations for includes.
-- bdb_incdirs="/ /db41/ /db4/ /db/"
-+ bdb_incdirs="/ /db42/ /db41/ /db4/ /db/"
- for d in $bdb_incdirs
- do
- if test -f $use_dlz_bdb/include${d}db.h
-@@ -4934,19 +4934,20 @@
- echo "$as_me:$LINENO: result: not found" >&5
- echo "${ECHO_T}not found" >&6
- { { echo "$as_me:$LINENO: error: Berkeley DB header was not found in $use_dlz_bdb/include, \
--$use_dlz_bdb/include/db41, $use_dlz_bdb/include/db4 or $use_dlz_bdb/include/db" >&5
-+$use_dlz_bdb/include/db42, $use_dlz_bdb/include/db41, $use_dlz_bdb/include/db4 or $use_dlz_bdb/include/db" >&5
- echo "$as_me: error: Berkeley DB header was not found in $use_dlz_bdb/include, \
--$use_dlz_bdb/include/db41, $use_dlz_bdb/include/db4 or $use_dlz_bdb/include/db" >&2;}
-+$use_dlz_bdb/include/db42, $use_dlz_bdb/include/db41, $use_dlz_bdb/include/db4 or $use_dlz_bdb/include/db" >&2;}
- { (exit 1); exit 1; }; }
- fi
-
- # look for libname other than libdb.so
-- bdb_libnames="db41 db-4.1 db"
-+ bdb_libnames="db-4.2 db42 db41 db-4.1 db"
- for d in $bdb_libnames
- do
- if test -f $use_dlz_bdb/lib/lib${d}.so
- then
- DLZ_BDB_LIB="-l${d}"
-+ break
- fi
- done
-
-@@ -4954,9 +4955,9 @@
- then
- echo "$as_me:$LINENO: result: not found" >&5
- echo "${ECHO_T}not found" >&6
-- { { echo "$as_me:$LINENO: error: Berkeley DB library libdb41.so, libdb-4.1.so or libdb.so could not be found \
-+ { { echo "$as_me:$LINENO: error: Berkeley DB library libdb-4.2.so, libdb42.so libdb41.so, libdb-4.1.so, or libdb.so could not be found \
- in $use_dlz_bdb/lib" >&5
--echo "$as_me: error: Berkeley DB library libdb41.so, libdb-4.1.so or libdb.so could not be found \
-+echo "$as_me: error: Berkeley DB library libdb-4.2.so, libdb42.so, libdb41.so, libdb-4.1.so or libdb.so could not be found \
- in $use_dlz_bdb/lib" >&2;}
- { (exit 1); exit 1; }; }
- fi
diff --git a/dns/bind9-dlz/files/dlz_postgres_driver.c.diff b/dns/bind9-dlz/files/dlz_postgres_driver.c.diff
deleted file mode 100644
index d7813efbe260..000000000000
--- a/dns/bind9-dlz/files/dlz_postgres_driver.c.diff
+++ /dev/null
@@ -1,21 +0,0 @@
---- bin/named/dlz_postgres_driver.c.orig Mon Jun 10 05:59:08 2002
-+++ bin/named/dlz_postgres_driver.c Mon Jun 10 05:59:45 2002
-@@ -510,15 +510,15 @@
-
- // free dbi->zone string
- if(dbi->zone != NULL)
-- isc_mem_free(ns_g_mctx, (char *) dbi->zone);
-+ isc_mem_free(ns_g_mctx, dbi->zone);
-
- // free dbi->record string
- if(dbi->record != NULL)
-- isc_mem_free(ns_g_mctx, (char *) dbi->record);
-+ isc_mem_free(ns_g_mctx, dbi->record);
-
- // free dbi->client string
- if(dbi->client != NULL)
-- isc_mem_free(ns_g_mctx, (char *) dbi->client);
-+ isc_mem_free(ns_g_mctx, dbi->client);
-
- #ifdef ISC_PLATFORM_USETHREADS
-
diff --git a/dns/bind9-dlz/files/postgres.patch b/dns/bind9-dlz/files/postgres.patch
deleted file mode 100644
index 037aae961041..000000000000
--- a/dns/bind9-dlz/files/postgres.patch
+++ /dev/null
@@ -1,134 +0,0 @@
---- bind-9.3.2/bin/named/dlz_postgres_driver.c.orig Tue May 23 13:33:45 2006
-+++ bind-9.3.2/bin/named/dlz_postgres_driver.c Tue May 23 13:37:43 2006
-@@ -351,7 +351,7 @@
- REQUIRE(*rs == NULL);
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d Getting DBI", dlz_thread_num);
-
- // get db instance / connection
-@@ -369,7 +369,7 @@
- #endif /* ISC_PLATFORM_USETHREADS */
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d Got DBI - checking query", dlz_thread_num);
-
- // if DBI is null, can't do anything else
-@@ -433,7 +433,7 @@
- }
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d checked query", dlz_thread_num);
-
- // was a zone string passed? If so, make it safe for use in queries.
-@@ -465,7 +465,7 @@
- }
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d did zone", dlz_thread_num);
-
- // was a record string passed? If so, make it safe for use in queries.
-@@ -481,7 +481,7 @@
-
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d did record", dlz_thread_num);
-
- // was a client string passed? If so, make it safe for use in queries.
-@@ -496,7 +496,7 @@
- }
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d did client", dlz_thread_num);
-
- // what type of query are we going to run?
-@@ -526,7 +526,7 @@
- }
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d built query", dlz_thread_num);
-
- // if the querystring is null, Bummer, outta RAM. UPGRADE TIME!!!
-@@ -536,7 +536,7 @@
- }
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d query is '%s'", dlz_thread_num, querystring);
-
- // output the full query string during debug so we can see
-@@ -548,7 +548,7 @@
- // attempt query up to 3 times.
- for(j=0; j < 3; j++){
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d executing query for %d time", dlz_thread_num, j);
- // try to get result set
- *rs = PQexec((PGconn *)dbi->dbconn, querystring );
-@@ -556,7 +556,7 @@
- // if result set is null, reset DB connection, max 3 attempts.
- for(i=0; *rs == NULL && i < 3; i++){
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d resetting connection", dlz_thread_num);
- result = ISC_R_FAILURE;
- PQreset((PGconn *) dbi->dbconn);
-@@ -567,12 +567,12 @@
- // result set ok, break outter loop
- if(PQresultStatus(*rs) == PGRES_TUPLES_OK){
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d rs ok", dlz_thread_num);
- break;
- }else{ // we got a result set object, but it's not right.
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d clearing rs", dlz_thread_num);
- PQclear(*rs); // get rid of it
- result = ISC_R_FAILURE; // incase this was the last attempt
-@@ -582,7 +582,7 @@
- cleanup: // it's always good to cleanup after yourself
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d cleaning up", dlz_thread_num);
-
- // if we couldn't even allocate DBI, just return NULL
-@@ -612,7 +612,7 @@
- #ifdef ISC_PLATFORM_USETHREADS
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d unlocking mutex", dlz_thread_num);
-
- // release the lock so another thread can use this dbi
-@@ -625,7 +625,7 @@
- isc_mem_free(ns_g_mctx, querystring );
-
- //** temporary logging message
--isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_ERROR,
-+isc_log_write(dns_lctx, DNS_LOGCATEGORY_DATABASE, DNS_LOGMODULE_DLZ, ISC_LOG_DEBUG(2),
- "%d returning", dlz_thread_num);
-
- // return result
diff --git a/dns/bind9-dlz/pkg-descr b/dns/bind9-dlz/pkg-descr
deleted file mode 100644
index d1d1a8c28436..000000000000
--- a/dns/bind9-dlz/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-BIND version 9 Nameserver, with DLZ extensions
-
-Add capabilities to Bind 9 that will allow Bind backend databases to support
-adding and removing zones without interrupting normal server operation.
-
-WWW: http://bind-dlz.sourceforge.net/
diff --git a/dns/bind9-dlz/pkg-plist b/dns/bind9-dlz/pkg-plist
deleted file mode 100644
index c76d06150737..000000000000
--- a/dns/bind9-dlz/pkg-plist
+++ /dev/null
@@ -1,232 +0,0 @@
-bin/dig
-bin/host
-bin/isc-config.sh
-bin/nslookup
-bin/nsupdate
-etc/rndc.conf.sample
-%%BIND922%%include/dns/a6.h
-%%BIND931%%include/bind9/check.h
-%%BIND931%%include/bind9/getaddresses.h
-%%BIND931%%include/bind9/version.h
-include/dns/acl.h
-include/dns/adb.h
-include/dns/byaddr.h
-include/dns/cache.h
-include/dns/callbacks.h
-include/dns/cert.h
-include/dns/compress.h
-include/dns/db.h
-include/dns/dbiterator.h
-include/dns/dbtable.h
-include/dns/diff.h
-include/dns/dispatch.h
-include/dns/dnssec.h
-%%BIND931%%include/dns/ds.h
-include/dns/enumclass.h
-include/dns/enumtype.h
-include/dns/events.h
-include/dns/fixedname.h
-include/dns/journal.h
-include/dns/keyflags.h
-include/dns/keytable.h
-include/dns/keyvalues.h
-include/dns/lib.h
-include/dns/log.h
-include/dns/master.h
-include/dns/masterdump.h
-include/dns/message.h
-include/dns/name.h
-include/dns/ncache.h
-%%BIND931%%include/dns/nsec.h
-%%BIND922%%include/dns/nxt.h
-include/dns/peer.h
-%%BIND931%%include/dns/portlist.h
-include/dns/rbt.h
-include/dns/rcode.h
-include/dns/rdata.h
-include/dns/rdataclass.h
-include/dns/rdatalist.h
-include/dns/rdataset.h
-include/dns/rdatasetiter.h
-include/dns/rdataslab.h
-include/dns/rdatastruct.h
-include/dns/rdatatype.h
-include/dns/request.h
-include/dns/resolver.h
-include/dns/result.h
-include/dns/rootns.h
-include/dns/sdb.h
-include/dns/secalg.h
-include/dns/secproto.h
-include/dns/soa.h
-include/dns/ssu.h
-include/dns/tcpmsg.h
-include/dns/time.h
-include/dns/tkey.h
-include/dns/tsig.h
-include/dns/ttl.h
-include/dns/types.h
-include/dns/validator.h
-%%BIND931%%include/dns/version.h
-include/dns/view.h
-include/dns/xfrin.h
-include/dns/zone.h
-include/dns/zonekey.h
-include/dns/zt.h
-include/dst/dst.h
-include/dst/lib.h
-include/dst/result.h
-include/isc/app.h
-include/isc/assertions.h
-include/isc/base64.h
-include/isc/bitstring.h
-include/isc/boolean.h
-include/isc/buffer.h
-include/isc/bufferlist.h
-include/isc/commandline.h
-include/isc/condition.h
-include/isc/dir.h
-include/isc/entropy.h
-include/isc/error.h
-include/isc/event.h
-include/isc/eventclass.h
-include/isc/file.h
-include/isc/formatcheck.h
-include/isc/fsaccess.h
-%%BIND931%%include/isc/hash.h
-include/isc/heap.h
-include/isc/hex.h
-include/isc/hmacmd5.h
-include/isc/int.h
-include/isc/interfaceiter.h
-include/isc/lang.h
-include/isc/lex.h
-include/isc/lfsr.h
-include/isc/lib.h
-include/isc/list.h
-include/isc/log.h
-include/isc/magic.h
-include/isc/md5.h
-include/isc/mem.h
-include/isc/msgcat.h
-include/isc/msgs.h
-include/isc/mutex.h
-include/isc/mutexblock.h
-include/isc/net.h
-include/isc/netaddr.h
-include/isc/netdb.h
-%%BIND931%%include/isc/parseint.h
-include/isc/offset.h
-include/isc/once.h
-include/isc/ondestroy.h
-include/isc/os.h
-include/isc/platform.h
-include/isc/print.h
-include/isc/quota.h
-include/isc/random.h
-include/isc/ratelimiter.h
-include/isc/refcount.h
-include/isc/region.h
-include/isc/resource.h
-include/isc/result.h
-include/isc/resultclass.h
-include/isc/rwlock.h
-include/isc/serial.h
-include/isc/sha1.h
-include/isc/sockaddr.h
-include/isc/socket.h
-include/isc/stdio.h
-%%BIND931%%include/isc/stdlib.h
-include/isc/stdtime.h
-include/isc/string.h
-include/isc/symtab.h
-include/isc/syslog.h
-include/isc/task.h
-include/isc/taskpool.h
-include/isc/thread.h
-include/isc/time.h
-include/isc/timer.h
-include/isc/types.h
-include/isc/util.h
-%%BIND931%%include/isc/version.h
-include/isccc/alist.h
-include/isccc/base64.h
-include/isccc/cc.h
-include/isccc/ccmsg.h
-include/isccc/events.h
-include/isccc/lib.h
-include/isccc/result.h
-include/isccc/sexpr.h
-include/isccc/symtab.h
-include/isccc/symtype.h
-include/isccc/types.h
-include/isccc/util.h
-%%BIND931%%include/isccc/version.h
-include/isccfg/cfg.h
-%%BIND922%%include/isccfg/check.h
-%%BIND931%%include/isccfg/grammar.h
-include/isccfg/log.h
-%%BIND931%%include/isccfg/namedconf.h
-%%BIND931%%include/isccfg/version.h
-include/lwres/context.h
-include/lwres/int.h
-include/lwres/ipv6.h
-include/lwres/lang.h
-include/lwres/list.h
-include/lwres/lwbuffer.h
-include/lwres/lwpacket.h
-include/lwres/lwres.h
-include/lwres/net.h
-include/lwres/netdb.h
-include/lwres/platform.h
-include/lwres/result.h
-%%BIND931%%include/lwres/version.h
-%%BIND931%%lib/libbind9.a
-lib/libdns.a
-lib/libisc.a
-lib/libisccc.a
-lib/libisccfg.a
-lib/liblwres.a
-sbin/dnssec-keygen
-%%BIND922%%sbin/dnssec-makekeyset
-%%BIND922%%sbin/dnssec-signkey
-sbin/dnssec-signzone
-sbin/lwresd
-sbin/named
-sbin/named-checkconf
-sbin/named-checkzone
-sbin/rndc
-sbin/rndc-confgen
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch01.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch02.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch03.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch04.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch05.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch06.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch07.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch08.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch09.html
-%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.html
-%%PORTDOCS%%%%DOCSDIR%%/misc/dnssec
-%%PORTDOCS%%%%DOCSDIR%%/misc/format-options.pl
-%%PORTDOCS%%%%DOCSDIR%%/misc/ipv6
-%%PORTDOCS%%%%DOCSDIR%%/misc/migration
-%%PORTDOCS%%%%DOCSDIR%%/misc/migration-4to9
-%%PORTDOCS%%%%DOCSDIR%%/misc/options
-%%PORTDOCS%%%%DOCSDIR%%/misc/rfc-compliance
-%%PORTDOCS%%%%DOCSDIR%%/misc/roadmap
-%%PORTDOCS%%%%DOCSDIR%%/misc/sdb
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/arm
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/misc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%BIND931%%@dirrm include/bind9
-@dirrm include/dns
-@dirrm include/dst
-@dirrmtry include/isc
-@dirrm include/isccc
-@dirrm include/isccfg
-@dirrm include/lwres