aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2009-06-17 20:52:53 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2009-06-17 20:52:53 +0000
commit1b7af2702d3678bb8ec0c6a6b4d7bca52383a9fc (patch)
tree134e7b9ce948f2519c47bffb4b220446603c200c
parent7d9cc7021443e251932f101a09acd35a447f18cd (diff)
downloadports-1b7af2702d3678bb8ec0c6a6b4d7bca52383a9fc.tar.gz
ports-1b7af2702d3678bb8ec0c6a6b4d7bca52383a9fc.zip
- Add GID and UID for emulators/virtualbox.
- Change virtualbox GID in port Makefile due to a conflict with databases/couchdb and add UPDATING note. - Bump PORTREVISION. Reported by: Mike Harding <mvh AT ix.netcom.com>
Notes
Notes: svn path=/head/; revision=236160
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--UPDATING9
-rw-r--r--emulators/virtualbox-ose-kmod-legacy/Makefile4
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile4
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile4
-rw-r--r--emulators/virtualbox-ose/Makefile4
-rw-r--r--emulators/virtualbox/Makefile4
8 files changed, 21 insertions, 10 deletions
diff --git a/GIDs b/GIDs
index c94dd49b9fd9..1b5f7d670dc7 100644
--- a/GIDs
+++ b/GIDs
@@ -141,3 +141,4 @@ ssmtp:*:916:
prayer:*:917:
nefu:*:918:
couchdb:*:919:
+vboxusers:*:920:
diff --git a/UIDs b/UIDs
index 1ba249f500ba..683136ec6ac0 100644
--- a/UIDs
+++ b/UIDs
@@ -151,3 +151,4 @@ logcheck:*:915:915::0:0:Logcheck system account:/var/lib/logcheck:/usr/local/bin
_prayer:*:917:917:daemon:0:0:Prayer Account:/nonexistent:/sbin/nologin
nefu:*:918:918::0:0:Nefu daemon:/var/db/nefu:/sbin/nologin
couchdb:*:919:919:daemon:0:0:CouchDB Account:/var/empty:/usr/sbin/nologin
+vboxusers:*:920:920::0:0:Virtualbox user:/nonexistent:/sbin/nologin
diff --git a/UPDATING b/UPDATING
index 2f1e4d05960b..6b0de035d19c 100644
--- a/UPDATING
+++ b/UPDATING
@@ -7,6 +7,15 @@ time you update your ports collection, before attempting any port
upgrades.
20090617:
+ AFFECTS: users of emulators/virtualbox
+ AUTHOR: beat@FreeBSD.org
+
+ The GID of virtualbox has changed due to a conflict with databases/couchdb.
+ Update GID of vboxusers after updating the port:
+
+ # pw groupmod vboxusers -g 920
+
+20090617:
AFFECTS: users of math/fftw3 math/fftw3-long math/fftw3-float
AUTHOR: db@FreeBSD.org
diff --git a/emulators/virtualbox-ose-kmod-legacy/Makefile b/emulators/virtualbox-ose-kmod-legacy/Makefile
index 84ac0744fc2a..70c1c1d4b56a 100644
--- a/emulators/virtualbox-ose-kmod-legacy/Makefile
+++ b/emulators/virtualbox-ose-kmod-legacy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= virtualbox
DISTVERSION= 2.2.51.r20457
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -43,7 +43,7 @@ USE_LDCONFIG= ${PREFIX}/lib/virtualbox
CONFLICTS= bcc-[0-9]*
VBOXGROUP?= vboxusers
-VBOXGID?= 919
+VBOXGID?= 920
VBOX_FRONTENDS= VBoxBFE VBoxHeadless VBoxSDL
VBOX_GUEST_VER= 2.2.4
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 84ac0744fc2a..70c1c1d4b56a 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= virtualbox
DISTVERSION= 2.2.51.r20457
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -43,7 +43,7 @@ USE_LDCONFIG= ${PREFIX}/lib/virtualbox
CONFLICTS= bcc-[0-9]*
VBOXGROUP?= vboxusers
-VBOXGID?= 919
+VBOXGID?= 920
VBOX_FRONTENDS= VBoxBFE VBoxHeadless VBoxSDL
VBOX_GUEST_VER= 2.2.4
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index 84ac0744fc2a..70c1c1d4b56a 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= virtualbox
DISTVERSION= 2.2.51.r20457
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -43,7 +43,7 @@ USE_LDCONFIG= ${PREFIX}/lib/virtualbox
CONFLICTS= bcc-[0-9]*
VBOXGROUP?= vboxusers
-VBOXGID?= 919
+VBOXGID?= 920
VBOX_FRONTENDS= VBoxBFE VBoxHeadless VBoxSDL
VBOX_GUEST_VER= 2.2.4
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 84ac0744fc2a..70c1c1d4b56a 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -7,7 +7,7 @@
PORTNAME= virtualbox
DISTVERSION= 2.2.51.r20457
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -43,7 +43,7 @@ USE_LDCONFIG= ${PREFIX}/lib/virtualbox
CONFLICTS= bcc-[0-9]*
VBOXGROUP?= vboxusers
-VBOXGID?= 919
+VBOXGID?= 920
VBOX_FRONTENDS= VBoxBFE VBoxHeadless VBoxSDL
VBOX_GUEST_VER= 2.2.4
diff --git a/emulators/virtualbox/Makefile b/emulators/virtualbox/Makefile
index 84ac0744fc2a..70c1c1d4b56a 100644
--- a/emulators/virtualbox/Makefile
+++ b/emulators/virtualbox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= virtualbox
DISTVERSION= 2.2.51.r20457
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -43,7 +43,7 @@ USE_LDCONFIG= ${PREFIX}/lib/virtualbox
CONFLICTS= bcc-[0-9]*
VBOXGROUP?= vboxusers
-VBOXGID?= 919
+VBOXGID?= 920
VBOX_FRONTENDS= VBoxBFE VBoxHeadless VBoxSDL
VBOX_GUEST_VER= 2.2.4