aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-27 01:48:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-27 01:48:54 +0000
commit1badeb83877714ab7856dd39b835f7d1c9cf5b58 (patch)
tree4e868b325df9166b300d80cdc085874a53edabff
parent6d28bf9b0d1ca3ac451bd1d7c14a21be7f4950dd (diff)
downloadports-1badeb83877714ab7856dd39b835f7d1c9cf5b58.tar.gz
ports-1badeb83877714ab7856dd39b835f7d1c9cf5b58.zip
Notes
-rw-r--r--deskutils/goesimage/Makefile11
-rw-r--r--deskutils/goesimage/files/crontab.in2
-rw-r--r--deskutils/goesimage/pkg-plist1
3 files changed, 11 insertions, 3 deletions
diff --git a/deskutils/goesimage/Makefile b/deskutils/goesimage/Makefile
index 4d2a09d049e4..ee7b111d29f6 100644
--- a/deskutils/goesimage/Makefile
+++ b/deskutils/goesimage/Makefile
@@ -3,6 +3,7 @@
PORTNAME= goesimage
DISTVERSION= 0.1.1-1
DISTVERSIONSUFFIX= -g0021b16
+PORTREVISION= 1
CATEGORIES= deskutils
MAINTAINER= yuri@FreeBSD.org
@@ -24,9 +25,11 @@ GH_ACCOUNT= pigmonkey
NO_BUILD= yes
NO_ARCH= yes
-SUB_LIST= PORTNAME=${PORTNAME}
+SUB_LIST= PORTNAME=${PORTNAME} RUN_ARGS="${RUN_ARGS}"
SUB_FILES= crontab
+RUN_ARGS= -w -e
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/libexec/
${MKDIR} ${STAGEDIR}${DATADIR}
@@ -39,6 +42,10 @@ do-install:
echo ""; \
echo "crontab -l | ${GREP} -v '${PREFIX}/libexec/${PORTNAME}' | crontab -"; \
) > ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-disable
- @cd ${STAGEDIR}${PREFIX}/bin && ${CHMOD} +x ${PORTNAME}-enable ${PORTNAME}-disable
+ @(echo "#!/bin/sh"; \
+ echo ""; \
+ echo "${PREFIX}/libexec/${PORTNAME} ${RUN_ARGS}"; \
+ ) > ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-run-now
+ @cd ${STAGEDIR}${PREFIX}/bin && ${CHMOD} +x ${PORTNAME}-enable ${PORTNAME}-disable ${PORTNAME}-run-now
.include <bsd.port.mk>
diff --git a/deskutils/goesimage/files/crontab.in b/deskutils/goesimage/files/crontab.in
index 1320d4b1accd..56c43d1d1db2 100644
--- a/deskutils/goesimage/files/crontab.in
+++ b/deskutils/goesimage/files/crontab.in
@@ -1 +1 @@
-01,16,31,46 * * * * env DISPLAY=:0 %%PREFIX%%/libexec/%%PORTNAME%% -w -e
+01,16,31,46 * * * * env DISPLAY=:0 %%PREFIX%%/libexec/%%PORTNAME%% %%RUN_ARGS%%
diff --git a/deskutils/goesimage/pkg-plist b/deskutils/goesimage/pkg-plist
index 73cb6fd9f3a3..5f1cda59e2b3 100644
--- a/deskutils/goesimage/pkg-plist
+++ b/deskutils/goesimage/pkg-plist
@@ -1,4 +1,5 @@
bin/goesimage-disable
bin/goesimage-enable
+bin/goesimage-run-now
libexec/goesimage
%%DATADIR%%/crontab