aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-28 17:06:51 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-28 17:06:51 +0000
commit1bd5efef95698cd7e99eeba4a2b104313d2089af (patch)
tree110008062284005356e400083434a566cb300a63
parent8fe7848586a3ab4c046db0a0d7047c42fb652d82 (diff)
downloadports-1bd5efef95698cd7e99eeba4a2b104313d2089af.tar.gz
ports-1bd5efef95698cd7e99eeba4a2b104313d2089af.zip
Notes
-rw-r--r--mail/courier-pythonfilter/Makefile24
-rw-r--r--mail/courier-pythonfilter/distinfo6
-rw-r--r--mail/courier-pythonfilter/files/patch-pythonfilter10
-rw-r--r--mail/courier-pythonfilter/files/patch-pythonfilter.conf.sample18
-rw-r--r--mail/courier-pythonfilter/pkg-plist16
5 files changed, 48 insertions, 26 deletions
diff --git a/mail/courier-pythonfilter/Makefile b/mail/courier-pythonfilter/Makefile
index 762897184b91..b90e097eb161 100644
--- a/mail/courier-pythonfilter/Makefile
+++ b/mail/courier-pythonfilter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= courier-pythonfilter
-PORTVERSION= 0.16
+PORTVERSION= 0.18
CATEGORIES= mail python
MASTER_SITES= http://phantom.dragonsdawn.net/~gordon/courier-patches/courier-pythonfilter/
@@ -30,8 +30,11 @@ OPTIONS= DEBUG "debug module" on \
NODUPLICATES "noduplicates module" off \
CLAMAV "clamav module" off \
AUTO_WHITELIST "auto_whitelist module" off \
- WHITELIST "whitelist module" on \
+ WHITELIST_RELAY "whitelist_relayclients module" on \
WHITELIST_AUTH "whitelist_auth module" on \
+ WHITELIST_BLOCK "whitelist_block module" off \
+ WHITELIST_DNSWL "whitelist_dnswl module" off \
+ WHITELIST_SPF "whitelist_spf module" off \
PRIVATEADDR "privateaddr module" off \
SPFCHECK "spfcheck module" off \
NOSUCCESSDSN "nosuccessdsn module" off \
@@ -53,7 +56,7 @@ post-extract:
${MV} ${WRKSRC}/pythonfilter.conf ${WRKSRC}/pythonfilter.conf.sample
post-configure:
- @${ECHO_MSG} Creating sample config file based on your OPTIONS ...
+ @${ECHO_MSG} Adding your OPTIONS to sample config file...
.if !defined(WITHOUT_DEBUG)
@${ECHO_MSG} debug >> ${WRKSRC}/pythonfilter.conf.sample
.endif
@@ -66,12 +69,21 @@ post-configure:
.if !defined(WITHOUT_AUTO_WHITELIST)
@${ECHO_MSG} auto_whitelist >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if !defined(WITHOUT_WHITELIST)
- @${ECHO_MSG} whitelist >> ${WRKSRC}/pythonfilter.conf.sample
+.if !defined(WITHOUT_WHITELIST_RELAY)
+ @${ECHO_MSG} whitelist_relayclients >> ${WRKSRC}/pythonfilter.conf.sample
.endif
.if !defined(WITHOUT_WHITELIST_AUTH)
@${ECHO_MSG} whitelist_auth >> ${WRKSRC}/pythonfilter.conf.sample
.endif
+.if defined(WHITELIST_BLOCK)
+ @${ECHO_MSG} whitelist_block >> ${WRKSRC}/pythonfilter.conf.sample
+.endif
+.if defined(WHITELIST_DNSWL)
+ @${ECHO_MSG} whitelist_dnswl >> ${WRKSRC}/pythonfilter.conf.sample
+.endif
+.if defined(WHITELIST_SPF)
+ @${ECHO_MSG} whitelist_spf >> ${WRKSRC}/pythonfilter.conf.sample
+.endif
.if defined(WITH_PRIVATEADDR)
@${ECHO_MSG} privateaddr >> ${WRKSRC}/pythonfilter.conf.sample
.endif
@@ -100,6 +112,6 @@ post-configure:
post-install:
${MKDIR} ${LOCALSTATEDIR}/pythonfilter
${CHOWN} ${MAILOWN}:${MAILGRP} ${LOCALSTATEDIR}/pythonfilter
- if [ -e ${PREFIX}/etc/pythonfilter.conf ]; then ${CP} -p ${PREFIX}/etc/pythonfilter.conf.sample ${PREFIX}/etc/pythonfilter.conf; fi
+ if [ ! -e ${PREFIX}/etc/pythonfilter.conf ]; then cp -p ${PREFIX}/etc/pythonfilter.conf.sample ${PREFIX}/etc/pythonfilter.conf; fi
.include <bsd.port.post.mk>
diff --git a/mail/courier-pythonfilter/distinfo b/mail/courier-pythonfilter/distinfo
index 595cb71b3727..d46f184f9419 100644
--- a/mail/courier-pythonfilter/distinfo
+++ b/mail/courier-pythonfilter/distinfo
@@ -1,3 +1,3 @@
-MD5 (courier-pythonfilter-0.16.tar.gz) = 67998e92c107a1a55099c9c038084a32
-SHA256 (courier-pythonfilter-0.16.tar.gz) = d57c675bdcba52dea0fe7b29e8b39902703e05841a315fa2075b2d1ba0f75c14
-SIZE (courier-pythonfilter-0.16.tar.gz) = 33160
+MD5 (courier-pythonfilter-0.18.tar.gz) = dd245fa5e9cf31c4a52f0fc3dbc27342
+SHA256 (courier-pythonfilter-0.18.tar.gz) = d2bf1a355a606ee111895fee3041be5076ad944b5f21a696a5b3515d430552b5
+SIZE (courier-pythonfilter-0.18.tar.gz) = 40135
diff --git a/mail/courier-pythonfilter/files/patch-pythonfilter b/mail/courier-pythonfilter/files/patch-pythonfilter
index 8a59dd38307e..5fbc84a76153 100644
--- a/mail/courier-pythonfilter/files/patch-pythonfilter
+++ b/mail/courier-pythonfilter/files/patch-pythonfilter
@@ -1,5 +1,5 @@
---- pythonfilter.orig Fri Dec 1 19:59:03 2006
-+++ pythonfilter Thu Dec 28 12:44:19 2006
+--- pythonfilter.orig Tue Jan 23 17:30:50 2007
++++ pythonfilter Thu Jan 25 19:34:11 2007
@@ -71,17 +71,15 @@
# First, locate and open the configuration file.
config = None
@@ -11,14 +11,14 @@
- break
+ configDir = ('/usr/local/etc')
+ if os.access('%s/pythonfilter.conf' % configDir, os.R_OK):
-+ config = open('%s/pythonfilter.conf' % configDir)
++ config = open('%s/pythonfilter.conf' % configDir)
except IOError:
sys.stderr.write('Could not open config file for reading.\n')
sys.exit()
if not config:
-- sys.stderr.write('Could not locate a configuration file in any of: %s\n',
+- sys.stderr.write('Could not locate a configuration file in any of: %s\n' %
- configDirs)
-+ sys.stderr.write('Could not locate a configuration file in %s\n',
++ sys.stderr.write('Could not locate a configuration file in %s\n' %
+ configDir)
sys.exit()
# Read the lines from the configuration file and load any module listed
diff --git a/mail/courier-pythonfilter/files/patch-pythonfilter.conf.sample b/mail/courier-pythonfilter/files/patch-pythonfilter.conf.sample
index 1e2791be00a5..710811c3e4c8 100644
--- a/mail/courier-pythonfilter/files/patch-pythonfilter.conf.sample
+++ b/mail/courier-pythonfilter/files/patch-pythonfilter.conf.sample
@@ -1,5 +1,5 @@
---- pythonfilter.conf.sample.orig Tue Dec 12 07:18:58 2006
-+++ pythonfilter.conf.sample Sun Jan 14 13:48:07 2007
+--- pythonfilter.conf.sample.orig Thu Jan 18 01:49:55 2007
++++ pythonfilter.conf.sample Mon Jan 22 12:57:00 2007
@@ -2,7 +2,7 @@
# in this file.
@@ -9,16 +9,16 @@
# noduplicates: checks for duplicate recipients which may occur due to alias
# expansion, and removes the duplicates.
-@@ -16,10 +16,10 @@
- # auto_whitelist
+@@ -17,10 +17,10 @@
- # whitelist: exempts IP addresses for which you relay from further filtering.
--whitelist
-+# whitelist
+ # whitelist_relayclients: exempts IP addresses for which you relay from
+ # further filtering.
+-whitelist_relayclients
++# whitelist_relayclients
# whitelist_auth: exempts users who authenticate from further filtering.
-whitelist_auth
+# whitelist_auth
- # privateaddr: restricts addresses to specific senders
- # privateaddr
+ # whitelist_block: exempts IP addresses and networks which have an empty
+ # BLOCK value in smtpaccess.dat
diff --git a/mail/courier-pythonfilter/pkg-plist b/mail/courier-pythonfilter/pkg-plist
index 0537ff40ec9f..dd6a6d803612 100644
--- a/mail/courier-pythonfilter/pkg-plist
+++ b/mail/courier-pythonfilter/pkg-plist
@@ -1,5 +1,6 @@
@unexec if cmp -s %D/etc/pythonfilter.conf %D/etc/pythonfilter.conf.sample; then rm -f %D/etc/pythonfilter.conf; fi
etc/pythonfilter.conf.sample
+@exec if [ ! -e %D/etc/pythonfilter.conf ]; then cp -p %D/etc/pythonfilter.conf.sample %D/etc/pythonfilter.conf; fi
libexec/filters/pythonfilter
%%PYTHON_SITELIBDIR%%/courier/__init__.py
%%PYTHON_SITELIBDIR%%/courier/__init__.pyc
@@ -58,8 +59,17 @@ libexec/filters/pythonfilter
%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_auth.py
%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_auth.pyc
%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_auth.pyo
-%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist.py
-%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist.pyc
-%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist.pyo
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_block.py
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_block.pyc
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_block.pyo
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_dnswl.py
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_dnswl.pyc
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_dnswl.pyo
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_relayclients.py
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_relayclients.pyc
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_relayclients.pyo
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_spf.py
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_spf.pyc
+%%PYTHON_SITELIBDIR%%/pythonfilter/whitelist_spf.pyo
@dirrm %%PYTHON_SITELIBDIR%%/courier
@dirrm %%PYTHON_SITELIBDIR%%/pythonfilter