aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-12-23 15:54:09 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-12-23 15:54:09 +0000
commit1c95d592ee0a159094d006c6dafd6157a2423223 (patch)
treeb28823af759f016cbb6569635cb4373604dc56a2
parent6a5f2170ef7ad1723a681702ff60b0c796b036fe (diff)
downloadports-1c95d592ee0a159094d006c6dafd6157a2423223.tar.gz
ports-1c95d592ee0a159094d006c6dafd6157a2423223.zip
- Remove unneeded USE_AUTOTOOLS.
- Add USES=libtool. - Put manpages in pkg-plist. - Replace post-configure with --disable-static.
Notes
Notes: svn path=/head/; revision=457063
-rw-r--r--devel/libdispatch/Makefile73
-rw-r--r--devel/libdispatch/pkg-plist55
2 files changed, 58 insertions, 70 deletions
diff --git a/devel/libdispatch/Makefile b/devel/libdispatch/Makefile
index be5240f4c0f4..2707330670db 100644
--- a/devel/libdispatch/Makefile
+++ b/devel/libdispatch/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libdispatch
PORTVERSION= 210
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
@@ -12,76 +12,9 @@ COMMENT= Grand Central Dispatch API support library
LICENSE= APACHE20
-USES= tar:bzip2
-USE_AUTOTOOLS= aclocal autoconf
-ACLOCAL_ARGS= -Im4
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USES= libtool tar:bzip2
USE_LDCONFIG= yes
-# This is needed because PIC support check in autoconf could fail for clang otherwise.
-CONFIGURE_ENV= lt_cv_prog_compiler_pic_works=yes
-
-_MAN3= dispatch.3 \
- dispatch_after.3 \
- dispatch_after_f.3 \
- dispatch_api.3 \
- dispatch_apply.3 \
- dispatch_apply_f.3 \
- dispatch_async.3 \
- dispatch_async_f.3 \
- dispatch_benchmark.3 \
- dispatch_benchmark_f.3 \
- dispatch_get_context.3 \
- dispatch_get_current_queue.3 \
- dispatch_get_global_queue.3 \
- dispatch_get_main_queue.3 \
- dispatch_group_async.3 \
- dispatch_group_async_f.3 \
- dispatch_group_create.3 \
- dispatch_group_enter.3 \
- dispatch_group_leave.3 \
- dispatch_group_notify.3 \
- dispatch_group_notify_f.3 \
- dispatch_group_wait.3 \
- dispatch_main.3 \
- dispatch_object.3 \
- dispatch_once.3 \
- dispatch_once_f.3 \
- dispatch_queue_create.3 \
- dispatch_queue_get_label.3 \
- dispatch_release.3 \
- dispatch_resume.3 \
- dispatch_retain.3 \
- dispatch_semaphore_create.3 \
- dispatch_semaphore_signal.3 \
- dispatch_semaphore_wait.3 \
- dispatch_set_context.3 \
- dispatch_set_finalizer_f.3 \
- dispatch_set_target_queue.3 \
- dispatch_source_cancel.3 \
- dispatch_source_create.3 \
- dispatch_source_get_data.3 \
- dispatch_source_get_handle.3 \
- dispatch_source_get_mask.3 \
- dispatch_source_merge_data.3 \
- dispatch_source_set_cancel_handler.3 \
- dispatch_source_set_cancel_handler_f.3 \
- dispatch_source_set_event_handler.3 \
- dispatch_source_set_event_handler_f.3 \
- dispatch_source_set_timer.3 \
- dispatch_source_testcancel.3 \
- dispatch_suspend.3 \
- dispatch_sync.3 \
- dispatch_sync_f.3 \
- dispatch_time.3 \
- dispatch_walltime.3
-PLIST_FILES+= ${_MAN3:S|^|man/man3/|:S|$|.gz|}
-
-#
-# Get rid of .la and static library files
-#
-post-configure:
- @${REINPLACE_CMD} -E -e \
- '/Install the pseudo-library/,/staticlibs=/s,^,#,' ${WRKSRC}/libtool
-
.include <bsd.port.mk>
diff --git a/devel/libdispatch/pkg-plist b/devel/libdispatch/pkg-plist
index e30c62b16080..4f6f08d7c58e 100644
--- a/devel/libdispatch/pkg-plist
+++ b/devel/libdispatch/pkg-plist
@@ -9,3 +9,58 @@ include/dispatch/source.h
include/dispatch/time.h
lib/libdispatch.so
lib/libdispatch.so.0
+lib/libdispatch.so.0.0.0
+man/man3/dispatch.3.gz
+man/man3/dispatch_after.3.gz
+man/man3/dispatch_after_f.3.gz
+man/man3/dispatch_api.3.gz
+man/man3/dispatch_apply.3.gz
+man/man3/dispatch_apply_f.3.gz
+man/man3/dispatch_async.3.gz
+man/man3/dispatch_async_f.3.gz
+man/man3/dispatch_benchmark.3.gz
+man/man3/dispatch_benchmark_f.3.gz
+man/man3/dispatch_get_context.3.gz
+man/man3/dispatch_get_current_queue.3.gz
+man/man3/dispatch_get_global_queue.3.gz
+man/man3/dispatch_get_main_queue.3.gz
+man/man3/dispatch_group_async.3.gz
+man/man3/dispatch_group_async_f.3.gz
+man/man3/dispatch_group_create.3.gz
+man/man3/dispatch_group_enter.3.gz
+man/man3/dispatch_group_leave.3.gz
+man/man3/dispatch_group_notify.3.gz
+man/man3/dispatch_group_notify_f.3.gz
+man/man3/dispatch_group_wait.3.gz
+man/man3/dispatch_main.3.gz
+man/man3/dispatch_object.3.gz
+man/man3/dispatch_once.3.gz
+man/man3/dispatch_once_f.3.gz
+man/man3/dispatch_queue_create.3.gz
+man/man3/dispatch_queue_get_label.3.gz
+man/man3/dispatch_release.3.gz
+man/man3/dispatch_resume.3.gz
+man/man3/dispatch_retain.3.gz
+man/man3/dispatch_semaphore_create.3.gz
+man/man3/dispatch_semaphore_signal.3.gz
+man/man3/dispatch_semaphore_wait.3.gz
+man/man3/dispatch_set_context.3.gz
+man/man3/dispatch_set_finalizer_f.3.gz
+man/man3/dispatch_set_target_queue.3.gz
+man/man3/dispatch_source_cancel.3.gz
+man/man3/dispatch_source_create.3.gz
+man/man3/dispatch_source_get_data.3.gz
+man/man3/dispatch_source_get_handle.3.gz
+man/man3/dispatch_source_get_mask.3.gz
+man/man3/dispatch_source_merge_data.3.gz
+man/man3/dispatch_source_set_cancel_handler.3.gz
+man/man3/dispatch_source_set_cancel_handler_f.3.gz
+man/man3/dispatch_source_set_event_handler.3.gz
+man/man3/dispatch_source_set_event_handler_f.3.gz
+man/man3/dispatch_source_set_timer.3.gz
+man/man3/dispatch_source_testcancel.3.gz
+man/man3/dispatch_suspend.3.gz
+man/man3/dispatch_sync.3.gz
+man/man3/dispatch_sync_f.3.gz
+man/man3/dispatch_time.3.gz
+man/man3/dispatch_walltime.3.gz