aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-05-02 22:29:01 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-05-02 22:29:01 +0000
commit1d1273b22cfd4f5f044f93faa3be4d2982d0d255 (patch)
treebcccfe04e4bade58b5925d239ac1019a4ff4e515
parentef24378044856c29aaa9e02a03dc8df014dbe4b0 (diff)
lang/php8*: Remove stale NOOP codes
json module is by default built into php and these module configs were stale.
-rw-r--r--lang/php81/Makefile5
-rw-r--r--lang/php82/Makefile5
-rw-r--r--lang/php83/Makefile5
3 files changed, 0 insertions, 15 deletions
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 346a0360ec9e..6a479fb62520 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -356,11 +356,6 @@ USES+= pkgconfig
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
.endif
-.if ${PHP_MODNAME} == "json"
-CONFIGURE_ARGS+= --enable-json
-BUILD_DEPENDS= re2c:devel/re2c
-.endif
-
.if ${PHP_MODNAME} == "ldap"
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}
USES+= ldap
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index f25cdcbe7aa5..0d5321f6a083 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -353,11 +353,6 @@ USES+= pkgconfig
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
.endif
-.if ${PHP_MODNAME} == "json"
-CONFIGURE_ARGS+= --enable-json
-BUILD_DEPENDS= re2c:devel/re2c
-.endif
-
.if ${PHP_MODNAME} == "ldap"
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}
USES+= ldap
diff --git a/lang/php83/Makefile b/lang/php83/Makefile
index 9e4b1de3ae4c..e668c7be4dbc 100644
--- a/lang/php83/Makefile
+++ b/lang/php83/Makefile
@@ -371,11 +371,6 @@ USES+= pkgconfig
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
.endif
-.if ${PHP_MODNAME} == "json"
-CONFIGURE_ARGS+= --enable-json
-BUILD_DEPENDS= re2c:devel/re2c
-.endif
-
.if ${PHP_MODNAME} == "ldap"
LIB_DEPENDS+=libsasl2.so:security/cyrus-sasl2
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}