aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2012-08-22 18:09:57 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2012-08-22 18:09:57 +0000
commit1d42494e45abd4762b73f7578c81ea9e8672c930 (patch)
tree82c8e535137786c4b61fc8ec4c55ba4d9d22a5b6
parentba263c5e7a38d109a4c9bee81edacf927abfe282 (diff)
downloadports-1d42494e45abd4762b73f7578c81ea9e8672c930.tar.gz
ports-1d42494e45abd4762b73f7578c81ea9e8672c930.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/R-cran-sqldf/Makefile29
-rw-r--r--databases/R-cran-sqldf/distinfo2
-rw-r--r--databases/R-cran-sqldf/pkg-descr10
4 files changed, 42 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 265897565067..29c9c0b89c7c 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -7,6 +7,7 @@
SUBDIR += R-cran-RMySQL
SUBDIR += R-cran-RSQLite
SUBDIR += R-cran-RSQLite.extfuns
+ SUBDIR += R-cran-sqldf
SUBDIR += WWWdb
SUBDIR += adminer
SUBDIR += adodb
diff --git a/databases/R-cran-sqldf/Makefile b/databases/R-cran-sqldf/Makefile
new file mode 100644
index 000000000000..73f92a30ffcb
--- /dev/null
+++ b/databases/R-cran-sqldf/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: R-cran-sqldf
+# Date created: 2012-08-21
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqldf
+DISTVERSION= 0.4-6.4
+CATEGORIES= databases
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= SQL select on R data frames
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= R-cran-proto>=0.3.9.2_6:${PORTSDIR}/devel/R-cran-proto \
+ R-cran-chron>=2.3.42:${PORTSDIR}/devel/R-cran-chron \
+ R-cran-gsubfn>=0.6.4:${PORTSDIR}/devel/R-cran-gsubfn \
+ R-cran-DBI>=0.2.5_6:${PORTSDIR}/databases/R-cran-DBI \
+ R-cran-RSQLite>=0.11.1:${PORTSDIR}/databases/R-cran-RSQLite \
+ R-cran-RSQLite.extfuns>=0.0.1:${PORTSDIR}/databases/R-cran-RSQLite.extfuns
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/R-cran-sqldf/distinfo b/databases/R-cran-sqldf/distinfo
new file mode 100644
index 000000000000..ae32675889cb
--- /dev/null
+++ b/databases/R-cran-sqldf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sqldf_0.4-6.4.tar.gz) = 6c51e4e48b93310f765c661a1756fe068629da775248d38a98c38f5b6f7511c4
+SIZE (sqldf_0.4-6.4.tar.gz) = 26817
diff --git a/databases/R-cran-sqldf/pkg-descr b/databases/R-cran-sqldf/pkg-descr
new file mode 100644
index 000000000000..6655c18f716a
--- /dev/null
+++ b/databases/R-cran-sqldf/pkg-descr
@@ -0,0 +1,10 @@
+sqldf is an R package for runing SQL statements on R data frames, optimized for
+convenience. The user simply specifies an SQL statement in R using data frame
+names in place of table names and a database with appropriate table
+layouts/schema is automatically created, the data frames are automatically
+loaded into the database, the specified SQL statement is performed, the result
+is read back into R and the database is deleted all automatically behind the
+scenes making the database's existence transparent to the user who only
+specifies the SQL statement.
+
+WWW: https://code.google.com/p/sqldf/