aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-12-29 20:18:35 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-12-29 20:18:35 +0000
commit1db83699fd8806e77c676848f821f10d073cfd50 (patch)
treecc16bd432906464e7cd3400f2f10bddf472ae325
parent980bb5389487be090d45fc99c64291b0fd825e3c (diff)
- Update to 1.16
- Add missed manpage entries [1] PR: ports/107173 Submitted by: Radim Kolar SF.NET <hsn@sendmail.cz> [1]
Notes
Notes: svn path=/head/; revision=180993
-rw-r--r--graphics/lcms/Makefile6
-rw-r--r--graphics/lcms/distinfo6
-rw-r--r--graphics/lcms/files/patch-32bit15
-rw-r--r--graphics/lcms/files/patch-config26
4 files changed, 7 insertions, 46 deletions
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index 9d887fcb838c..09170cc076bf 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= lcms
-PORTVERSION= 1.15
-PORTREVISION= 1
+PORTVERSION= 1.16
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
@@ -32,6 +32,7 @@ OPTIONS= TIFFICC "Build color profile applier for tiff" off \
.if defined(WITH_TIFFICC)
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
PLIST_SUB+= TIFFICC=""
+MAN1+= tifficc.1
.else
CONFIGURE_ARGS= --without-tiff
PLIST_SUB+= TIFFICC="@comment "
@@ -40,6 +41,7 @@ PLIST_SUB+= TIFFICC="@comment "
.if defined(WITH_JPEGICC)
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
PLIST_SUB+= JPEGICC=""
+MAN1+= jpegicc.1
.else
CONFIGURE_ARGS= --without-jpeg
PLIST_SUB+= JPEGICC="@comment "
diff --git a/graphics/lcms/distinfo b/graphics/lcms/distinfo
index 0d9254a5257d..fc0215ecdf43 100644
--- a/graphics/lcms/distinfo
+++ b/graphics/lcms/distinfo
@@ -1,3 +1,3 @@
-MD5 (lcms-1.15.tar.gz) = 76c921973fdea4f880944a024197f924
-SHA256 (lcms-1.15.tar.gz) = 930ef7de15eb028c1cdbfe3f1170aaa1d5b0b4d45a8fa496d944216e155122c2
-SIZE (lcms-1.15.tar.gz) = 777834
+MD5 (lcms-1.16.tar.gz) = b07b623f3e712373ff713fb32cf23651
+SHA256 (lcms-1.16.tar.gz) = aa10a5295029c0fadaf95e33608121c04bf6044f165e0b418a1c4919b71a6993
+SIZE (lcms-1.16.tar.gz) = 911546
diff --git a/graphics/lcms/files/patch-32bit b/graphics/lcms/files/patch-32bit
deleted file mode 100644
index d46710470240..000000000000
--- a/graphics/lcms/files/patch-32bit
+++ /dev/null
@@ -1,15 +0,0 @@
-This patch fixes assumptions made in different parts of the code
-regarding the sizeof long and int. The original code appears to use them
-interchangeably, even though it expects them to be 32 bit wide.
---- src/cmsmtrx.c Tue Feb 13 12:08:06 2001
-+++ src/cmsmtrx.c Wed Sep 5 10:28:02 2001
-@@ -705,6 +705,6 @@
- void VEC3scaleAndCut(LPWVEC3 r, LPVEC3 v, double d)
- {
-- r -> n[VX] = (int) floor(v -> n[VX] * d + .5);
-- r -> n[VY] = (int) floor(v -> n[VY] * d + .5);
-- r -> n[VZ] = (int) floor(v -> n[VZ] * d + .5);
-+ r -> n[VX] = (icInt32Number) floor(v -> n[VX] * d + .5);
-+ r -> n[VY] = (icInt32Number) floor(v -> n[VY] * d + .5);
-+ r -> n[VZ] = (icInt32Number) floor(v -> n[VZ] * d + .5);
- }
diff --git a/graphics/lcms/files/patch-config b/graphics/lcms/files/patch-config
deleted file mode 100644
index e68979f93620..000000000000
--- a/graphics/lcms/files/patch-config
+++ /dev/null
@@ -1,26 +0,0 @@
---- include/lcms.h.orig Sat Nov 26 17:23:47 2005
-+++ include/lcms.h Mon Aug 7 21:28:13 2006
-@@ -47,7 +47,13 @@
-
- // Uncomment this one if you are using big endian machines (only meaningful
- // when NON_WINDOWS is used)
--// #define USE_BIG_ENDIAN 1
-+
-+#include <sys/endian.h>
-+#if BYTE_ORDER == BIG_ENDIAN
-+# define USE_BIG_ENDIAN 1
-+#elif BYTE_ORDER != LITTLE_ENDIAN
-+# error "Unexpected BYTE_ORDER on this architecture"
-+#endif
-
- // Uncomment this one if your compiler/machine does support the
- // "long long" type This will speedup fixed point math. (USE_C only)
-@@ -134,7 +140,7 @@
- #if defined(__OpenBSD__) || defined(__NetBSD__) || defined(__FreeBSD__)
- # include <sys/types.h>
- # define USE_INT64 1
--# define LCMSSLONGLONG int_64_t
-+# define LCMSSLONGLONG int64_t
- # define LCMSULONGLONG u_int64_t
- #endif
-