aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-10-09 02:46:14 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-10-09 02:46:14 +0000
commit1df34a16c1aae29c2ba246e67ab71d20318ec30c (patch)
tree43f2cb8855885e36fc732a4e57151856de07ca37
parentfe04da78c61dfa2c8bb52422cd5e736de45f17ce (diff)
downloadports-1df34a16c1aae29c2ba246e67ab71d20318ec30c.tar.gz
ports-1df34a16c1aae29c2ba246e67ab71d20318ec30c.zip
Notes
-rw-r--r--mail/im/Makefile29
-rw-r--r--mail/im/distinfo2
-rw-r--r--mail/im/files/patch-aa11
-rw-r--r--mail/im/pkg-plist87
4 files changed, 80 insertions, 49 deletions
diff --git a/mail/im/Makefile b/mail/im/Makefile
index d1fad1b04841..5c23c0e01e5a 100644
--- a/mail/im/Makefile
+++ b/mail/im/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: IM
-# Version required: 76
+# Version required: 100
# Date created: 13 November 1997
# Whom: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
-# $Id: Makefile,v 1.2 1998/01/09 21:37:57 max Exp $
+# $Id: Makefile,v 1.3 1998/06/06 03:47:23 itojun Exp $
#
-DISTNAME= im-76
+DISTNAME= im-100
CATEGORIES= mail
MASTER_SITES= ftp://ftp.mew.org/pub/Mew/ \
ftp://ftp.kyushu-u.ac.jp/pub/Misc/mew/ \
@@ -17,26 +17,21 @@ MAINTAINER= kiri@kiri.toba-cmt.ac.jp
USE_PERL5= yes
GNU_CONFIGURE= yes
-
-MANLANG= ja
-MAN1= imali.1 imget.1 imsetup.1 imstore.1
+CONFIGURE_ARGS= --libdir=${PREFIX}/etc
+# If you use RPOP instead of APOP, comment out following line.
+#CONFIGURE_ARGS+=--enable-rpop
PORTDOCDIR= ${PREFIX}/share/doc/im
SAMPLEDIR= ${PREFIX}/share/examples/im
-MANFILES= imali.jis imget.jis imsetup.jis imstore.jis
-PORTDOCS= 00readme imget2.jis imput imput.jis
+PORTDOCS= 00changes 00copyright 00copyright.jis 00perl 00readme 00usage
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PORTDOCDIR} ${SAMPLEDIR}
- @(cd ${WRKSRC}; \
- (cd man; ${INSTALL_DATA} ${PORTDOCS} ${PORTDOCDIR}); \
- ${INSTALL_DATA} dot.im/* ${SAMPLEDIR}; \
- )
+ @${MKDIR} ${PORTDOCDIR}/man ${SAMPLEDIR}
+ @cd ${WRKSRC}; \
+ ${INSTALL_DATA} ${PORTDOCS} ${PORTDOCDIR}; \
+ ${INSTALL_DATA} man/* ${PORTDOCDIR}/man; \
+ ${INSTALL_DATA} dot.im/* ${SAMPLEDIR}
.endif
-.for f in ${MANFILES}
- @${INSTALL_MAN} ${WRKSRC}/man/${f} \
- ${PREFIX}/man/ja/man1/`${BASENAME} ${f} .jis`.1
-.endfor
.include <bsd.port.mk>
diff --git a/mail/im/distinfo b/mail/im/distinfo
index e435c150a106..6184e1a0caa3 100644
--- a/mail/im/distinfo
+++ b/mail/im/distinfo
@@ -1 +1 @@
-MD5 (im-76.tar.gz) = 9a25dd274f0af1abdb94351a8ac4786c
+MD5 (im-100.tar.gz) = 11c86eca599c8f1a43cd2ff9578915dd
diff --git a/mail/im/files/patch-aa b/mail/im/files/patch-aa
new file mode 100644
index 000000000000..6cc8391bdbf3
--- /dev/null
+++ b/mail/im/files/patch-aa
@@ -0,0 +1,11 @@
+--- IM/TcpTransaction.pm.orig Sat Sep 5 08:04:33 1998
++++ IM/TcpTransaction.pm Wed Sep 9 17:47:55 1998
+@@ -437,7 +437,7 @@
+ }
+
+ sub inet6_family () {
+- return eval '&AF_INET6' || 24;
++ return eval '&AF_INET6' || 28;
+ }
+
+ 1;
diff --git a/mail/im/pkg-plist b/mail/im/pkg-plist
index e0465202a06b..383dc0fb3260 100644
--- a/mail/im/pkg-plist
+++ b/mail/im/pkg-plist
@@ -14,32 +14,38 @@ bin/imrm
bin/imsetup
bin/imsort
bin/imstore
-lib/im/SiteConfig
-lib/perl5/site_perl/%%PERL_VER%%/IM/Address.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Alias.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Config.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/EncDec.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/File.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Folder.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/GetPass.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Header.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/History.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Http.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Imap.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Iso2022jp.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Japanese.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/LocalMbox.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Log.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/MD5.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Message.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/MsgStore.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Nntp.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Pop.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Recipient.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Scan.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Smtp.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/Stdio.pm
-lib/perl5/site_perl/%%PERL_VER%%/IM/TcpTransaction.pm
+bin/imclean
+bin/imjoin
+bin/imtar
+etc/im/SiteConfig
+@unexec if [ -f %B/SiteConfig.new ]; then rm -f %B/SiteConfig.new; fi
+lib/IM/Address.pm
+lib/IM/Alias.pm
+lib/IM/Config.pm
+lib/IM/EncDec.pm
+lib/IM/File.pm
+lib/IM/Folder.pm
+lib/IM/GetPass.pm
+lib/IM/Header.pm
+lib/IM/History.pm
+lib/IM/Http.pm
+lib/IM/Imap.pm
+lib/IM/Iso2022jp.pm
+lib/IM/Japanese.pm
+lib/IM/LocalMbox.pm
+lib/IM/Log.pm
+lib/IM/MD5.pm
+lib/IM/Message.pm
+lib/IM/MsgStore.pm
+lib/IM/Nntp.pm
+lib/IM/Pop.pm
+lib/IM/Recipient.pm
+lib/IM/Scan.pm
+lib/IM/Smtp.pm
+lib/IM/Stdio.pm
+lib/IM/TcpTransaction.pm
+lib/IM/Grep.pm
+lib/IM/Util.pm
share/examples/im/Config
share/examples/im/Petnames
share/examples/im/get.sbr
@@ -47,11 +53,30 @@ share/examples/im/password
share/examples/im/scan.sbr
share/examples/im/scan.sbr.sample1
share/examples/im/scan.sbr.sample2
+share/doc/im/00changes
+share/doc/im/00copyright
+share/doc/im/00copyright.jis
+share/doc/im/00perl
share/doc/im/00readme
-share/doc/im/imget2.jis
-share/doc/im/imput
-share/doc/im/imput.jis
-@dirrm lib/im
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/IM
+share/doc/im/00usage
+share/doc/im/man/00readme
+share/doc/im/man/imali.jis
+share/doc/im/man/imcat.jis
+share/doc/im/man/imcd.jis
+share/doc/im/man/imclean.jis
+share/doc/im/man/imget.jis
+share/doc/im/man/imhist.jis
+share/doc/im/man/imjoin.jis
+share/doc/im/man/immv.jis
+share/doc/im/man/impack.jis
+share/doc/im/man/imput
+share/doc/im/man/imput.jis
+share/doc/im/man/imrm.jis
+share/doc/im/man/imsetup.jis
+share/doc/im/man/imsort.jis
+share/doc/im/man/imstore.jis
+share/doc/im/man/imtar.jis
+@dirrm lib/IM
+@dirrm share/doc/im/man
@dirrm share/doc/im
@dirrm share/examples/im