aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-06-09 06:50:02 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-06-09 06:50:02 +0000
commit1f150690e1d586147f3e4b204d5093515cda1868 (patch)
tree63530a58f4ea7dd61689a19c1235464c2545e1a1
parent4b0a5b46723a23688486990078fa82bf94c25a78 (diff)
downloadports-1f150690e1d586147f3e4b204d5093515cda1868.tar.gz
ports-1f150690e1d586147f3e4b204d5093515cda1868.zip
Notes
-rw-r--r--devel/p5-Alzabo-GUI-Mason/Makefile6
-rw-r--r--devel/p5-Alzabo/Makefile8
-rw-r--r--devel/p5-Data-ObjectDriver/Makefile12
-rw-r--r--devel/p5-DateTime-Calendar-Julian/Makefile2
-rw-r--r--devel/p5-DateTime-Calendar-Pataphysical/Makefile2
-rw-r--r--devel/p5-DateTime-Format-IBeat/Makefile2
-rw-r--r--devel/p5-DateTime-Format-Mail/Makefile2
-rw-r--r--devel/p5-DateTime-Format-Roman/Makefile4
-rw-r--r--devel/p5-DateTime-TimeZone-LMT/Makefile2
-rw-r--r--devel/p5-Log-TraceMessages/Makefile2
-rw-r--r--devel/p5-MooseX-IOC/Makefile10
-rw-r--r--devel/p5-POE-Component-Cron/Makefile18
-rw-r--r--devel/p5-TheSchwartz-Simple/Makefile2
-rw-r--r--devel/p5-Tie-DB_File-SplitHash/Makefile2
-rw-r--r--devel/p5-Yada-Yada-Yada/Makefile2
15 files changed, 38 insertions, 38 deletions
diff --git a/devel/p5-Alzabo-GUI-Mason/Makefile b/devel/p5-Alzabo-GUI-Mason/Makefile
index e77bc0adc424..c0e0599e19a5 100644
--- a/devel/p5-Alzabo-GUI-Mason/Makefile
+++ b/devel/p5-Alzabo-GUI-Mason/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A GUI for Alzabo using Mason
-BUILD_DEPENDS= ${SITE_PERL}/Alzabo.pm:${PORTSDIR}/devel/p5-Alzabo \
- ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
- ${SITE_PERL}/HTTP/BrowserDetect.pm:${PORTSDIR}/www/p5-HTTP-BrowserDetect
+BUILD_DEPENDS= p5-Alzabo>=0:${PORTSDIR}/devel/p5-Alzabo \
+ p5-HTML-Mason>=0:${PORTSDIR}/www/p5-HTML-Mason \
+ p5-HTTP-BrowserDetect>=0:${PORTSDIR}/www/p5-HTTP-BrowserDetect
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Alzabo/Makefile b/devel/p5-Alzabo/Makefile
index 09f0454ab426..6ffb13eb1e3a 100644
--- a/devel/p5-Alzabo/Makefile
+++ b/devel/p5-Alzabo/Makefile
@@ -14,11 +14,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A data modelling tool and RDBMS-OO mapper
-BUILD_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
- ${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util \
+BUILD_DEPENDS= p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-Class-Factory-Util>=0:${PORTSDIR}/devel/p5-Class-Factory-Util \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+ p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Data-ObjectDriver/Makefile b/devel/p5-Data-ObjectDriver/Makefile
index 5c53a44b7b48..50202888a79d 100644
--- a/devel/p5-Data-ObjectDriver/Makefile
+++ b/devel/p5-Data-ObjectDriver/Makefile
@@ -14,12 +14,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple, transparent data interface, with caching
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
- ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/Text/SimpleTable.pm:${PORTSDIR}/textproc/p5-Text-SimpleTable
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Trigger>=0:${PORTSDIR}/devel/p5-Class-Trigger \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Text-SimpleTable>=0:${PORTSDIR}/textproc/p5-Text-SimpleTable
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Calendar-Julian/Makefile b/devel/p5-DateTime-Calendar-Julian/Makefile
index e1a945ba8cf3..d7048ca8e0e1 100644
--- a/devel/p5-DateTime-Calendar-Julian/Makefile
+++ b/devel/p5-DateTime-Calendar-Julian/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Dates in the Julian calendar
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Calendar-Pataphysical/Makefile b/devel/p5-DateTime-Calendar-Pataphysical/Makefile
index 6bf9329fe98b..a35588561590 100644
--- a/devel/p5-DateTime-Calendar-Pataphysical/Makefile
+++ b/devel/p5-DateTime-Calendar-Pataphysical/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Dates in the pataphysical calendar
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Format-IBeat/Makefile b/devel/p5-DateTime-Format-IBeat/Makefile
index d595e8c3b2aa..60b58e43f1a0 100644
--- a/devel/p5-DateTime-Format-IBeat/Makefile
+++ b/devel/p5-DateTime-Format-IBeat/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Format times in .beat notation
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Format-Mail/Makefile b/devel/p5-DateTime-Format-Mail/Makefile
index 89ba27933f7a..3a661a8b1c5f 100644
--- a/devel/p5-DateTime-Format-Mail/Makefile
+++ b/devel/p5-DateTime-Format-Mail/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Convert between DateTime and RFC2822/822 formats
RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Format-Roman/Makefile b/devel/p5-DateTime-Format-Roman/Makefile
index ce23962e796d..b9108f90888c 100644
--- a/devel/p5-DateTime-Format-Roman/Makefile
+++ b/devel/p5-DateTime-Format-Roman/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Roman day numbering for DateTime objects
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/Roman.pm:${PORTSDIR}/math/p5-Roman
+RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Roman>=0:${PORTSDIR}/math/p5-Roman
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-TimeZone-LMT/Makefile b/devel/p5-DateTime-TimeZone-LMT/Makefile
index 3abeb75f6f82..b61d5f7d8b8d 100644
--- a/devel/p5-DateTime-TimeZone-LMT/Makefile
+++ b/devel/p5-DateTime-TimeZone-LMT/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Local Mean Time time zone for DateTime
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Log-TraceMessages/Makefile b/devel/p5-Log-TraceMessages/Makefile
index a9fb332086bd..b16b55875b34 100644
--- a/devel/p5-Log-TraceMessages/Makefile
+++ b/devel/p5-Log-TraceMessages/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for trace messages used in debugging
-BUILD_DEPENDS= ${SITE_PERL}/HTML/FromText.pm:${PORTSDIR}/www/p5-HTML-FromText
+BUILD_DEPENDS= p5-HTML-FromText>=0:${PORTSDIR}/www/p5-HTML-FromText
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-MooseX-IOC/Makefile b/devel/p5-MooseX-IOC/Makefile
index 57ffa43e649a..d45f7c019023 100644
--- a/devel/p5-MooseX-IOC/Makefile
+++ b/devel/p5-MooseX-IOC/Makefile
@@ -15,11 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Moose attributes with IOC integration
-BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/IOC.pm:${PORTSDIR}/devel/p5-IOC \
- ${SITE_PERL}/${PERL_ARCH}/Moose.pm:${PORTSDIR}/devel/p5-Moose
-RUN_DEPENDS= ${SITE_PERL}/IOC.pm:${PORTSDIR}/devel/p5-IOC \
- ${SITE_PERL}/${PERL_ARCH}/Moose.pm:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-IOC>=0:${PORTSDIR}/devel/p5-IOC \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
+RUN_DEPENDS= p5-IOC>=0:${PORTSDIR}/devel/p5-IOC \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
PERL_CONFIGURE= yes
diff --git a/devel/p5-POE-Component-Cron/Makefile b/devel/p5-POE-Component-Cron/Makefile
index 681f352cf83f..a96b4b4277ef 100644
--- a/devel/p5-POE-Component-Cron/Makefile
+++ b/devel/p5-POE-Component-Cron/Makefile
@@ -14,15 +14,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Schedule POE Events using a cron spec
-BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/Component/Schedule.pm:${PORTSDIR}/devel/p5-POE-Component-Schedule \
- ${SITE_PERL}/DateTime/Event/Random.pm:${PORTSDIR}/devel/p5-DateTime-Event-Random \
- ${SITE_PERL}/DateTime/Event/Cron.pm:${PORTSDIR}/devel/p5-DateTime-Event-Cron
-RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/Component/Schedule.pm:${PORTSDIR}/devel/p5-POE-Component-Schedule \
- ${SITE_PERL}/DateTime/Event/Random.pm:${PORTSDIR}/devel/p5-DateTime-Event-Random \
- ${SITE_PERL}/DateTime/Event/Cron.pm:${PORTSDIR}/devel/p5-DateTime-Event-Cron
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-Schedule>=0:${PORTSDIR}/devel/p5-POE-Component-Schedule \
+ p5-DateTime-Event-Random>=0:${PORTSDIR}/devel/p5-DateTime-Event-Random \
+ p5-DateTime-Event-Cron>=0:${PORTSDIR}/devel/p5-DateTime-Event-Cron
+RUN_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-Schedule>=0:${PORTSDIR}/devel/p5-POE-Component-Schedule \
+ p5-DateTime-Event-Random>=0:${PORTSDIR}/devel/p5-DateTime-Event-Random \
+ p5-DateTime-Event-Cron>=0:${PORTSDIR}/devel/p5-DateTime-Event-Cron
PERL_CONFIGURE= yes
diff --git a/devel/p5-TheSchwartz-Simple/Makefile b/devel/p5-TheSchwartz-Simple/Makefile
index feeae129116d..750313f428f0 100644
--- a/devel/p5-TheSchwartz-Simple/Makefile
+++ b/devel/p5-TheSchwartz-Simple/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= DBI only job dispatcher for TheSchwartz
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Tie-DB_File-SplitHash/Makefile b/devel/p5-Tie-DB_File-SplitHash/Makefile
index 72241c45ff2f..dcd1b69f2543 100644
--- a/devel/p5-Tie-DB_File-SplitHash/Makefile
+++ b/devel/p5-Tie-DB_File-SplitHash/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A wrapper around the DB_File Berkeley database system
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Yada-Yada-Yada/Makefile b/devel/p5-Yada-Yada-Yada/Makefile
index 8ba85003c0dd..49308dd2f120 100644
--- a/devel/p5-Yada-Yada-Yada/Makefile
+++ b/devel/p5-Yada-Yada-Yada/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Adds a Yada-Yada-Yada operator (...) to Perl 5
-BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple
+BUILD_DEPENDS= p5-Filter-Simple>=0:${PORTSDIR}/textproc/p5-Filter-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Yada::Yada::Yada.3