aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-11-15 10:29:37 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-11-15 10:29:37 +0000
commit2046f46836ee9f785d22c87d1d2a078303edecc0 (patch)
tree57134fe9256f6629b425ef908d88e2b9e51b6988
parent39d5fa4087321acfe0116b35b81f6da1aa1cdaa7 (diff)
downloadports-2046f46836ee9f785d22c87d1d2a078303edecc0.tar.gz
ports-2046f46836ee9f785d22c87d1d2a078303edecc0.zip
Notes
-rw-r--r--security/l0phtcrack/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/security/l0phtcrack/Makefile b/security/l0phtcrack/Makefile
index c866f7bd08f8..df5e1ae773e2 100644
--- a/security/l0phtcrack/Makefile
+++ b/security/l0phtcrack/Makefile
@@ -21,7 +21,10 @@ USE_PERL5= build
USE_ZIP= yes
USE_DOS2UNIX= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-extract:
${RM} ${WRKDIR}/*exe
${REINPLACE_CMD} -i '' -e 's|ommited|omitted|' ${WRKDIR}/util.c
@@ -31,7 +34,7 @@ do-build:
pre-install:
${ECHO_CMD} bin/lc_CLI > ${PLIST}
-.if !defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
for i in `${FIND} ${WRKDIR} -name '*txt'`; \
do ${ECHO_CMD} ${DOCDIR}/`${BASENAME} $${i}` >> ${PLIST}; \
done
@@ -39,10 +42,10 @@ pre-install:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lc_CLI ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/${DOCDIR}
- cd ${WRKSRC} && ${PAX} -r -w *txt ${PREFIX}/${DOCDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/lc_CLI ${STAGEDIR}${PREFIX}/bin
+.if ! ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${DOCDIR}
+ cd ${WRKSRC} && ${PAX} -r -w *txt ${STAGEDIR}${PREFIX}/${DOCDIR}
.endif
.include <bsd.port.mk>