aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-04-20 20:09:11 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-04-24 21:21:15 +0000
commit208fb31e968ef9f85102dcee9ce9c4679a95c403 (patch)
tree0ef7f963a0db570bac3c086a1adf3db84fe2808f
parent966c4864a8e27389b748ad7d79b6172f14a302be (diff)
downloadports-208fb31e968ef9f85102dcee9ce9c4679a95c403.tar.gz
ports-208fb31e968ef9f85102dcee9ce9c4679a95c403.zip
security/openssl31-quictls: correctly detect architecture on powerpc64* / riscv64
-rw-r--r--security/openssl31-quictls/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/security/openssl31-quictls/Makefile b/security/openssl31-quictls/Makefile
index 4f829d9afa6e..0952ba0f9da9 100644
--- a/security/openssl31-quictls/Makefile
+++ b/security/openssl31-quictls/Makefile
@@ -1,7 +1,7 @@
PORTNAME= openssl
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 3.1.5
-PORTREVISION= 2
+PORTREVISION= 3
DISTVERSIONSUFFIX= -quic1
CATEGORIES= security devel
PKGNAMESUFFIX= 31-quictls
@@ -141,6 +141,16 @@ SHLIBS= lib/engines-${OPENSSL_SHLIBVER}/loader_attic.so
PORTSCOUT= limit=^3\.1\.
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+CONFIGURE_ARGS+= BSD-ppc64
+.elif ${ARCH} == powerpc64le
+CONFIGURE_ARGS+= BSD-ppc64le
+.elif ${ARCH} == riscv64
+CONFIGURE_ARGS+= BSD-riscv64
+.endif
+
.include <bsd.port.pre.mk>
.if ${PREFIX} == /usr
IGNORE= the OpenSSL port can not be installed over the base version