aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-16 14:31:54 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-16 14:31:54 +0000
commit217ed45bf94757c34f79783b7402354783903558 (patch)
treeda504f9b49b4e741a0dee923eab380ffe34bef30
parent46d8696533b8961d0b96df54b52cef8db01b7890 (diff)
downloadports-217ed45bf94757c34f79783b7402354783903558.tar.gz
ports-217ed45bf94757c34f79783b7402354783903558.zip
- Update MASTER_SITES and WWW: line of pkg/DESCR
- Support CC/CFLAGS/PREFIX/LOCALBASE/X11BASE/etc properly PR: 19757 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=30703
-rw-r--r--games/biorythm/Makefile30
-rw-r--r--games/biorythm/files/patch-aa38
-rw-r--r--games/biorythm/pkg-descr2
-rw-r--r--games/libshhcards/Makefile45
-rw-r--r--games/libshhcards/files/patch-aa76
-rw-r--r--games/libshhcards/pkg-descr2
-rw-r--r--games/libshhcards/pkg-plist2
-rw-r--r--games/sol/Makefile28
-rw-r--r--games/sol/files/patch-aa43
-rw-r--r--games/sol/pkg-descr2
10 files changed, 156 insertions, 112 deletions
diff --git a/games/biorythm/Makefile b/games/biorythm/Makefile
index b14adb6d1981..7012e111e147 100644
--- a/games/biorythm/Makefile
+++ b/games/biorythm/Makefile
@@ -5,31 +5,25 @@
# $FreeBSD$
#
-PORTNAME= biorythm
-PORTVERSION= 1.1.1
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://home.sol.no/~sverrehu/pub-unix/files/
-MASTER_SITE_SUBDIR= games/amusements
+PORTNAME= biorythm
+PORTVERSION= 1.1.1
+CATEGORIES= games
+MASTER_SITES= http://shh.thathost.com/pub-unix/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= shhmsg.1:${PORTSDIR}/devel/libshhmsg \
- shhopt.1:${PORTSDIR}/devel/libshhopt
+LIB_DEPENDS= shhmsg.1:${PORTSDIR}/devel/libshhmsg \
+ shhopt.1:${PORTSDIR}/devel/libshhopt
-USE_GMAKE= yes
+USE_GMAKE= yes
-MAN6= biorythm.6
-
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/biorythm ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/biorythm.6 ${PREFIX}/man/man6
+MAN6= biorythm.6
post-install:
-.if !defined (NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/biorythm
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/biorythm
.for file in CREDITS ChangeLog README
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/biorythm
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/biorythm
.endfor
.endif
diff --git a/games/biorythm/files/patch-aa b/games/biorythm/files/patch-aa
index dc818b4b8fb2..ad77bb6649d3 100644
--- a/games/biorythm/files/patch-aa
+++ b/games/biorythm/files/patch-aa
@@ -1,28 +1,40 @@
---- Makefile Sun Jul 5 19:55:11 1998
-+++ /home/andy/tmp/wrk/Makefile Tue May 4 10:55:11 1999
-@@ -11,10 +11,10 @@
+--- Makefile.orig Mon Jul 6 00:55:11 1998
++++ Makefile Tue Jul 4 21:47:21 2000
+@@ -11,15 +11,15 @@
###########################################################################
# where are shhmsg and shhopt?
-INCDIR = -I/usr/local/include
-LIBDIR = -L/usr/local/lib
-+INCDIR = -I$(LOCALBASE)/include
-+LIBDIR = -L$(LOCALBASE)/lib
++INCDIR = -I${LOCALBASE}/include
++LIBDIR = -L${LOCALBASE}/lib
-INSTBASEDIR = /usr/local
-+INSTBASEDIR = $(PREFIX)
- INSTBINDIR = $(INSTBASEDIR)/games
+-INSTBINDIR = $(INSTBASEDIR)/games
++INSTBASEDIR = ${PREFIX}
++INSTBINDIR = $(INSTBASEDIR)/bin
INSTMANDIR = $(INSTBASEDIR)/man/man6
- INSTALL = install -m 644
-@@ -27,9 +27,9 @@
+-INSTALL = install -m 644
+-INSTALLPROG = install -s -m 755
+-MKDIRP = install -d -m 755
++INSTALL = ${BSD_INSTALL_DATA}
++INSTALLPROG = ${BSD_INSTALL_PROGRAM}
++MKDIRP = mkdir -p
+
+ DEFINES = -DVERSION=\"$(VERSION)\" \
+ "-DCOMPILED_DATE=\"$(COMPILED_DATE)\"" \
+@@ -27,11 +27,11 @@
###########################################################################
-CC = gcc
+#CC = gcc
--OPTIM = -O2
-+OPTIM = $(CFLAGS)
- CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
- LDOPT = -s $(LIBDIR) $(LDFLAGS)
+ OPTIM = -O2
+-CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
+-LDOPT = -s $(LIBDIR) $(LDFLAGS)
++CCOPT = $(INCDIR) $(DEFINES) $(CFLAGS)
++LDOPT = $(LIBDIR) $(LDFLAGS)
+ LIBS = -lshhmsg -lshhopt -lm
+ OBJS = $(PROG).o date.o
diff --git a/games/biorythm/pkg-descr b/games/biorythm/pkg-descr
index 5fb94d9ee9e3..6d9a112028cf 100644
--- a/games/biorythm/pkg-descr
+++ b/games/biorythm/pkg-descr
@@ -12,4 +12,4 @@ curves. This may be overridden by command line options.
The author has no idea how to interpret the plot, so please don't ask
him about it.
-WWW: http://home.sol.no/~sverrehu/pub-unix/
+WWW: http://shh.thathost.com/pub-unix/#biorythm
diff --git a/games/libshhcards/Makefile b/games/libshhcards/Makefile
index b43ccaf9f37e..0b2f33962309 100644
--- a/games/libshhcards/Makefile
+++ b/games/libshhcards/Makefile
@@ -5,42 +5,25 @@
# $FreeBSD$
#
-PORTNAME= libshhcards
-PORTVERSION= 1.0.4
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://home.sol.no/~sverrehu/pub-unix/files/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= libs/ui mph
-DISTNAME= shhcards-${PORTVERSION}
+PORTNAME= libshhcards
+PORTVERSION= 1.0.4
+CATEGORIES= games
+MASTER_SITES= http://shh.thathost.com/pub-unix/files/
+DISTNAME= shhcards-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
-USE_GMAKE= yes
-USE_X_PREFIX= yes
-INSTALLS_SHLIB= yes
-SOLIB= libshhcards.so
-
-.include <bsd.port.pre.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-SOVERSION= 1
-.else
-SOVERSION= 1.1
-.endif
-
-do-install:
- @ ${INSTALL_DATA} ${WRKSRC}/shhcards.h ${PREFIX}/include
- @ ${INSTALL_DATA} ${WRKSRC}/${SOLIB}.${SOVERSION} ${PREFIX}/lib
- @ ${LN} -sf ${SOLIB}.${SOVERSION} ${PREFIX}/lib/${SOLIB}
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
post-install:
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/libshhcards
- @ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/libshhcards
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/libshhcards
+ @${MKDIR} ${PREFIX}/share/doc/libshhcards
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/libshhcards
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/libshhcards
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/libshhcards/files/patch-aa b/games/libshhcards/files/patch-aa
index 898cd23991b5..098d95429562 100644
--- a/games/libshhcards/files/patch-aa
+++ b/games/libshhcards/files/patch-aa
@@ -1,19 +1,6 @@
---- Makefile.orig Sun Jul 5 11:52:26 1998
-+++ Makefile Sun May 30 21:07:36 1999
-@@ -1,14 +1,17 @@
- # $Id: Makefile,v 1.4 1998/07/05 16:52:26 sverrehu Exp $
- DIST = shhcards
- VERMAJ = 1
--VERMIN = 0
--VERPAT = 4
--VERSION = $(VERMAJ).$(VERMIN).$(VERPAT)
-+VERMIN = 1
-+ifeq ($(PORTOBJFORMAT),elf)
-+VERSION = $(VERMAJ)
-+else
-+VERSION = $(VERMAJ).$(VERMIN)
-+endif
-
+--- Makefile.orig Mon Jul 6 01:52:26 1998
++++ Makefile Tue Jul 4 21:38:46 2000
+@@ -8,7 +8,7 @@
###########################################################################
# Define SHARED as 1 for Linux shared ELF library
@@ -22,18 +9,36 @@
ifeq ($(SHARED),1)
LIBTARGET = lib$(DIST).so.$(VERSION)
-@@ -28,8 +31,8 @@
- INSTALL = install -m 644
- MKDIRP = install -d -m 755
+@@ -22,13 +22,13 @@
+ LIBHEAD = $(DIST).h
+ TARGETS = $(LIBTARGET)
+
+-INSTBASEDIR = /usr/local
++INSTBASEDIR = ${PREFIX}
+ INSTLIBDIR = $(INSTBASEDIR)/lib
+ INSTINCDIR = $(INSTBASEDIR)/include
+-INSTALL = install -m 644
+-MKDIRP = install -d -m 755
++INSTALL = ${BSD_INSTALL_DATA}
++MKDIRP = mkdir -p
-CC = gcc
--OPTIM = -O2
+#CC = gcc
-+OPTIM = $(CFLAGS)
+ OPTIM = -O2
###########################################################################
+@@ -36,8 +36,8 @@
+ # Where are Xpm and X11?
-@@ -68,10 +71,10 @@
+ # GNU/Linux at home
+-INCDIR = -I. -I/usr/local/include -I/usr/X11R6/include
+-LIBDIR = -L. -L/usr/local/lib -L/usr/X11R6/lib -L/usr/local/lib/X11
++INCDIR = -I. -I${X11BASE}/include
++LIBDIR = -L. -L${X11BASE}/lib
+ EXTRA_LD_OPT =
+ EXTRA_LIBS =
+
+@@ -68,14 +68,14 @@
endif
# Alpha at USIT
@@ -48,16 +53,31 @@
###########################################################################
-@@ -87,7 +90,11 @@
+-CCOPT = -Wall $(OPTIM) $(INCDIR) $(CFLAGS)
++CCOPT = $(INCDIR) $(CFLAGS)
+ LDOPT = $(LIBDIR) $(LDFLAGS)
+
+ # Object files to store in the library
+@@ -87,7 +87,7 @@
$(LIBTARGET): $(LIBOBJS)
ifeq ($(SHARED),1)
- $(CC) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGET) $(LIBOBJS)
-+ifeq ($(PORTOBJFORMAT),elf)
-+ $(CC) -shared -Wl,-soname,$(LIBTARGET) -o $(LIBTARGET) $(LIBOBJS)
-+else
-+ $(CC) -shared -o $(LIBTARGET) $(LIBOBJS)
-+endif
++ $(CC) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGETSOMAJ) $(LIBOBJS)
else
ar rcs $(LIBTARGET) $(LIBOBJS)
endif
+@@ -106,12 +106,10 @@
+
+ install: $(LIBTARGET)
+ $(MKDIRP) $(INSTLIBDIR) $(INSTINCDIR)
+- $(INSTALL) $(LIBTARGET) $(INSTLIBDIR)
++ $(INSTALL) $(LIBTARGETSOMAJ) $(INSTLIBDIR)
+ $(INSTALL) $(LIBHEAD) $(INSTINCDIR)
+ ifeq ($(SHARED),1)
+- ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSOMAJ)
+ ln -sf $(LIBTARGETSOMAJ) $(INSTLIBDIR)/$(LIBTARGETSO)
+- echo "If you use GNU/Linux, remember to run ldconfig"
+ endif
+
+ depend dep:
diff --git a/games/libshhcards/pkg-descr b/games/libshhcards/pkg-descr
index bad9f3ddf99c..7c53f15445ae 100644
--- a/games/libshhcards/pkg-descr
+++ b/games/libshhcards/pkg-descr
@@ -1,3 +1,5 @@
shhcards is a library for displaying game cards on X11.
It provides pixmaps for card games, and functions for
using the cards in X11 programs.
+
+WWW: http://shh.thathost.com/pub-unix/#shhcards
diff --git a/games/libshhcards/pkg-plist b/games/libshhcards/pkg-plist
index c82eff08934c..2664179c4faf 100644
--- a/games/libshhcards/pkg-plist
+++ b/games/libshhcards/pkg-plist
@@ -1,6 +1,6 @@
include/shhcards.h
lib/libshhcards.so
-lib/libshhcards.so.1.1
+lib/libshhcards.so.1
share/doc/libshhcards/CREDITS
share/doc/libshhcards/README
@dirrm share/doc/libshhcards
diff --git a/games/sol/Makefile b/games/sol/Makefile
index ed97790c8f1e..863aa6a580c8 100644
--- a/games/sol/Makefile
+++ b/games/sol/Makefile
@@ -8,7 +8,7 @@
PORTNAME= sol
PORTVERSION= 1.0.6
CATEGORIES= games
-MASTER_SITES= http://home.sol.no/~sverrehu/pub-unix/files/
+MASTER_SITES= http://shh.thathost.com/pub-unix/files/
MAINTAINER= ports@FreeBSD.org
@@ -24,17 +24,19 @@ USE_X_PREFIX= yes
MAN6= sol.6
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/sol
- @ ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
- @ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
- @ ${MKDIR} ${PREFIX}/share/doc/sol
- @ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
- @ ${CHOWN} root:games ${PREFIX}/bin/sol
- @ ${CHOWN} root:games ${PREFIX}/share/sol/sol.score
- @ ${CHMOD} 2755 ${PREFIX}/bin/sol
- @ ${CHMOD} 770 ${PREFIX}/share/sol
- @ ${CHMOD} 660 ${PREFIX}/share/sol/sol.score
+ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
+ @${MKDIR} ${PREFIX}/share/sol
+ ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
+ @${CHOWN} root:games ${PREFIX}/bin/sol
+ @${CHOWN} root:games ${PREFIX}/share/sol/sol.score
+ @${CHMOD} 2755 ${PREFIX}/bin/sol
+ @${CHMOD} 770 ${PREFIX}/share/sol
+ @${CHMOD} 660 ${PREFIX}/share/sol/sol.score
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
+.endif
.include <bsd.port.mk>
diff --git a/games/sol/files/patch-aa b/games/sol/files/patch-aa
index 1b870204ad4c..9af1c970551b 100644
--- a/games/sol/files/patch-aa
+++ b/games/sol/files/patch-aa
@@ -1,6 +1,18 @@
---- Makefile.orig Sun Jul 5 03:30:26 1998
-+++ Makefile Sun May 30 21:12:31 1999
-@@ -53,16 +53,16 @@
+--- Makefile.orig Sun Jul 5 17:30:26 1998
++++ Makefile Tue Jul 4 21:59:11 2000
+@@ -13,9 +13,8 @@
+ # Where are shhmsg, shhopt, xalloc, shhcards, Xpm and X11?
+
+ # GNU/Linux at home
+-INCDIR = -I/usr/local/include -I/usr/X11R6/include \
+- -I/usr/local/include/X11
+-LIBDIR = -L/usr/local/lib -L/usr/X11R6/lib -L/usr/local/lib/X11
++INCDIR = -I${LOCALBASE}/include -I${X11BASE}/include
++LIBDIR = -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+ # Irix at Ifi
+ ifeq ($(HOSTTYPE),sgi)
+@@ -53,18 +52,18 @@
endif
# DEC Alpha at USIT
@@ -19,7 +31,26 @@
# Where do you want to install the program and the highscore file?
-INSTLIBDIR = /var/local/lib/games
-+INSTLIBDIR = /usr/X11R6/share/sol
- INSTBINDIR = /usr/local/games
- INSTMANDIR = /usr/local/man/man6
+-INSTBINDIR = /usr/local/games
+-INSTMANDIR = /usr/local/man/man6
++INSTLIBDIR = ${PREFIX}/share/sol
++INSTBINDIR = ${PREFIX}/bin
++INSTMANDIR = ${PREFIX}/man/man6
#INSTLIBDIR = /hom/sverrehu/lib
+ #INSTBINDIR = /hom/sverrehu/bin/$$HOSTTYPE
+ #INSTMANDIR = /hom/sverrehu/man/man6
+@@ -84,11 +83,11 @@
+
+ ###########################################################################
+
+-CC = gcc
++#CC = gcc
+
+ OPTIM = -s -O2
+-CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
+-LDOPT = -s $(LIBDIR) $(LDFLAGS) $(EXTRA_LD_OPT)
++CCOPT = $(INCDIR) $(DEFINES) $(CFLAGS)
++LDOPT = $(LIBDIR) $(LDFLAGS) $(EXTRA_LD_OPT)
+
+ LIBS = -lshhopt -lshhmsg -lxalloc -lshhcards \
+ -lXaw -lXt -lXpm -lXext -lXmu -lX11 $(EXTRA_LIBS)
diff --git a/games/sol/pkg-descr b/games/sol/pkg-descr
index 32c246e5dd5e..19404f96baba 100644
--- a/games/sol/pkg-descr
+++ b/games/sol/pkg-descr
@@ -2,4 +2,4 @@ This is a Solitaire card game highly inspired by the one
bundeled with a well known "operating system". Features
a site-wide highscore table.
-WWW: http://home.sol.no/~sverrehu/pub-unix/html/sol.html
+WWW: http://shh.thathost.com/pub-unix/#sol