aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-03-25 01:46:54 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-03-25 01:46:54 +0000
commit219b30185a9edf352eb05e908208f4ef3f8d82a9 (patch)
tree5cc43b73efa79988b1c493c377291aa44e93d27f
parent972cb30fb7d3b2f696db2f7c450b8d1db702567c (diff)
downloadports-219b30185a9edf352eb05e908208f4ef3f8d82a9.tar.gz
ports-219b30185a9edf352eb05e908208f4ef3f8d82a9.zip
Notes
-rw-r--r--net/openldap21-server/Makefile6
-rw-r--r--net/openldap21-server/files/patch-build::ltmain.sh33
-rw-r--r--net/openldap22-server/Makefile11
-rw-r--r--net/openldap22-server/files/patch-build::ltmain.sh32
-rw-r--r--net/openldap23-server/Makefile11
-rw-r--r--net/openldap23-server/files/patch-build::ltmain.sh32
-rw-r--r--net/openldap24-server/Makefile11
-rw-r--r--net/openldap24-server/files/patch-build::ltmain.sh32
-rw-r--r--security/clamav/Makefile5
-rw-r--r--security/clamav/files/patch-ltmain.sh39
10 files changed, 182 insertions, 30 deletions
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index ccab5660c961..44981acd628d 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -62,7 +62,7 @@ CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[02-9].*
USE_OPENSSL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
@@ -245,12 +245,10 @@ post-patch:
${WRKSRC}/servers/slapd/slapd.conf
pre-configure:
- @if [ -n "`${PKG_INFO} -xI '^bind\(84\)\{0,1\}-base-8\.'`" ]; then \
+ @if [ -n "`${PKG_INFO} -xI '^bind\(84\)\{0,1\}-base-8\.' 2>/dev/null`" ]; then \
${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
${FALSE}; \
fi
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
- ${WRKSRC}/configure
post-build:
.for script in slapd slurpd
diff --git a/net/openldap21-server/files/patch-build::ltmain.sh b/net/openldap21-server/files/patch-build::ltmain.sh
new file mode 100644
index 000000000000..53bc16473d95
--- /dev/null
+++ b/net/openldap21-server/files/patch-build::ltmain.sh
@@ -0,0 +1,33 @@
+--- build/ltmain.sh.orig Mon Feb 10 20:24:24 2003
++++ build/ltmain.sh Thu Mar 25 02:17:45 2004
+@@ -1066,7 +1066,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -4286,10 +4286,17 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
+- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+- instname="$dir/$name"i
+- $show "$install_prog $instname $destdir/$name"
+- $run eval "$install_prog $instname $destdir/$name" || exit $?
++ case $host in
++ *-*-freebsd*)
++ # Do not install the useless pseudo-library
++ ;;
++ *)
++ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
++ instname="$dir/$name"i
++ $show "$install_prog $instname $destdir/$name"
++ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ ;;
++ esac
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 963298af4634..3739c5834177 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -62,7 +62,7 @@ CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[013-9].*
USE_OPENSSL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
@@ -121,14 +121,14 @@ CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
--enable-null \
--enable-monitor
-WITH_BDB_VER?= 42
-
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --with-ldbm-api=bcompat \
--disable-bdb
.else
CONFIGURE_ARGS+= --with-ldbm-api=berkeley
+WITH_BDB_VER?= 42
+
.if ${WITH_BDB_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
CONFIGURE_ARGS+= --enable-bdb
@@ -182,7 +182,8 @@ CONFIGURE_ARGS+= --enable-sql
.if defined(WITH_SLAPI)
LIB_DEPENDS+= ltdl.4:${PORTSDIR}/devel/libltdl
-CONFIGURE_ARGS+= --enable-slapi
+CONFIGURE_ARGS+= --enable-slapi \
+ --enable-modules
PLIST_SUB+= SLAPI=""
INSTALLS_SHLIB= yes
.else
@@ -261,8 +262,6 @@ pre-configure:
${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
${FALSE}; \
fi
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
- ${WRKSRC}/configure
post-build:
.for script in slapd slurpd
diff --git a/net/openldap22-server/files/patch-build::ltmain.sh b/net/openldap22-server/files/patch-build::ltmain.sh
new file mode 100644
index 000000000000..7865cad95d9e
--- /dev/null
+++ b/net/openldap22-server/files/patch-build::ltmain.sh
@@ -0,0 +1,32 @@
+--- build/ltmain.sh.orig Thu Jan 1 19:16:25 2004
++++ build/ltmain.sh Thu Mar 25 02:19:32 2004
+@@ -1076,7 +1076,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -4296,10 +4296,16 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
+- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+- instname="$dir/$name"i
+- $show "$install_prog $instname $destdir/$name"
+- $run eval "$install_prog $instname $destdir/$name" || exit $?
++ + case $host in
++ *-*-freebsd*)
++ # Do not install the useless pseudo-library
++ ;;
++ *)
++ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
++ instname="$dir/$name"i
++ $show "$install_prog $instname $destdir/$name"
++ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ esac
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 963298af4634..3739c5834177 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -62,7 +62,7 @@ CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[013-9].*
USE_OPENSSL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
@@ -121,14 +121,14 @@ CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
--enable-null \
--enable-monitor
-WITH_BDB_VER?= 42
-
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --with-ldbm-api=bcompat \
--disable-bdb
.else
CONFIGURE_ARGS+= --with-ldbm-api=berkeley
+WITH_BDB_VER?= 42
+
.if ${WITH_BDB_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
CONFIGURE_ARGS+= --enable-bdb
@@ -182,7 +182,8 @@ CONFIGURE_ARGS+= --enable-sql
.if defined(WITH_SLAPI)
LIB_DEPENDS+= ltdl.4:${PORTSDIR}/devel/libltdl
-CONFIGURE_ARGS+= --enable-slapi
+CONFIGURE_ARGS+= --enable-slapi \
+ --enable-modules
PLIST_SUB+= SLAPI=""
INSTALLS_SHLIB= yes
.else
@@ -261,8 +262,6 @@ pre-configure:
${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
${FALSE}; \
fi
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
- ${WRKSRC}/configure
post-build:
.for script in slapd slurpd
diff --git a/net/openldap23-server/files/patch-build::ltmain.sh b/net/openldap23-server/files/patch-build::ltmain.sh
new file mode 100644
index 000000000000..7865cad95d9e
--- /dev/null
+++ b/net/openldap23-server/files/patch-build::ltmain.sh
@@ -0,0 +1,32 @@
+--- build/ltmain.sh.orig Thu Jan 1 19:16:25 2004
++++ build/ltmain.sh Thu Mar 25 02:19:32 2004
+@@ -1076,7 +1076,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -4296,10 +4296,16 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
+- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+- instname="$dir/$name"i
+- $show "$install_prog $instname $destdir/$name"
+- $run eval "$install_prog $instname $destdir/$name" || exit $?
++ + case $host in
++ *-*-freebsd*)
++ # Do not install the useless pseudo-library
++ ;;
++ *)
++ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
++ instname="$dir/$name"i
++ $show "$install_prog $instname $destdir/$name"
++ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ esac
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 963298af4634..3739c5834177 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -62,7 +62,7 @@ CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[013-9].*
USE_OPENSSL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
@@ -121,14 +121,14 @@ CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
--enable-null \
--enable-monitor
-WITH_BDB_VER?= 42
-
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --with-ldbm-api=bcompat \
--disable-bdb
.else
CONFIGURE_ARGS+= --with-ldbm-api=berkeley
+WITH_BDB_VER?= 42
+
.if ${WITH_BDB_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
CONFIGURE_ARGS+= --enable-bdb
@@ -182,7 +182,8 @@ CONFIGURE_ARGS+= --enable-sql
.if defined(WITH_SLAPI)
LIB_DEPENDS+= ltdl.4:${PORTSDIR}/devel/libltdl
-CONFIGURE_ARGS+= --enable-slapi
+CONFIGURE_ARGS+= --enable-slapi \
+ --enable-modules
PLIST_SUB+= SLAPI=""
INSTALLS_SHLIB= yes
.else
@@ -261,8 +262,6 @@ pre-configure:
${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
${FALSE}; \
fi
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
- ${WRKSRC}/configure
post-build:
.for script in slapd slurpd
diff --git a/net/openldap24-server/files/patch-build::ltmain.sh b/net/openldap24-server/files/patch-build::ltmain.sh
new file mode 100644
index 000000000000..7865cad95d9e
--- /dev/null
+++ b/net/openldap24-server/files/patch-build::ltmain.sh
@@ -0,0 +1,32 @@
+--- build/ltmain.sh.orig Thu Jan 1 19:16:25 2004
++++ build/ltmain.sh Thu Mar 25 02:19:32 2004
+@@ -1076,7 +1076,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -4296,10 +4296,16 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
+- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+- instname="$dir/$name"i
+- $show "$install_prog $instname $destdir/$name"
+- $run eval "$install_prog $instname $destdir/$name" || exit $?
++ + case $host in
++ *-*-freebsd*)
++ # Do not install the useless pseudo-library
++ ;;
++ *)
++ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
++ instname="$dir/$name"i
++ $show "$install_prog $instname $destdir/$name"
++ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ esac
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 59695b556c63..1ccc7bd106a1 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -29,7 +29,6 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
PKGINSTALL= ${WRKDIR}/pkg-install
@@ -90,10 +89,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/lib/sendmail|/usr/sbin/sendmail|g' \
${WRKSRC}/clamav-milter/clamav-milter.c
-pre-configure:
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s|\$$(top_builddir)/libtool|${LIBTOOL}|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
post-build:
@${REINPLACE_CMD} ${SED_CONF} ${BUILD_WRKSRC}/etc/clamav.conf
@${SED} ${SED_SCRIPT} ${PKGDIR}/pkg-install >${PKGINSTALL}
diff --git a/security/clamav/files/patch-ltmain.sh b/security/clamav/files/patch-ltmain.sh
index 74d32db0b279..261f3f868cad 100644
--- a/security/clamav/files/patch-ltmain.sh
+++ b/security/clamav/files/patch-ltmain.sh
@@ -1,6 +1,39 @@
---- ltmain.sh.orig Sat Sep 27 05:20:20 2003
-+++ ltmain.sh Sat Sep 27 05:24:02 2003
-@@ -4259,10 +4259,16 @@
+--- ltmain.sh.orig Sun Feb 15 12:44:09 2004
++++ ltmain.sh Thu Mar 25 02:15:25 2004
+@@ -1050,25 +1050,18 @@
+ test "X$arg" = "X-lc" && continue
+ ;;
+ esac
+- # This change is required for -lc_r under FreeBSD / Tomasz Kojm
+- #elif test "X$arg" = "X-lc_r"; then
+- # case $host in
+- #*-*-openbsd* | *-*-freebsd*)
+- # # Do not include libc_r directly, use -pthread flag.
+- # continue
+- # ;;
+- # esac
++ elif test "X$arg" = "X-lc_r"; then
++ case $host in
++ *-*-openbsd* | *-*-freebsd4*)
++ # Do not include libc_r directly, use -pthread flag.
++ continue
++ ;;
++ esac
+ fi
+ deplibs="$deplibs $arg"
+ continue
+ ;;
+
+- # We need this change for old -pthread *BSD style / Tomasz Kojm
+- -pthread)
+- deplibs="$deplibs -pthread"
+- continue
+- ;;
+-
+ -module)
+ module=yes
+ continue
+@@ -4259,10 +4252,16 @@
fi
# Install the pseudo-library for information purposes.