aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-10-28 09:14:20 +0000
committerWen Heping <wen@FreeBSD.org>2011-10-28 09:14:20 +0000
commit21a331381cc6abfd98134b9c2ba60ff073476619 (patch)
treef1583f2c7157316e2487fe8dde2be36531c4e54a
parentb2d07ae343848b7f842153c622ffa13999cbf01a (diff)
downloadports-21a331381cc6abfd98134b9c2ba60ff073476619.tar.gz
ports-21a331381cc6abfd98134b9c2ba60ff073476619.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/py-roman/Makefile22
-rw-r--r--math/py-roman/distinfo2
-rw-r--r--math/py-roman/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 1e7f10f40dd7..219e344a2b4c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -507,6 +507,7 @@
SUBDIR += py-probstat
SUBDIR += py-pybloom
SUBDIR += py-pymc
+ SUBDIR += py-roman
SUBDIR += py-scientific
SUBDIR += py-svgmath
SUBDIR += py-symeig
diff --git a/math/py-roman/Makefile b/math/py-roman/Makefile
new file mode 100644
index 000000000000..bf4c2c41d636
--- /dev/null
+++ b/math/py-roman/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-roman
+# Date created: Oct 28, 2011
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= roman
+PORTVERSION= 1.4.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Integer to Roman numerals converter
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS=easy_install
+
+.include <bsd.port.mk>
diff --git a/math/py-roman/distinfo b/math/py-roman/distinfo
new file mode 100644
index 000000000000..5aaf61b31f9c
--- /dev/null
+++ b/math/py-roman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (roman-1.4.0.tar.gz) = f7bf0304e2a79279cc06d245b2b7f5a3872cddbaa2932db0cbacc12a77e477ec
+SIZE (roman-1.4.0.tar.gz) = 3033
diff --git a/math/py-roman/pkg-descr b/math/py-roman/pkg-descr
new file mode 100644
index 000000000000..3b82c4fe3ad7
--- /dev/null
+++ b/math/py-roman/pkg-descr
@@ -0,0 +1,3 @@
+This is a Integer to Roman numerals converter.
+
+WWW: http://pypi.python.org/pypi/roman/