aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-11 01:14:20 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-11 01:14:20 +0000
commit21b439620286234101f422230c1b82abb15a2baa (patch)
tree77c2fa6fcc8bc884f012e60f8de097b86e66f1ce
parentba056fb3f860240f4ebb8cb9ed8d6669d0009feb (diff)
Notes
-rw-r--r--games/species/Makefile28
-rw-r--r--games/species/files/patch-main.cpp11
2 files changed, 23 insertions, 16 deletions
diff --git a/games/species/Makefile b/games/species/Makefile
index 3beabaa97d0b..a06bcb8a0ec8 100644
--- a/games/species/Makefile
+++ b/games/species/Makefile
@@ -11,32 +11,28 @@ DISTNAME= redcoder
MAINTAINER= ports@FreeBSD.org
COMMENT= Corewars evolver - generates warriors using genetic algorithms
+USE_DOS2UNIX= yes
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= VISITOOL
VISITOOL_DESC= Buil GUI tool for displaying evolution
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MVISITOOL}
-USE_WX= 2.4
-ALL_TARGET= all visitool
-PLIST_SUB+= VISITOOL=""
-.else
-PLIST_SUB+= VISITOOL="@comment "
-.endif
+VISITOOL_USE= WX=2.4
+VISITOOL_ALL_TARGET= all visitool
+
+.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${INSTALL_DATA} koen.* species.ini *.rc ${DATADIR}
- cd ${WRKSRC} && ${CP} -r bench evolver_hill wilfiz ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} koen.* species.ini *.rc ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${CP} -r bench evolver_hill wilfiz ${STAGEDIR}${DATADIR}
.if ${PORT_OPTIONS:MVISITOOL}
- ${INSTALL_PROGRAM} ${WRKSRC}/visitool \
- ${PREFIX}/bin/${PORTNAME}-visitool
+ ${INSTALL_PROGRAM} ${WRKSRC}/visitool ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-visitool
.endif
.include <bsd.port.mk>
diff --git a/games/species/files/patch-main.cpp b/games/species/files/patch-main.cpp
new file mode 100644
index 000000000000..b2f8bcbdd5c8
--- /dev/null
+++ b/games/species/files/patch-main.cpp
@@ -0,0 +1,11 @@
+--- ./main.cpp.orig 2013-11-10 23:14:27.000000000 -0200
++++ ./main.cpp 2013-11-10 23:14:37.000000000 -0200
+@@ -29,7 +29,7 @@
+
+ /***** main program entry point ********************/
+
+-int main(int /*argc*/,char /***args*/) {
++int main(int /*argc*/,char ** /*args*/) {
+ CKingdom kingdom;
+
+ #ifndef _WIN32