aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-12-09 17:29:13 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-12-09 17:29:13 +0000
commit21c7730fc4f2df17508ac3d88f036b6784c07f95 (patch)
treed3d6514e0959ae27b008c2c80a485f75bb439157
parentdb473da67e6eff24a69e13bef1c9ba164b704608 (diff)
downloadports-21c7730fc4f2df17508ac3d88f036b6784c07f95.tar.gz
ports-21c7730fc4f2df17508ac3d88f036b6784c07f95.zip
Notes
-rw-r--r--UPDATING24
-rw-r--r--devel/geany-plugin-debugger/Makefile6
-rw-r--r--devel/geany-plugin-devhelp/Makefile6
-rw-r--r--devel/geany-plugin-geanypy/Makefile5
-rw-r--r--devel/geany-plugin-markdown/Makefile6
-rw-r--r--devel/geany-plugin-multiterm/Makefile5
-rw-r--r--devel/geany-plugin-scope/Makefile5
-rw-r--r--devel/geany-plugin-vc/Makefile6
-rw-r--r--devel/geany-plugin-webhelper/Makefile6
-rw-r--r--devel/geany-plugins/Makefile37
-rw-r--r--devel/geany-plugins/files/Makefile.common37
-rw-r--r--devel/geany-plugins/files/bsd.geany-plugins.mk11
-rw-r--r--devel/geany/Makefile32
-rw-r--r--devel/geany/pkg-plist5
14 files changed, 157 insertions, 34 deletions
diff --git a/UPDATING b/UPDATING
index 176bc21ba725..d9212fb47c4b 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,30 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20181209
+ AFFECTS: users of devel/geany and devel/geany-plugins
+ AUTHOR: madpilot@FreeBSD.org
+
+ Geany and it's plugins port have been moved to gtk3 and a new gtk2
+ flavor has been added. The gtk2 flavor has a -gtk2 suffix added to the
+ package name.
+
+ If you want to stay with the gtk2 version you need to use "pkg install"
+ to install the new gtk2 flavor, pkg will automatically deinstall the
+ gtk3 flavors.
+
+ If using port, to maintain the gtk2 version, you will need to deinstall
+ geany and it's plugins and reinstall specifying the gtk2 flavor.
+
+ Note that the following plugins are not available if using the new
+ gtk3 flavor:
+
+ * geany-plugin-debugger
+ * geany-plugin-devhelp
+ * geany-plugin-geanypy
+ * geany-plugin-multiterm
+ * geany-plugin-scope
+
20181208:
AFFECTS: users of misc/openhab2
AUTHOR: netchild@FreeBSD.org
diff --git a/devel/geany-plugin-debugger/Makefile b/devel/geany-plugin-debugger/Makefile
index a88eb5e04ff8..b6b7fc9e99c9 100644
--- a/devel/geany-plugin-debugger/Makefile
+++ b/devel/geany-plugin-debugger/Makefile
@@ -2,11 +2,17 @@
PORTNAME= geany-plugin-debugger
PORTVERSION= ${GEANY_VER}
+PKGNAMESUFFIX= -gtk2
CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
+LIB_DEPENDS= libgeany.so:devel/geany@gtk2
+
+FLAVORS= # intentionally left empty
+
+USES= gnome
USE_GNOME= vte
USE_XORG= x11 xext
diff --git a/devel/geany-plugin-devhelp/Makefile b/devel/geany-plugin-devhelp/Makefile
index 6dd15d326b1b..4e1bdd7dc583 100644
--- a/devel/geany-plugin-devhelp/Makefile
+++ b/devel/geany-plugin-devhelp/Makefile
@@ -2,6 +2,7 @@
PORTNAME= geany-plugin-devhelp
PORTVERSION= ${GEANY_VER}
+PKGNAMESUFFIX= -gtk2
CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
@@ -9,7 +10,10 @@ COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
LIB_DEPENDS= libwnck-1.so:x11-toolkits/libwnck \
libwebkitgtk-1.0.so:www/webkit-gtk2 \
- libsoup-2.4.so:devel/libsoup
+ libsoup-2.4.so:devel/libsoup \
+ libgeany.so:devel/geany@gtk2
+
+FLAVORS= # intentionally left empty
USE_GNOME= gconf2
diff --git a/devel/geany-plugin-geanypy/Makefile b/devel/geany-plugin-geanypy/Makefile
index 20b6c57162ad..1f8a1018ed33 100644
--- a/devel/geany-plugin-geanypy/Makefile
+++ b/devel/geany-plugin-geanypy/Makefile
@@ -2,11 +2,16 @@
PORTNAME= geany-plugin-geanypy
PORTVERSION= ${GEANY_VER}
+PKGNAMESUFFIX= -gtk2
CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
+LIB_DEPENDS= libgeany.so:devel/geany@gtk2
+
+FLAVORS= # intentionally left empty
+
USES= python:2.7
USE_GNOME= pygtk2
diff --git a/devel/geany-plugin-markdown/Makefile b/devel/geany-plugin-markdown/Makefile
index 1aade70ce5ef..81652a75ed71 100644
--- a/devel/geany-plugin-markdown/Makefile
+++ b/devel/geany-plugin-markdown/Makefile
@@ -7,8 +7,10 @@ CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
-LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2 \
- libsoup-2.4.so:devel/libsoup
+LIB_DEPENDS= libsoup-2.4.so:devel/libsoup
+
+gtk2_LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2
+gtk3_LIB_DEPENDS= libwebkitgtk-3.0.so:www/webkit-gtk3
OPTIONS_DEFINE= DOCS
diff --git a/devel/geany-plugin-multiterm/Makefile b/devel/geany-plugin-multiterm/Makefile
index 5156031bed8d..b532263f771c 100644
--- a/devel/geany-plugin-multiterm/Makefile
+++ b/devel/geany-plugin-multiterm/Makefile
@@ -2,12 +2,17 @@
PORTNAME= geany-plugin-multiterm
PORTVERSION= ${GEANY_VER}
+PKGNAMESUFFIX= -gtk2
CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
BUILD_DEPENDS= valac:lang/vala
+LIB_DEPENDS= libgeany.so:devel/geany@gtk2
+
+FLAVORS= # intentionally left empty
+
USE_GNOME= vte
USE_XORG= x11 xext
diff --git a/devel/geany-plugin-scope/Makefile b/devel/geany-plugin-scope/Makefile
index 24d8d7f18156..c489d4ecb74c 100644
--- a/devel/geany-plugin-scope/Makefile
+++ b/devel/geany-plugin-scope/Makefile
@@ -2,11 +2,16 @@
PORTNAME= geany-plugin-scope
PORTVERSION= ${GEANY_VER}
+PKGNAMESUFFIX= -gtk2
CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
+LIB_DEPENDS= libgeany.so:devel/geany@gtk2
+
+FLAVORS= # intentionally left empty
+
USE_GNOME= vte
USE_XORG= x11 xext
diff --git a/devel/geany-plugin-vc/Makefile b/devel/geany-plugin-vc/Makefile
index 4738a96be932..1c985bef83f1 100644
--- a/devel/geany-plugin-vc/Makefile
+++ b/devel/geany-plugin-vc/Makefile
@@ -7,11 +7,13 @@ CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
-OPTIONS_DEFINE= GTKSPELL
+gtk2_LIB_DEPENDS= libgtkspell.so:textproc/gtkspell
+gtk3_LIB_DEPENDS= libgtkspell3-3.so:textproc/gtkspell3
+
+OPTIONS_DEFINE= GTKSPELL
OPTIONS_DEFAULT= GTKSPELL
GTKSPELL_DESC= Spell checking support via GtkSpell
-GTKSPELL_LIB_DEPENDS= libgtkspell.so:textproc/gtkspell
GTKSPELL_CONFIGURE_ENABLE= gtkspell
.include "${.CURDIR}/../geany-plugins/files/Makefile.common"
diff --git a/devel/geany-plugin-webhelper/Makefile b/devel/geany-plugin-webhelper/Makefile
index 1916530386bf..100f732ae762 100644
--- a/devel/geany-plugin-webhelper/Makefile
+++ b/devel/geany-plugin-webhelper/Makefile
@@ -7,8 +7,10 @@ CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
-LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2 \
- libsoup-2.4.so:devel/libsoup
+LIB_DEPENDS= libsoup-2.4.so:devel/libsoup
+
+gtk2_LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2
+gtk3_LIB_DEPENDS= libwebkitgtk-3.0.so:www/webkit-gtk3
.include "${.CURDIR}/../geany-plugins/files/Makefile.common"
.include <bsd.port.mk>
diff --git a/devel/geany-plugins/Makefile b/devel/geany-plugins/Makefile
index 161833400af9..f0616eecfdf7 100644
--- a/devel/geany-plugins/Makefile
+++ b/devel/geany-plugins/Makefile
@@ -3,25 +3,52 @@
PORTNAME= geany-plugins
PORTVERSION= ${GEANY_VER}
+PORTREVISION= 1
CATEGORIES= devel
DISTFILES= # none
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugins (meta port)
+FLAVORS= gtk3 gtk2
+FLAVOR?= ${FLAVORS:[1]}
+
+gtk2_CONFLICTS_INSTALL= geany-plugins
+gtk2_PKGNAMESUFFIX= -gtk2
+
+gtk3_CONFLICTS_INSTALL= geany-plugins-gtk2
+
USES= metaport
-OPTIONS_DEFINE= NLS ${GEANY_PLUGINS_ALL:tu}
-OPTIONS_DEFAULT= ${GEANY_PLUGINS_ALL:tu}
+OPTIONS_DEFINE= NLS
+OPTIONS_GROUP= GTK2 ALL
+OPTIONS_GROUP_GTK2= ${GEANY_PLUGINS_GTK2:tu}
+OPTIONS_GROUP_ALL= ${GEANY_PLUGINS_ALL:tu}
+OPTIONS_DEFAULT= ${GEANY_PLUGINS_ALL:tu} ${GEANY_PLUGINS_GTK2:tu}
NO_OPTIONS_SORT= yes
+GTK2_DESC= Available only for GTK2
+ALL_DESC= Available for both GTK2 and GTK3
+
.include "${.CURDIR}/files/bsd.geany-plugins.mk"
-.for plugin in ${GEANY_PLUGINS_ALL}
+.for plugin in ${GEANY_PLUGINS_ALL} ${GEANY_PLUGINS_GTK2}
${plugin:tu}_DESC= ${${plugin}_DESC}
-${plugin:tu}_RUN_DEPENDS= geany-plugin-${plugin}>=0:devel/geany-plugin-${plugin}
.endfor
-NLS_RUN_DEPENDS= geany-plugins-l10n>=0:devel/geany-plugins-l10n
+.if ${FLAVOR} == gtk2
+.for plugin in ${GEANY_PLUGINS_ALL}
+${plugin:tu}_RUN_DEPENDS= geany-plugin-${plugin}-gtk2>=0:devel/geany-plugin-${plugin}@gtk2
+.endfor
+.for plugin in ${GEANY_PLUGINS_GTK2}
+${plugin:tu}_RUN_DEPENDS= geany-plugin-${plugin}-gtk2>=0:devel/geany-plugin-${plugin}
+.endfor
+NLS_RUN_DEPENDS= geany-plugins-l10n-gtk2>=0:devel/geany-plugins-l10n@gtk2
+.elif ${FLAVOR} == gtk3
+.for plugin in ${GEANY_PLUGINS_ALL}
+${plugin:tu}_RUN_DEPENDS= geany-plugin-${plugin}>=0:devel/geany-plugin-${plugin}@gtk3
+.endfor
+NLS_RUN_DEPENDS= geany-plugins-l10n>=0:devel/geany-plugins-l10n@gtk3
+.endif
.include <bsd.port.mk>
diff --git a/devel/geany-plugins/files/Makefile.common b/devel/geany-plugins/files/Makefile.common
index dd74cb16fad5..3a5b1551ecfc 100644
--- a/devel/geany-plugins/files/Makefile.common
+++ b/devel/geany-plugins/files/Makefile.common
@@ -2,18 +2,25 @@
.include "${.CURDIR}/../../devel/geany-plugins/files/bsd.geany-plugins.mk"
+PORTREVISION= 1
+
MASTER_SITES= http://plugins.geany.org/geany-plugins/
DISTNAME= geany-plugins-${PORTVERSION}
DISTINFO_FILE= ${.CURDIR}/../../devel/geany-plugins/distinfo
-BUILD_DEPENDS+= ${LOCALBASE}/bin/geany:devel/geany
-LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
-RUN_DEPENDS+= ${LOCALBASE}/bin/geany:devel/geany
-
GNU_CONFIGURE= yes
-USES+= gettext-tools gmake libtool pkgconfig tar:bzip2
-USE_GNOME+= cairo gdkpixbuf2 gtk20 intltool
+USES+= gettext-tools gmake gnome libtool pkgconfig tar:bzip2
+USE_GNOME+= intltool
+
+FLAVORS?= gtk3 gtk2
+FLAVOR?= ${FLAVORS:[1]}
+
+gtk2_CONFLICTS_INSTALL= geany-plugin-${GEANY_PLUGIN}
+gtk2_PKGNAMESUFFIX= -gtk2
+gtk2_LIB_DEPENDS+= libgeany.so:devel/geany@gtk2
+
+gtk3_CONFLICTS_INSTALL= geany-plugin-${GEANY_PLUGIN}-gtk2
+gtk3_LIB_DEPENDS+= libgeany.so:devel/geany@gtk3
# geany-plugins-l10n is not a plugin, thus special treatment
.if ${PORTNAME} == "geany-plugins-l10n"
@@ -22,6 +29,17 @@ po_SWITCH= --enable-nls
USES+= localbase
.else
INSTALL_TARGET= install-strip
+USE_GNOME+= cairo gdkpixbuf2
+
+.if ${FLAVOR} == gtk3
+CONFIGURE_ARGS+= --enable-gtk3
+USE_GNOME+= gtk30
+.else
+LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+CONFIGURE_ARGS+= --disable-gtk3
+USE_GNOME+= gtk20
+.endif
.endif
GEANY_PLUGIN?= ${PORTNAME:S,geany-plugin-,,}
@@ -38,8 +56,9 @@ DOCSDIR= share/doc/geany-plugins
.if ${GEANY_UTIL:M${GEANY_PLUGIN}}
-LIB_DEPENDS+= libgeanypluginutils.so:devel/geany-plugin-utilslib
-CONFIGURE_ARGS+=--enable-utilslib
+gtk2_LIB_DEPENDS+= libgeanypluginutils.so:devel/geany-plugin-utilslib@gtk2
+gtk3_LIB_DEPENDS+= libgeanypluginutils.so:devel/geany-plugin-utilslib@gtk3
+CONFIGURE_ARGS+= --enable-utilslib
pre-build:
(cd ${WRKSRC}/utils; ${DO_MAKE_BUILD} ${ALL_TARGET})
diff --git a/devel/geany-plugins/files/bsd.geany-plugins.mk b/devel/geany-plugins/files/bsd.geany-plugins.mk
index bd3b730f5478..9a4d96d6b469 100644
--- a/devel/geany-plugins/files/bsd.geany-plugins.mk
+++ b/devel/geany-plugins/files/bsd.geany-plugins.mk
@@ -1,18 +1,21 @@
# $FreeBSD$
GEANY_VER= 1.33
+GEANY_PLUGINS_GTK2= debugger \
+ devhelp \
+ geanypy \
+ multiterm \
+ scope
+
GEANY_PLUGINS_ALL= addons \
autoclose \
automark \
codenav \
commander \
ctags \
- debugger \
defineformat \
- devhelp \
doc \
extrasel \
- geanypy \
gendoc \
geniuspaste \
git-changebar \
@@ -24,7 +27,6 @@ GEANY_PLUGINS_ALL= addons \
macro \
markdown \
miniscript \
- multiterm \
numberedbookmarks \
overview \
pairtaghighlighter \
@@ -33,7 +35,6 @@ GEANY_PLUGINS_ALL= addons \
pretty-printer \
projectorganizer \
prj \
- scope \
sendmail \
shiftcolumn \
spellcheck \
diff --git a/devel/geany/Makefile b/devel/geany/Makefile
index b0f3530be911..2214982cd26a 100644
--- a/devel/geany/Makefile
+++ b/devel/geany/Makefile
@@ -3,7 +3,7 @@
PORTNAME= geany
PORTVERSION= 1.33
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel editors
MASTER_SITES= http://download.geany.org/ SF
@@ -13,15 +13,23 @@ COMMENT= Fast and lightweight GTK+ IDE
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+FLAVORS= gtk3 gtk2
+FLAVOR?= ${FLAVORS:[1]}
+
+gtk2_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+gtk2_CONFLICTS_INSTALL= geany
+gtk2_PKGNAMESUFFIX= -gtk2
+
+gtk3_CONFLICTS_INSTALL= geany-gtk2
+
+USES= compiler:c++11-lang desktop-file-utils gettext-tools gmake \
+ gnome libtool localbase pathfix pkgconfig tar:bzip2
+USE_GNOME= cairo intltool
+USE_LDCONFIG= yes
-USES= compiler:c++11-lang desktop-file-utils gettext-tools gmake libtool \
- localbase pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_GNOME= cairo gtk20 intltool
-USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= VTE NLS DOCS
@@ -35,6 +43,16 @@ VTE_DESC= Embedded virtual terminal
VTE_CONFIGURE_ENABLE= vte
VTE_USE= GNOME=vte
+.if ${FLAVOR} == gtk2
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --disable-gtk3
+PLIST_SUB+= GTK2="" GTK3="@comment "
+.elif ${FLAVOR} == gtk3
+USE_GNOME+= gtk30
+CONFIGURE_ARGS+= --enable-gtk3
+PLIST_SUB+= GTK2="@comment " GTK3=""
+.endif
+
post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/^SUBDIRS/ s|doc||' ${WRKSRC}/Makefile.in
diff --git a/devel/geany/pkg-plist b/devel/geany/pkg-plist
index 0ea55257a60a..8524c238bc98 100644
--- a/devel/geany/pkg-plist
+++ b/devel/geany/pkg-plist
@@ -153,8 +153,11 @@ share/applications/geany.desktop
%%DATADIR%%/filedefs/filetypes.xml
%%DATADIR%%/filedefs/filetypes.yaml
%%DATADIR%%/filedefs/filetypes.zephir
+%%GTK3%%%%DATADIR%%/geany-3.0.css
+%%GTK3%%%%DATADIR%%/geany-3.20.css
+%%GTK3%%%%DATADIR%%/geany.css
%%DATADIR%%/geany.glade
-%%DATADIR%%/geany.gtkrc
+%%GTK2%%%%DATADIR%%/geany.gtkrc
%%DATADIR%%/snippets.conf
%%DATADIR%%/tags/entities.html.tags
%%DATADIR%%/tags/std.pas.tags