aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-01 09:45:44 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-01 09:45:44 +0000
commit22fb65b135e0900ba4ab0246346a03c859c2baee (patch)
tree02b56d2b887adcc1ce188ac55ccfdfe2558b3aff
parentdf2678cd39b0436c1923a28baa5e5e4b4917401b (diff)
downloadports-22fb65b135e0900ba4ab0246346a03c859c2baee.tar.gz
ports-22fb65b135e0900ba4ab0246346a03c859c2baee.zip
Notes
-rw-r--r--games/flying/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/flying/Makefile b/games/flying/Makefile
index 2a0d2dbd5e2c..139db0001b76 100644
--- a/games/flying/Makefile
+++ b/games/flying/Makefile
@@ -10,8 +10,12 @@ MASTER_SITES= SUNSITE/games/arcade
MAINTAINER= ports@FreeBSD.org
COMMENT= Pool/snooker/billiards/carrom/etc game
-USES= imake tar:tgz
+USES= compiler imake tar:tgz
USE_XORG= x11
PLIST_FILES= bin/flying man/man1/flying.1.gz
+# build ignores CXXFLAGS, imake gets in the way of fixing it
+CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
+CFLAGS_clang= -Wno-c++11-narrowing
+
.include <bsd.port.mk>