aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-04-20 18:46:49 +0000
committerSteve Wills <swills@FreeBSD.org>2016-04-20 18:46:49 +0000
commit23fef823c7660c279dc2598e29c8d6de9242bd4b (patch)
tree10067f61818a7f2d2adcad93676f77233bfab6c6
parentc57f61ecec12ee8618619646676baef8c9f08439 (diff)
downloadports-23fef823c7660c279dc2598e29c8d6de9242bd4b.tar.gz
ports-23fef823c7660c279dc2598e29c8d6de9242bd4b.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-annotations/Makefile43
-rw-r--r--www/py-django-annotations/distinfo2
-rw-r--r--www/py-django-annotations/files/patch-annotations.py18
-rw-r--r--www/py-django-annotations/files/patch-setup.py13
-rw-r--r--www/py-django-annotations/pkg-descr3
6 files changed, 80 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 05fe1bf56d20..e8b493219604 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1522,6 +1522,7 @@
SUBDIR += py-cssutils
SUBDIR += py-django
SUBDIR += py-django-allauth
+ SUBDIR += py-django-annotations
SUBDIR += py-django-annoying
SUBDIR += py-django-app-plugins
SUBDIR += py-django-appconf
diff --git a/www/py-django-annotations/Makefile b/www/py-django-annotations/Makefile
new file mode 100644
index 000000000000..a79ad195fe07
--- /dev/null
+++ b/www/py-django-annotations/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= django-annotations
+PORTVERSION= 0.0.0.2016041401
+CATEGORIES= www python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Django implementation of annotatorjs Storage
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django-cors-headers>=1.1.0:www/py-django-cors-headers \
+ ${PYTHON_PKGNAMEPREFIX}djangorestframework>=3.3.2:www/py-djangorestframework \
+ ${PYTHON_PKGNAMEPREFIX}django-rq>0:devel/py-django-rq \
+ ${PYTHON_PKGNAMEPREFIX}django-rq-dashboard>0:devel/py-django-rq-dashboard \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+
+GH_ACCOUNT= TheDataShed
+GH_TAGNAME= cdb04b4
+
+NO_ARCH= yes
+PLIST_FILES= "@sample etc/annotations/default/__init__.py.example" \
+ "@dir etc/annotations" \
+ "@dir etc/annotations/default"
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${MV} ${WRKSRC}/manage.py ${WRKSRC}/annotations.py
+ @${MV} ${WRKSRC}/templates ${WRKSRC}/annotation
+
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/annotations.py
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/annotations/default
+ ${INSTALL_DATA} ${WRKSRC}/annotator/settings/base.py ${STAGEDIR}${PREFIX}/etc/annotations/default/__init__.py.example
+
+.include <bsd.port.post.mk>
diff --git a/www/py-django-annotations/distinfo b/www/py-django-annotations/distinfo
new file mode 100644
index 000000000000..15cd5d222948
--- /dev/null
+++ b/www/py-django-annotations/distinfo
@@ -0,0 +1,2 @@
+SHA256 (TheDataShed-django-annotations-0.0.0.2016041401-cdb04b4_GH0.tar.gz) = b2f33370524003ee39fdc7e54e7cc7133929faa7d564e3ccc9369efe6e70980d
+SIZE (TheDataShed-django-annotations-0.0.0.2016041401-cdb04b4_GH0.tar.gz) = 92627
diff --git a/www/py-django-annotations/files/patch-annotations.py b/www/py-django-annotations/files/patch-annotations.py
new file mode 100644
index 000000000000..0e02e4f5a83b
--- /dev/null
+++ b/www/py-django-annotations/files/patch-annotations.py
@@ -0,0 +1,18 @@
+--- annotations.py.orig 2016-02-10 10:11:37 UTC
++++ annotations.py
+@@ -1,9 +1,13 @@
+-#!/usr/bin/env python
++#!/usr/local/bin/python2.7
+ import os
+ import sys
+
+ if __name__ == "__main__":
+- os.environ.setdefault("DJANGO_SETTINGS_MODULE", "annotator.settings.local")
++ if not os.environ.get("DJANGO_SETTINGS_MODULE"):
++ print "Please set DJANGO_SETTINGS_MODULE"
++ exit(-1)
++
++ sys.path.append("/usr/local/etc/annotations")
+
+ from django.core.management import execute_from_command_line
+
diff --git a/www/py-django-annotations/files/patch-setup.py b/www/py-django-annotations/files/patch-setup.py
new file mode 100644
index 000000000000..c20e178b1fb2
--- /dev/null
+++ b/www/py-django-annotations/files/patch-setup.py
@@ -0,0 +1,13 @@
+--- setup.py.orig 2016-04-14 21:10:12 UTC
++++ setup.py
+@@ -0,0 +1,10 @@
++#!/usr/bin/env python
++
++from distutils.core import setup
++
++setup(name='django-annotations',
++ version='0.0.0.2016041401',
++ packages=['annotation/migrations', 'annotation', 'annotator/settings', 'annotator', 'enqueue/migrations', 'enqueue'],
++ scripts=['annotations.py'],
++ package_data={'annotation': ['static/js/annotator.min.js', 'templates/*']},
++)
diff --git a/www/py-django-annotations/pkg-descr b/www/py-django-annotations/pkg-descr
new file mode 100644
index 000000000000..f26932b323dd
--- /dev/null
+++ b/www/py-django-annotations/pkg-descr
@@ -0,0 +1,3 @@
+Django implementation of annotatorjs Storage.
+
+WWW: https://github.com/TheDataShed/django-annotations