aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-25 11:33:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-25 11:33:34 +0000
commit25250f0850176793059ddf7d50c6f14511cec2dc (patch)
tree535e67aa0ce90fa1ad316af5516147ac0b4269d0
parent19d965192e72a666bdcd3ace65c3e4d851fe0be3 (diff)
downloadports-25250f0850176793059ddf7d50c6f14511cec2dc.tar.gz
ports-25250f0850176793059ddf7d50c6f14511cec2dc.zip
Notes
-rw-r--r--audio/libshout2/Makefile22
-rw-r--r--audio/libshout2/pkg-plist12
2 files changed, 17 insertions, 17 deletions
diff --git a/audio/libshout2/Makefile b/audio/libshout2/Makefile
index 0640e0fdd5c2..ff892b110a4c 100644
--- a/audio/libshout2/Makefile
+++ b/audio/libshout2/Makefile
@@ -1,33 +1,33 @@
# Created by: Zach Zurflu <zach@pabst.bendnet.com>
# $FreeBSD$
-PORTNAME= libshout2
+PORTNAME= libshout
PORTVERSION= 2.3.1
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio net
-MASTER_SITES= http://downloads.xiph.org/releases/libshout/ \
+MASTER_SITES= http://downloads.xiph.org/releases/${PORTNAME}/ \
LOCAL/sunpoet
-DISTNAME= libshout-${PORTVERSION}
+PKGNAMESUFFIX= 2
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Connect and transmit data to an Icecast media streaming server
-LIB_DEPENDS= speex:${PORTSDIR}/audio/speex \
- theora:${PORTSDIR}/multimedia/libtheora \
- vorbis:${PORTSDIR}/audio/libvorbis
+LICENSE= LGPL20
+
+LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex \
+ libtheora.so:${PORTSDIR}/multimedia/libtheora \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
CONFLICTS= libshout-[0-9]*
-CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
USE_LDCONFIG= yes
-NO_STAGE= yes
+#NO_STAGE= yes
USES= gmake pathfix pkgconfig
-DOCSDIR= ${PREFIX}/share/doc/libshout
-
post-patch:
@${REINPLACE_CMD} -e 's|-ffast-math||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^Requires: |Requires.private: |' ${WRKSRC}/shout.pc.in
diff --git a/audio/libshout2/pkg-plist b/audio/libshout2/pkg-plist
index 1a1f6e7ffc74..502061cb232a 100644
--- a/audio/libshout2/pkg-plist
+++ b/audio/libshout2/pkg-plist
@@ -5,10 +5,10 @@ lib/libshout.so
lib/libshout.so.5
libdata/pkgconfig/shout.pc
share/aclocal/shout.m4
-%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/NEWS
-%%DOCSDIR%%/README
-%%DOCSDIR%%/example.c
-%%DOCSDIR%%/nonblocking.c
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/example.c
+%%PORTDOCS%%%%DOCSDIR%%/nonblocking.c
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/shout