aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-16 23:14:29 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-16 23:14:29 +0000
commit2556ea40579c81d6d501bf33a2dbc07f45c2ae5d (patch)
tree8f739320ddeb50ebc2dbfbe0d12158f3bbcc627c
parentf75374592d96d50c228b412b144faf7b821b79c2 (diff)
Notes
-rw-r--r--mail/balsa2/Makefile3
-rw-r--r--mail/balsa2/files/patch-ltmain.sh51
2 files changed, 2 insertions, 52 deletions
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index 09671f53e8a7..1fa94bf5f0ea 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -25,7 +25,8 @@ USE_PERL5= yes
USE_OPENSSL= yes
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui libgnomeprintui \
libgtkhtml
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
+USE_LIBLTDL= yes
USE_ICONV= yes
CONFIGURE_ARGS= --enable-threads \
--enable-gtkhtml \
diff --git a/mail/balsa2/files/patch-ltmain.sh b/mail/balsa2/files/patch-ltmain.sh
deleted file mode 100644
index 5d2266f8c055..000000000000
--- a/mail/balsa2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Sun Jul 4 13:15:31 2004
-+++ ltmain.sh Wed Jul 7 18:18:07 2004
-@@ -1359,7 +1359,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1374,8 +1374,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3075,6 +3083,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5550,10 +5561,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"