aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-08-28 22:54:22 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-08-28 22:54:22 +0000
commit26277d9501eca0afb3cf43ed19ea97f6092f9a42 (patch)
treed86c68aa4a9fa58e17402e298ec9ef25024eae26
parent9f7abba6c3bc9d28212bb221dafd0d64f051ff15 (diff)
downloadports-26277d9501eca0afb3cf43ed19ea97f6092f9a42.tar.gz
ports-26277d9501eca0afb3cf43ed19ea97f6092f9a42.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_umask/Makefile28
-rw-r--r--www/mod_umask/distinfo2
-rw-r--r--www/mod_umask/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0d0a76694db3..b011eabc5bce 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -523,6 +523,7 @@
SUBDIR += mod_spdy
SUBDIR += mod_tidy
SUBDIR += mod_tsa
+ SUBDIR += mod_mask
SUBDIR += mod_uid
SUBDIR += mod_vhost_ldap
SUBDIR += mod_vhs
diff --git a/www/mod_umask/Makefile b/www/mod_umask/Makefile
new file mode 100644
index 000000000000..2b62e7ff8316
--- /dev/null
+++ b/www/mod_umask/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: mod_umask
+# Date created: 2012-08-28
+# Whom: Ralf Gebhart <gebhart@secnetix.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_umask
+PORTVERSION= 0.1.0
+CATEGORIES= www
+MASTER_SITES= http://www.outoforder.cc/downloads/mod_umask/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+DIST_SUBDIR= apache2
+
+MAINTAINER= gebhart@secnetix.de
+COMMENT= Apache 2.x module to set umask of created files
+
+MAKE_JOBS_SAFE= yes
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_APACHE= 22+
+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+SRC_FILE= src/${PORTNAME}.c
+
+.include <bsd.port.mk>
diff --git a/www/mod_umask/distinfo b/www/mod_umask/distinfo
new file mode 100644
index 000000000000..adb8c4c47d91
--- /dev/null
+++ b/www/mod_umask/distinfo
@@ -0,0 +1,2 @@
+SHA256 (apache2/mod_umask-0.1.0.tar.bz2) = 2be142d562260c895de94600a56b13d8346174b5e2f8a4974adcef23249ec790
+SIZE (apache2/mod_umask-0.1.0.tar.bz2) = 182078
diff --git a/www/mod_umask/pkg-descr b/www/mod_umask/pkg-descr
new file mode 100644
index 000000000000..73a014207120
--- /dev/null
+++ b/www/mod_umask/pkg-descr
@@ -0,0 +1,6 @@
+mod_umask sets the Unix umask of the Apache HTTPd process after it has started.
+This is useful when accessing Subversion from both mod_dav_svn and via a local
+client with a file:// url. Without setting a proper umask the file permissions
+can create a repository that is not easily accessable from both.
+
+WWW: http://www.outoforder.cc/projects/httpd/mod_umask/