aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-09-23 16:18:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-09-23 16:22:54 +0000
commit266130ce71ef2f1cd944a70789bf003da3254c29 (patch)
tree9d1d11a998d94ba964697fc8d56f65eed716d239
parent3556bb222640f4cf6dd22a59542fafdf5ffbd934 (diff)
downloadports-266130ce71ef2f1cd944a70789bf003da3254c29.tar.gz
ports-266130ce71ef2f1cd944a70789bf003da3254c29.zip
-rw-r--r--audio/cam/Makefile2
-rw-r--r--audio/cmp3/Makefile3
-rw-r--r--audio/funktrackergold/Makefile2
-rw-r--r--audio/juke/Makefile1
-rw-r--r--audio/mp3c/Makefile1
-rw-r--r--audio/mp3info/Makefile1
-rw-r--r--audio/playmidi/Makefile1
-rw-r--r--audio/rexima/Makefile1
-rw-r--r--audio/siren/Makefile2
-rw-r--r--audio/stymulator/Makefile1
-rw-r--r--audio/stymulator/files/patch-Makefile2
-rw-r--r--audio/tcd/Makefile1
-rw-r--r--audio/timidity/Makefile1
-rw-r--r--audio/umix/Makefile1
-rw-r--r--audio/vitunes/Makefile1
-rw-r--r--audio/xmcd/Makefile1
-rw-r--r--deskutils/dfshow/Makefile2
-rw-r--r--devel/notcurses/Makefile2
-rw-r--r--devel/stfl/Makefile2
-rw-r--r--games/gtypist/Makefile2
-rw-r--r--games/tty-solitaire/Makefile2
-rw-r--r--misc/ipbt/Makefile2
-rw-r--r--misc/mdp/Makefile2
-rw-r--r--net/httping/Makefile2
-rw-r--r--security/kc24/Makefile2
-rw-r--r--shells/wcd/Makefile2
-rw-r--r--sysutils/multitail/Makefile3
-rw-r--r--sysutils/powermon/Makefile2
-rw-r--r--sysutils/tty-clock/Makefile2
-rw-r--r--textproc/aspell/Makefile2
-rw-r--r--www/gopherus/Makefile2
-rw-r--r--www/netrik/Makefile2
-rw-r--r--www/newsboat/Makefile2
-rw-r--r--x11/bemenu/Makefile2
34 files changed, 37 insertions, 22 deletions
diff --git a/audio/cam/Makefile b/audio/cam/Makefile
index 3802edd5d96f..84003b177b42 100644
--- a/audio/cam/Makefile
+++ b/audio/cam/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= ncurses tar:tgz
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
- LIBS="${LDFLAGS} -lncurses" \
+ LIBS="${LDFLAGS} ${NCURSESLIBS}" \
BINDIR="${PREFIX}/bin" \
MANDIR="${PREFIX}/share/man/man1" \
XEFILE=""
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
index 554bc876c4a2..4e2591b921e8 100644
--- a/audio/cmp3/Makefile
+++ b/audio/cmp3/Makefile
@@ -19,7 +19,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-kenrevs
USES= gmake ncurses
GNU_CONFIGURE= yes
-MAKE_ARGS= install_directory=${STAGEDIR}${PREFIX}/bin
+MAKE_ARGS= install_directory=${STAGEDIR}${PREFIX}/bin \
+ LIBS="${NCURSESLIBS} -lform"
PORTDOCS= README sample.cmp3rc
PLIST_FILES= bin/cmp3 bin/rnmp3
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index dc68afcfd9dd..4ce5f6b67023 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -18,7 +18,7 @@ BROKEN_armv7= fails to compile: function definition is not allowed here
USES= compiler:nestedfct ncurses tar:tgz
WRKSRC= ${WRKDIR}/funkgold
-MAKE_ARGS= EXTRA_LDFLAGS="-lpthread"
+MAKE_ARGS= EXTRA_LDFLAGS="-lpthread ${NCURSESLIBS}"
PORTDOCS= INSTALL
PLIST_FILES= bin/funkgold
diff --git a/audio/juke/Makefile b/audio/juke/Makefile
index 90785dfa04c1..055d9c24c8db 100644
--- a/audio/juke/Makefile
+++ b/audio/juke/Makefile
@@ -15,6 +15,7 @@ SUB_FILES= pkg-message
OPTIONS_DEFINE= VI_BINDINGS
VI_BINDINGS_DESC= Use vi-like key bindings
+MAKE_ARGS+= LIBS="${NCURSESLIBS}"
VI_BINDINGS_EXTRA_PATCHES= ${FILESDIR}/extra-patch-vi
diff --git a/audio/mp3c/Makefile b/audio/mp3c/Makefile
index 836aa142e9c2..972c24884709 100644
--- a/audio/mp3c/Makefile
+++ b/audio/mp3c/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= mp3info:audio/mp3info \
USES= ncurses
GNU_CONFIGURE= yes
+MAKE_ARGS+= LIBS="${NCURSESLIBS}"
DEFAULT_CDROM_DEVICE?= cd0
diff --git a/audio/mp3info/Makefile b/audio/mp3info/Makefile
index 64c2d0867105..ee389b4e45cc 100644
--- a/audio/mp3info/Makefile
+++ b/audio/mp3info/Makefile
@@ -27,6 +27,7 @@ GTK2_ALL_TARGET= gmp3info
GTK2_PLIST_FILES= bin/gmp3info
GTK2_USE= GNOME=gtk20
GTK2_USES= gnome pkgconfig
+MAKE_ARGS= LIBS="\$${LDFLAGS} ${NCURSESLIBS}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mp3info ${STAGEDIR}${PREFIX}/bin/
diff --git a/audio/playmidi/Makefile b/audio/playmidi/Makefile
index 48641e96d9c3..e6e16646f03f 100644
--- a/audio/playmidi/Makefile
+++ b/audio/playmidi/Makefile
@@ -19,6 +19,7 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ENV= PREFIX=${PREFIX}
INSTALL_TARGET= install.lame install.man
+MAKE_ARGS= LIBNC="${NCURSESLIBS}"
OPTIONS_SINGLE= DEFAULTDEVICE
OPTIONS_SINGLE_DEFAULTDEVICE= EXTERNAL YAMAHA2 YAMAHA4 GRAVISULTRA SBAWE32
diff --git a/audio/rexima/Makefile b/audio/rexima/Makefile
index 5cb773cbf11e..e4754257ee76 100644
--- a/audio/rexima/Makefile
+++ b/audio/rexima/Makefile
@@ -12,5 +12,6 @@ LICENSE= GPLv2
USES= ncurses
PLIST_FILES= bin/rexima man/man1/rexima.1.gz
+LDFLAGS+= ${NCURSESLIBS}
.include <bsd.port.mk>
diff --git a/audio/siren/Makefile b/audio/siren/Makefile
index 89d0ca410b5e..b72e4201b65e 100644
--- a/audio/siren/Makefile
+++ b/audio/siren/Makefile
@@ -69,7 +69,7 @@ CONFIGURE_ARGS= alsa=no \
portaudio=no
post-patch:
- @${REINPLACE_CMD} -e 's|-lcurses|-lncurses|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lcurses|${NCURSESLIBS}|' ${WRKSRC}/configure
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/siren
diff --git a/audio/stymulator/Makefile b/audio/stymulator/Makefile
index 7442b99cd4f9..81167ba9fcf2 100644
--- a/audio/stymulator/Makefile
+++ b/audio/stymulator/Makefile
@@ -21,6 +21,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
MANPAGE1= ymplayer.1 ym2wav.1
PLIST_FILES= bin/ym2wav bin/ymplayer bin/stymulator man/man1/ymplayer.1.gz \
man/man1/ym2wav.1.gz
+LDFLAGS+= ${NCURSESLIBS}
post-patch:
@${REINPLACE_CMD} -e 's|-lncurses|$$(LDFLAGS) -lncurses|' \
diff --git a/audio/stymulator/files/patch-Makefile b/audio/stymulator/files/patch-Makefile
index 698c78ea0bba..e0fbec9f6f55 100644
--- a/audio/stymulator/files/patch-Makefile
+++ b/audio/stymulator/files/patch-Makefile
@@ -13,7 +13,7 @@
ymplayer: ymplayer.o sound.o ui.o
- $(CC) -o ymplayer $(INCLUDE) ymplayer.o sound.o ui.o -lasound -lym -llzh -lncurses
-+ $(CXX) $(CXXFLAGS) -o ymplayer $(INCLUDE) ymplayer.o sound.o ui.o -lym -llzh -lncurses
++ $(CXX) $(CXXFLAGS) -o ymplayer $(INCLUDE) ymplayer.o sound.o ui.o -lym -llzh ${LFFLAGS} -lncurses
ym2wav: ym2wav.o
- $(CC) -o ym2wav $(INCLUDE) ym2wav.o -lym -llzh
diff --git a/audio/tcd/Makefile b/audio/tcd/Makefile
index 105de5176b97..e2689dd57b6f 100644
--- a/audio/tcd/Makefile
+++ b/audio/tcd/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
USES= ncurses sdl
USE_SDL= sdl
GNU_CONFIGURE= yes
+MAKE_ARGS= LIBS="${NCURSESLIBS}"
PLIST_FILES= bin/tcd \
man/man1/tcd.1.gz
diff --git a/audio/timidity/Makefile b/audio/timidity/Makefile
index e1c4e86256e6..9892359167cc 100644
--- a/audio/timidity/Makefile
+++ b/audio/timidity/Makefile
@@ -20,6 +20,7 @@ OPTIONS_SINGLE= FONTS
OPTIONS_SINGLE_FONTS= GOEMON GUSPAT
OPTIONS_DEFAULT=GOEMON
OPTIONS_SUB= yes
+MAKE_ARGS= EXTRALIBS="${NCURSESLIBS}"
FONTS_DESC= Default sound fonts
diff --git a/audio/umix/Makefile b/audio/umix/Makefile
index c44463f4f8c7..0a5dd7888149 100644
--- a/audio/umix/Makefile
+++ b/audio/umix/Makefile
@@ -11,6 +11,7 @@ COMMENT= Advanced tool for adjusting soundcard mixers, replacement for aumix
USES= alias ncurses
GNU_CONFIGURE= yes
+MAKE_ARGS= LIBS="${NCURSESLIBS}"
PLIST_FILES= bin/umix \
man/man1/umix.1.gz
diff --git a/audio/vitunes/Makefile b/audio/vitunes/Makefile
index 5cebc65cdb32..f5f2fe95acf7 100644
--- a/audio/vitunes/Makefile
+++ b/audio/vitunes/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libtag.so:audio/taglib
USES= ncurses
ALL_TARGET= vitunes
PLIST_FILES= bin/vitunes man/man1/${PORTNAME}.1.gz
+LDFLAGS+= ${NCURSESLIBS}
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/Makefile
diff --git a/audio/xmcd/Makefile b/audio/xmcd/Makefile
index 3328c4c8b588..68056a605190 100644
--- a/audio/xmcd/Makefile
+++ b/audio/xmcd/Makefile
@@ -30,6 +30,7 @@ pre-patch:
@${CP} ${WRKSRC}/xmcd_d/XMcd.ad ${WRKSRC}/xmcd_d/XMcd.ad.in
post-patch:
+ ${REINPLACE_CMD} -e "s/-lncurses/${NCURSESLIBS}/g" ${WRKSRC}/cda_d/Imakefile
@${SED} -e "s;@PREFIX@;${STAGDIR}${PREFIX};g" ${WRKSRC}/xmcd_d/XMcd.ad.in \
> ${WRKSRC}/xmcd_d/XMcd.ad
diff --git a/deskutils/dfshow/Makefile b/deskutils/dfshow/Makefile
index 7ba7746605bb..796e233043df 100644
--- a/deskutils/dfshow/Makefile
+++ b/deskutils/dfshow/Makefile
@@ -17,6 +17,6 @@ GH_ACCOUNT= roberthawdon
GNU_CONFIGURE= yes
post-patch:
- @${REINPLACE_CMD} 's/-lncursesw/-l${NCURSES_IMPL}/g' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} 's/-lncursesw/${NCURSESLIBS}/g' ${WRKSRC}/Makefile.am
.include <bsd.port.mk>
diff --git a/devel/notcurses/Makefile b/devel/notcurses/Makefile
index faec95f21d07..fed39e4cba4c 100644
--- a/devel/notcurses/Makefile
+++ b/devel/notcurses/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libunistring.so:devel/libunistring
USES= cmake:noninja compiler:c++17-lang localbase \
- ncurses:port pkgconfig readline
+ ncurses:ports pkgconfig readline
USE_GITHUB= yes
GH_ACCOUNT= dankamongmen
USE_LDCONFIG= yes
diff --git a/devel/stfl/Makefile b/devel/stfl/Makefile
index a7b6927abbfc..95cb47ba7c64 100644
--- a/devel/stfl/Makefile
+++ b/devel/stfl/Makefile
@@ -23,7 +23,7 @@ MAKE_ENV= LDLIBS="${LDFLAGS}"
post-patch:
@${REINPLACE_CMD} -e 's|-Os||;/gcc/d;/-MM/s|-I.|$${CFLAGS}|; \
/pkgconfig/s|$$(libdir)|libdata| ; \
- s/-lncursesw/-l${NCURSES_IMPL}/g' \
+ s/-lncursesw/${NCURSESLIBS}/g' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e '/Libs.private/s|$$| ${ICONV_LIB}|' \
${WRKSRC}/stfl.pc.in
diff --git a/games/gtypist/Makefile b/games/gtypist/Makefile
index ff03e489f841..74eb031e6af3 100644
--- a/games/gtypist/Makefile
+++ b/games/gtypist/Makefile
@@ -34,6 +34,6 @@ post-patch:
${WRKSRC}/src/script.c \
${WRKSRC}/src/gtypist.c \
${WRKSRC}/src/utf8.c
- ${REINPLACE_CMD} -e 's/-lncursesw/-l${NCURSES_IMPL}/g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's/-lncursesw/${NCURSESLIBS}/g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/games/tty-solitaire/Makefile b/games/tty-solitaire/Makefile
index a6f66bf1ddfa..4634011c225a 100644
--- a/games/tty-solitaire/Makefile
+++ b/games/tty-solitaire/Makefile
@@ -15,7 +15,7 @@ GH_ACCOUNT= mpereira
USES= gmake ncurses
TEST_TARGET= test
-MAKE_ARGS= NCURSES=-l${NCURSES_IMPL}
+MAKE_ARGS= NCURSES="${NCURSESLIBS}"
PORTDOCS= *
PLIST_FILES= bin/ttysolitaire
diff --git a/misc/ipbt/Makefile b/misc/ipbt/Makefile
index b5eb49c57ce2..d92e04eb3548 100644
--- a/misc/ipbt/Makefile
+++ b/misc/ipbt/Makefile
@@ -12,7 +12,7 @@ COMMENT= High-tech ttyrec player with improvements over ttyplay
USES= ncurses perl5 shebangfix
ALL_TARGET= ${PORTNAME}
-MAKE_ARGS= LFLAGS="${LDFLAGS}" NCURSES_LIB=-l${NCURSES_IMPL}
+MAKE_ARGS= LFLAGS="${LDFLAGS}" NCURSES_LIB="${NCURSESLIBS}
PLIST_FILES= bin/ipbt bin/ttygrep bin/ttydump man/man1/ipbt.1.gz
SHEBANG_FILES= sbcsgen.pl Makefile ttygrep ttydump
diff --git a/misc/mdp/Makefile b/misc/mdp/Makefile
index bd693fa3115f..6592b360d4c0 100644
--- a/misc/mdp/Makefile
+++ b/misc/mdp/Makefile
@@ -14,7 +14,7 @@ USES= gmake ncurses
USE_GITHUB= yes
GH_ACCOUNT= visit1985
-MAKE_ARGS= CURSES=${NCURSES_IMPL}
+MAKE_ARGS= LDLIBS="${NCURSESLIBS}"
PLIST_FILES= bin/mdp \
share/man/man1/mdp.1.gz
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 4310a5e6c725..6a6f76734700 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -50,7 +50,7 @@ MAKE_ENV+= TFO=yes
.endif
post-patch-NCURSES-on:
- @${REINPLACE_CMD} "s/lncursesw/l${NCURSES_IMPL}/g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} "s/-lncursesw/${NCURSESLIBS}/g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/security/kc24/Makefile b/security/kc24/Makefile
index 8aa5679207c2..547c33c75669 100644
--- a/security/kc24/Makefile
+++ b/security/kc24/Makefile
@@ -41,6 +41,6 @@ PLIST_FILES= bin/kc man/man1/kc.1.gz
MAKE_ENV+= BUNDLED_BCRYPT=y
post-patch:
- @${REINPLACE_CMD} -e 's|-lncursesw|-l${NCURSES_IMPL}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-lncursesw|${NCURSESLIBS}|' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/shells/wcd/Makefile b/shells/wcd/Makefile
index ecd4d1721f71..7bd9c1a42ac0 100644
--- a/shells/wcd/Makefile
+++ b/shells/wcd/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/doc/copying.txt
USES= gmake ncurses
MAKE_ARGS= EXT= PREFIX=${PREFIX} docsubdir=${PORTNAME} \
- mandir=${PREFIX}/man LIB_CURSES=-l${NCURSES_IMPL}
+ mandir=${PREFIX}/man LIB_CURSES="${NCURSESILBS}
CFLAGS+= -I${NCURSESINC}
OPTIONS_DEFINE= DOCS NLS
diff --git a/sysutils/multitail/Makefile b/sysutils/multitail/Makefile
index 67a5cf076c20..da484654da31 100644
--- a/sysutils/multitail/Makefile
+++ b/sysutils/multitail/Makefile
@@ -21,6 +21,9 @@ MAKE_ARGS= NCURSES_IMPL="${NCURSES_IMPL}"
OPTIONS_DEFINE= DOCS
+post-patch:
+ ${REINPLACE_CMD} -e "s/NCURSES_LIB:/LDFLAGS+/g" ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/multitail ${STAGEDIR}${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/multitail.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/sysutils/powermon/Makefile b/sysutils/powermon/Makefile
index 0593acdb68fb..5e021005eee7 100644
--- a/sysutils/powermon/Makefile
+++ b/sysutils/powermon/Makefile
@@ -20,7 +20,7 @@ USES= gmake ncurses
PLIST_FILES= man/man8/powermon.8.gz sbin/powermon
post-patch:
- ${REINPLACE_CMD} 's/cursesw/${NCURSES_IMPL}/g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} 's/-lcursesw/${NCURSESLIBS}/g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/release/powermon \
diff --git a/sysutils/tty-clock/Makefile b/sysutils/tty-clock/Makefile
index 0c8393a849de..92a59727bf50 100644
--- a/sysutils/tty-clock/Makefile
+++ b/sysutils/tty-clock/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
USES= gmake ncurses pkgconfig
ALL_TARGET= tty-clock
-LDFLAGS+= -l${NCURSES_IMPL}
+LDFLAGS+= ${NCURSESLIBS}
PLIST_FILES= bin/tty-clock \
share/man/man1/tty-clock.1.gz
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 8d5eb089b5e2..350152a305fa 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -20,7 +20,7 @@ OPTIONS_SUB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
- --enable-curses=${NCURSES_IMPL} \
+ --enable-curses="${NCURSESLIBS}" \
--enable-static
USE_LDCONFIG= yes
diff --git a/www/gopherus/Makefile b/www/gopherus/Makefile
index 98f72b7c5b6e..535d7e94e4db 100644
--- a/www/gopherus/Makefile
+++ b/www/gopherus/Makefile
@@ -11,7 +11,7 @@ LICENSE= BSD2CLAUSE
USES= ncurses tar:xz uidfix
MAKEFILE= ${FILESDIR}/Makefile
CFLAGS+= -I${NCURSESINC}
-LDFLAGS+= -L${NCURSESLIB} -l${NCURSES_IMPL}
+LDFLAGS+= -L${NCURSESLIB} ${NCURSESLIBS}
PLIST_FILES= bin/gopherus
diff --git a/www/netrik/Makefile b/www/netrik/Makefile
index 3982d9f30d49..19d24e20b466 100644
--- a/www/netrik/Makefile
+++ b/www/netrik/Makefile
@@ -23,7 +23,7 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} "s|^CFLAGS =|CFLAGS?=|" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} "s|ncursesw|${NCURSES_IMPL}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} "s|-lncursesw|${NCURSESLIBS}|g" ${WRKSRC}/configure
@${REINPLACE_CMD} "s/#include <ncursesw\//#include </" \
${WRKSRC}/*.c
diff --git a/www/newsboat/Makefile b/www/newsboat/Makefile
index ee6d62a0badb..1a66c3c40400 100644
--- a/www/newsboat/Makefile
+++ b/www/newsboat/Makefile
@@ -133,7 +133,7 @@ post-patch:
@${REINPLACE_CMD} -e 's,fail "ncursesw",true,; s,fail "libcrypto",true,' \
-e 's,fail "libssl",true,' \
${WRKSRC}/config.sh
- @${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB} -lcrypto -l${NCURSES_IMPL}|;s|-Werror||' \
+ @${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB} -lcrypto ${NCURSESLIBS}|;s|-Werror||' \
${WRKSRC}/Makefile
post-install:
diff --git a/x11/bemenu/Makefile b/x11/bemenu/Makefile
index 782d14e9c329..b71175497aa4 100644
--- a/x11/bemenu/Makefile
+++ b/x11/bemenu/Makefile
@@ -26,7 +26,7 @@ BACKEND_DESC= Backend
NCURSES_USES= ncurses
NCURSES_MAKE_ARGS= curses_CFLAGS="-I${NCURSESINC}" \
- curses_LIBS="-L${NCURSESLIB} -l${NCURSES_IMPL}"
+ curses_LIBS="-L${NCURSESLIB} ${NCURSESLIBS}"
NCURSES_VARS= _BEMENU_RENDERERS+=curses
WAYLAND_BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \