aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-11 16:21:18 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-11 16:21:18 +0000
commit276f8c1c637a81988ebcc89913da37b42ab0882b (patch)
treec0e5a4b2a38bf497fce1cc48f3cdcaa774d331ef
parent07c5643255af7e98d9122195831223470c068373 (diff)
downloadports-276f8c1c637a81988ebcc89913da37b42ab0882b.tar.gz
ports-276f8c1c637a81988ebcc89913da37b42ab0882b.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/libgnomedb-reference/Makefile5
-rw-r--r--databases/libgnomedb/Makefile13
-rw-r--r--databases/libgnomedb/pkg-plist109
4 files changed, 16 insertions, 112 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b4ed6e5038fc..33ad7970334b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -94,6 +94,7 @@
SUBDIR += libgda3-reference
SUBDIR += libgdamm
SUBDIR += libgnomedb
+ SUBDIR += libgnomedb-reference
SUBDIR += libiodbc
SUBDIR += libmemcache
SUBDIR += libodbc++
diff --git a/databases/libgnomedb-reference/Makefile b/databases/libgnomedb-reference/Makefile
new file mode 100644
index 000000000000..1f3dd3542a1c
--- /dev/null
+++ b/databases/libgnomedb-reference/Makefile
@@ -0,0 +1,5 @@
+# $FreeBSD$
+
+REFERENCE_SRC= ${WRKSRC}/doc/C
+
+.include "${.CURDIR}/../../devel/glib20-reference/bsd.gnome-reference.mk"
diff --git a/databases/libgnomedb/Makefile b/databases/libgnomedb/Makefile
index a37be36e6dca..f2366b03c8a7 100644
--- a/databases/libgnomedb/Makefile
+++ b/databases/libgnomedb/Makefile
@@ -8,7 +8,6 @@
PORTNAME= libgnomedb
PORTVERSION= 1.9.102
-PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -18,10 +17,16 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Library components for the GNOME database frontend
USE_BZIP2= yes
-USE_X_PREFIX= yes
+PREFIX?= ${X11BASE}
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 2
+
+USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgda3 gtksourceview \
- intlhack
+ intlhack referencehack
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
@@ -33,3 +38,5 @@ GCONF_SCHEMAS= libgnomedb.schemas
PLIST_SUB= VERSION=${PORTVERSION:R}
.include <bsd.port.mk>
+
+.endif
diff --git a/databases/libgnomedb/pkg-plist b/databases/libgnomedb/pkg-plist
index b5fd5a9f80c2..d1b67ec41278 100644
--- a/databases/libgnomedb/pkg-plist
+++ b/databases/libgnomedb/pkg-plist
@@ -102,114 +102,6 @@ lib/libgnomedb_handlers-3.la
lib/libgnomedb_handlers-3.so
lib/libgnomedb_handlers-3.so.4
libdata/pkgconfig/libgnomedb-2.0.pc
-%%DOCSDIR%%/GnomeDbBasicForm.html
-%%DOCSDIR%%/GnomeDbCanvas.html
-%%DOCSDIR%%/GnomeDbCanvasCursor.html
-%%DOCSDIR%%/GnomeDbCanvasDbRelations.html
-%%DOCSDIR%%/GnomeDbCanvasEntity.html
-%%DOCSDIR%%/GnomeDbCanvasField.html
-%%DOCSDIR%%/GnomeDbCanvasFkconstraint.html
-%%DOCSDIR%%/GnomeDbCanvasItem.html
-%%DOCSDIR%%/GnomeDbCanvasJoin.html
-%%DOCSDIR%%/GnomeDbCanvasQueryStruct.html
-%%DOCSDIR%%/GnomeDbCanvasText.html
-%%DOCSDIR%%/GnomeDbCanvasTip.html
-%%DOCSDIR%%/GnomeDbCombo.html
-%%DOCSDIR%%/GnomeDbConnectionProperties.html
-%%DOCSDIR%%/GnomeDbDataCellRendererBoolean.html
-%%DOCSDIR%%/GnomeDbDataCellRendererCombo.html
-%%DOCSDIR%%/GnomeDbDataCellRendererInfo.html
-%%DOCSDIR%%/GnomeDbDataCellRendererTextual.html
-%%DOCSDIR%%/GnomeDbDataEntry.html
-%%DOCSDIR%%/GnomeDbDataSourceSelector.html
-%%DOCSDIR%%/GnomeDbDataStore.html
-%%DOCSDIR%%/GnomeDbDataWidgetInfo.html
-%%DOCSDIR%%/GnomeDbDsnConfig.html
-%%DOCSDIR%%/GnomeDbDsnConfigDruid.html
-%%DOCSDIR%%/GnomeDbDsnSpec.html
-%%DOCSDIR%%/GnomeDbEditor.html
-%%DOCSDIR%%/GnomeDbEntryBoolean.html
-%%DOCSDIR%%/GnomeDbEntryCidr.html
-%%DOCSDIR%%/GnomeDbEntryCombo.html
-%%DOCSDIR%%/GnomeDbEntryFilesel.html
-%%DOCSDIR%%/GnomeDbEntryNone.html
-%%DOCSDIR%%/GnomeDbEntryPassmd5.html
-%%DOCSDIR%%/GnomeDbEntryShell.html
-%%DOCSDIR%%/GnomeDbEntryString.html
-%%DOCSDIR%%/GnomeDbEntryText.html
-%%DOCSDIR%%/GnomeDbEntryTime.html
-%%DOCSDIR%%/GnomeDbEntryWrapper.html
-%%DOCSDIR%%/GnomeDbError.html
-%%DOCSDIR%%/GnomeDbErrorDialog.html
-%%DOCSDIR%%/GnomeDbFindDialog.html
-%%DOCSDIR%%/GnomeDbForm.html
-%%DOCSDIR%%/GnomeDbGrayBar.html
-%%DOCSDIR%%/GnomeDbGrid.html
-%%DOCSDIR%%/GnomeDbLogin.html
-%%DOCSDIR%%/GnomeDbLoginDialog.html
-%%DOCSDIR%%/GnomeDbProviderSelector.html
-%%DOCSDIR%%/GnomeDbRawForm.html
-%%DOCSDIR%%/GnomeDbRawGrid.html
-%%DOCSDIR%%/GnomeDbReportEditor.html
-%%DOCSDIR%%/GnomeDbSelector.html
-%%DOCSDIR%%/GnomeDbSqlConsole.html
-%%DOCSDIR%%/GnomeDbmsUpdateViewer.html
-%%DOCSDIR%%/ch01s02.html
-%%DOCSDIR%%/ch01s03.html
-%%DOCSDIR%%/ch02.html
-%%DOCSDIR%%/ch03.html
-%%DOCSDIR%%/ch07.html
-%%DOCSDIR%%/ch08.html
-%%DOCSDIR%%/ch09.html
-%%DOCSDIR%%/databound-widgets.html
-%%DOCSDIR%%/dsn-widgets.html
-%%DOCSDIR%%/example_bad.png
-%%DOCSDIR%%/example_result.png
-%%DOCSDIR%%/fdl-section1.html
-%%DOCSDIR%%/fdl-section10.html
-%%DOCSDIR%%/fdl-section2.html
-%%DOCSDIR%%/fdl-section3.html
-%%DOCSDIR%%/fdl-section4.html
-%%DOCSDIR%%/fdl-section5.html
-%%DOCSDIR%%/fdl-section6.html
-%%DOCSDIR%%/fdl-section7.html
-%%DOCSDIR%%/fdl-section8.html
-%%DOCSDIR%%/fdl-section9.html
-%%DOCSDIR%%/fdl-using.html
-%%DOCSDIR%%/fdl.html
-%%DOCSDIR%%/general-widgets.html
-%%DOCSDIR%%/gnome-db-canvas-db-relations.png
-%%DOCSDIR%%/gnome-db-canvas-query-struct.png
-%%DOCSDIR%%/gnome-db-combo.png
-%%DOCSDIR%%/gnome-db-console.png
-%%DOCSDIR%%/gnome-db-editor.png
-%%DOCSDIR%%/gnome-db-form.png
-%%DOCSDIR%%/gnome-db-grid.png
-%%DOCSDIR%%/gnome-db-selector.png
-%%DOCSDIR%%/gnome-dbms-update-viewer.png
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/libgnomedb-GnomeDB-Stock-images.html
-%%DOCSDIR%%/libgnomedb-List-of-enumerated.html
-%%DOCSDIR%%/libgnomedb-example.html
-%%DOCSDIR%%/libgnomedb-gnome-db-data-widget.html
-%%DOCSDIR%%/libgnomedb-index.html
-%%DOCSDIR%%/libgnomedb-libgnomedb.html
-%%DOCSDIR%%/libgnomedb.devhelp
-%%DOCSDIR%%/misc.html
-%%DOCSDIR%%/non-inst-widgets.html
-%%DOCSDIR%%/pt01.html
-%%DOCSDIR%%/pt02.html
-%%DOCSDIR%%/query01.png
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/sampleapp1.png
-%%DOCSDIR%%/sampleapp2.png
-%%DOCSDIR%%/sampleapp3.png
-%%DOCSDIR%%/sampleapp4.png
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/up.png
share/gnome/applications/database-properties.desktop
share/gnome/mime-info/libgnomedb.keys
share/gnome/mime-info/libgnomedb.mime
@@ -299,7 +191,6 @@ share/locale/zh_TW/LC_MESSAGES/libgnomedb-3.mo
@dirrmtry share/locale/rw
@dirrm share/gnome/pixmaps/libgnomedb
@dirrm share/gnome/omf/libgnomedb
-@dirrm %%DOCSDIR%%
@dirrm lib/libgnomedb/plugins
@dirrm lib/libgnomedb
@dirrm include/libgnomedb-%%VERSION%%/libgnomedb/graph