aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-06-29 00:26:01 +0000
committerSteve Wills <swills@FreeBSD.org>2019-06-29 00:26:01 +0000
commit285bab6c1374db56ec74f95140c330ef56b224a9 (patch)
tree848702ce6f33b55d9926251c555a289629ca58ab
parentd77700ddec87db5ae19817958e58e6a6caeda4dd (diff)
downloadports-285bab6c1374db56ec74f95140c330ef56b224a9.tar.gz
ports-285bab6c1374db56ec74f95140c330ef56b224a9.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/snorenotify/Makefile22
-rw-r--r--devel/snorenotify/distinfo3
-rw-r--r--devel/snorenotify/pkg-descr5
-rw-r--r--devel/snorenotify/pkg-plist56
5 files changed, 87 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5b6e6a7473df..25bb9f0b910d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6071,6 +6071,7 @@
SUBDIR += smake
SUBDIR += smc
SUBDIR += smv
+ SUBDIR += snorenotify
SUBDIR += soapui
SUBDIR += socket_wrapper
SUBDIR += sonar-ant-task
diff --git a/devel/snorenotify/Makefile b/devel/snorenotify/Makefile
new file mode 100644
index 000000000000..5d91add987b3
--- /dev/null
+++ b/devel/snorenotify/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= snorenotify
+PORTVERSION= 0.7.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Multi platform Qt notification framework
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING.LGPL-3
+
+USES= cmake kde:5 qt:5
+USE_KDE= ecm
+USE_QT= core dbus gui network widgets buildtools_build qmake_build
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+GH_ACCOUNT= KDE
+
+.include <bsd.port.mk>
diff --git a/devel/snorenotify/distinfo b/devel/snorenotify/distinfo
new file mode 100644
index 000000000000..6df0d47c05fd
--- /dev/null
+++ b/devel/snorenotify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1561753153
+SHA256 (KDE-snorenotify-v0.7.0_GH0.tar.gz) = 2e3f5fbb80ab993f6149136cd9a14c2de66f48cabce550dead167a9448f5bed9
+SIZE (KDE-snorenotify-v0.7.0_GH0.tar.gz) = 226659
diff --git a/devel/snorenotify/pkg-descr b/devel/snorenotify/pkg-descr
new file mode 100644
index 000000000000..b34c8e39e8fe
--- /dev/null
+++ b/devel/snorenotify/pkg-descr
@@ -0,0 +1,5 @@
+Snorenotify is a multi platform Qt notification framework. Using a plugin
+system it is possible to create notifications with many different notification
+systems on Windows, Mac OS and Unix and mobile Devices.
+
+WWW: https://github.com/KDE/snorenotify
diff --git a/devel/snorenotify/pkg-plist b/devel/snorenotify/pkg-plist
new file mode 100644
index 000000000000..729811daf519
--- /dev/null
+++ b/devel/snorenotify/pkg-plist
@@ -0,0 +1,56 @@
+bin/snorenotify
+bin/snoresend
+bin/snoresettings
+bin/snoresettings-cli
+include/libsnore/alert.h
+include/libsnore/application.h
+include/libsnore/hint.h
+include/libsnore/lambdahint.h
+include/libsnore/notification/icon.h
+include/libsnore/notification/notification.h
+include/libsnore/notification/notificationaction.h
+include/libsnore/plugins/plugins.h
+include/libsnore/plugins/settingsplugin.h
+include/libsnore/plugins/snorebackend.h
+include/libsnore/plugins/snorefrontend.h
+include/libsnore/plugins/snoresecondarybackend.h
+include/libsnore/settings/pluginsettingswidget.h
+include/libsnore/settings/settings.h
+include/libsnore/settings/settingsdialog.h
+include/libsnore/settings/snore_settings_exports.h
+include/libsnore/snore_exports.h
+include/libsnore/snore_p.h
+include/libsnore/snore.h
+include/libsnore/snoreglobals.h
+include/libsnore/utils.h
+include/libsnore/version.h
+lib/cmake/libsnoreQt5/LibsnoreQt5Config.cmake
+lib/cmake/libsnoreQt5/LibsnoreQt5ConfigVersion.cmake
+lib/cmake/libsnoreQt5/LibsnoreQt5Target-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/libsnoreQt5/LibsnoreQt5Target.cmake
+lib/cmake/libsnoreQt5/SnoreAddPlugin.cmake
+lib/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5Config.cmake
+lib/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5ConfigVersion.cmake
+lib/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5Target-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/libsnoresettingsQt5/LibsnoreSettingsQt5Target.cmake
+lib/libsnore-qt5.so
+lib/libsnore-qt5.so.0.7
+lib/libsnore-qt5.so.0.7.0
+lib/libsnoresettings-qt5.so
+lib/libsnoresettings-qt5.so.0.7
+lib/libsnoresettings-qt5.so.0.7.0
+%%QT_MKSPECDIR%%/modules/qt_LibsnoreQt5.pri
+%%QT_MKSPECDIR%%/modules/qt_LibsnoreSettingsQt5.pri
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_backend_freedesktop.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_frontend_freedesktop.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_frontend_snarlnetwork.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_secondarybackend_nma.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_secondarybackend_puhover.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_secondarybackend_toasty.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_backend_trayicon.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_settings_secondarybackend_nma.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_settings_secondarybackend_puhover.so
+%%QT_PLUGINDIR%%/libsnore-qt5/libsnore_settings_secondarybackend_toasty.so
+share/applications/snorenotify.desktop
+share/applications/snoresettings.desktop
+share/icons/hicolor/128x128/apps/snore.png