aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2011-05-06 06:20:12 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2011-05-06 06:20:12 +0000
commit2879ba6109bcd310912668b8e3e76ea84dc42abd (patch)
tree396735222e2da6d2f9c1a0145f326d25fa830009
parenta8eec48cb519d73d75a85f00fff0987bcabe2511 (diff)
downloadports-2879ba6109bcd310912668b8e3e76ea84dc42abd.tar.gz
ports-2879ba6109bcd310912668b8e3e76ea84dc42abd.zip
Change default Perl version to 5.12.
Notes
Notes: svn path=/head/; revision=273695
-rw-r--r--Mk/bsd.perl.mk2
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--UPDATING10
-rw-r--r--lang/perl5.10/Makefile2
-rw-r--r--lang/perl5.12/Makefile2
-rw-r--r--lang/perl5.14/Makefile2
-rw-r--r--lang/perl5.16/Makefile2
7 files changed, 16 insertions, 6 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 73560de8b9e2..78cee9519791 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -84,7 +84,7 @@ PERL_Include_MAINTAINER= perl@FreeBSD.org
# to set one of the conditionals that force the inclusion of bsd.perl.mk
.if defined(_PERL_REFACTORING_COMPLETE)
-PERL_VERSION?= 5.10.1
+PERL_VERSION?= 5.12.3
.if !defined(PERL_LEVEL) && defined(PERL_VERSION)
perl_major= ${PERL_VERSION:C|\..*||}
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 2035935ec45b..797cc8c1772d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1448,7 +1448,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
# to set one of the conditionals that force the inclusion of bsd.perl.mk
.if !defined(_PERL_REFACTORING_COMPLETE)
-PERL_VERSION?= 5.10.1
+PERL_VERSION?= 5.12.3
.if !defined(PERL_LEVEL) && defined(PERL_VERSION)
perl_major= ${PERL_VERSION:C|^([1-9]+).*|\1|}
diff --git a/UPDATING b/UPDATING
index dda678aa07a6..0e511dbd6027 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,16 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20110506:
+ AFFECTS: users of lang/perl*
+ AUTHOR: skv@FreeBSD.org
+
+ Default version of Perl was bumped to 5.12.
+
+ If you already have lang/perl5.10 or lang/perl5.8 installed, and want to
+ switch to lang/perl5.12 please follow instructions in the entry 20100715
+ in this file.
+
20110503
AFFECTS: users of www/codeigniter and www/codeigniter-devel
AUTHOR: glarkin@FreeBSD.org
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index cdef0674c517..d79377350361 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -158,7 +158,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-LATEST_LINK= perl
+NO_LATEST_LINK= yes
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index edf686e4a0db..9669180cf908 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -147,7 +147,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-NO_LATEST_LINK= yes
+LATEST_LINK= perl
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index edf686e4a0db..9669180cf908 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -147,7 +147,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-NO_LATEST_LINK= yes
+LATEST_LINK= perl
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index edf686e4a0db..9669180cf908 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -147,7 +147,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-NO_LATEST_LINK= yes
+LATEST_LINK= perl
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3