aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-21 18:40:15 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-21 18:40:15 +0000
commit2899abe804f2ace1bf29e05e3184155186f25394 (patch)
treedc019923ebe76aac3d5d88dc5c3edf2b201dca61
parentf5291514626c7271bb9440faa5058ebd66b92bb0 (diff)
php53 and fallout: Deprecate, set removal for 15 APR 2015
The PHP developers stopped providing security patches for the 5.3 branch on 14 August 2014. They "strongly urge" to upgrade to current versions "as using older versions may expose you to security vulnerabilities and bugs that have been fixed in more recent versions" of PHP. The PHP53 branch was released from maintainership today, so it's being deprecated with removal set for 15 April 2015. There were only 8 ports limited to php53, six of which were pecl- ports. These ports must be upgraded to use a later version of php (5.6 is recommended) soon, or they will be removed with php53. Note that all 8 ports incorrectly set the PHP_DEFAULT_VERSION, so this was changed to use IGNORE_WITH_PHP instead while here. PR: 198150
Notes
Notes: svn path=/head/; revision=381813
-rw-r--r--databases/sqlitemanager/Makefile6
-rw-r--r--devel/pecl-uuid/Makefile6
-rw-r--r--finance/php-tclink/Makefile5
-rw-r--r--german/pecl-konto_check/Makefile5
-rw-r--r--graphics/pecl-imlib2/Makefile6
-rw-r--r--lang/php53-extensions/Makefile3
-rw-r--r--lang/php53/Makefile3
-rw-r--r--print/pecl-ps/Makefile6
-rw-r--r--security/pecl-crack/Makefile6
-rw-r--r--www/pecl-amfext/Makefile6
10 files changed, 38 insertions, 14 deletions
diff --git a/databases/sqlitemanager/Makefile b/databases/sqlitemanager/Makefile
index f3f283270485..e01c0a7394fe 100644
--- a/databases/sqlitemanager/Makefile
+++ b/databases/sqlitemanager/Makefile
@@ -10,8 +10,10 @@ DISTNAME= SQLiteManager-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multilingual web based tool to manage SQLite database
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
+IGNORE_WITH_PHP=5 55 56
NO_BUILD= yes
PLIST_SUB+= WWWDIR_REL="${WWWDIR_REL}"
USE_PHP= sqlite
diff --git a/devel/pecl-uuid/Makefile b/devel/pecl-uuid/Makefile
index a9bb200c3163..c40b23e7dc9e 100644
--- a/devel/pecl-uuid/Makefile
+++ b/devel/pecl-uuid/Makefile
@@ -12,13 +12,15 @@ DIST_SUBDIR= PECL
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= UUID extension
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
LIB_DEPENDS= libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
CONFIGURE_ARGS= --with-uuid=${LOCALBASE} CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
PHP_MODNAME= ${PORTNAME}
USE_PHP= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
+IGNORE_WITH_PHP=5 55 56
.include <bsd.port.mk>
diff --git a/finance/php-tclink/Makefile b/finance/php-tclink/Makefile
index 1085df583e47..2e8f4bad66db 100644
--- a/finance/php-tclink/Makefile
+++ b/finance/php-tclink/Makefile
@@ -11,9 +11,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-php
MAINTAINER= mbowie@buzmo.com
COMMENT= PHP extension for TrustCommerce credit card processing
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
+IGNORE_WITH_PHP=5 55 56
USE_PHP= yes
USE_PHPEXT= yes
USE_OPENSSL= yes
-DEFAULT_PHP_VER=53
.include <bsd.port.mk>
diff --git a/german/pecl-konto_check/Makefile b/german/pecl-konto_check/Makefile
index bef349a788e5..db562149032f 100644
--- a/german/pecl-konto_check/Makefile
+++ b/german/pecl-konto_check/Makefile
@@ -10,12 +10,15 @@ PKGNAMEPREFIX= pecl-
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP module to check German and Austrian Bank Account Numbers
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
+IGNORE_WITH_PHP=5 55 56
USES= zip:infozip
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PORTNAME}
-DEFAULT_PHP_VER=53
WRKSRC= ${WRKDIR}/php
diff --git a/graphics/pecl-imlib2/Makefile b/graphics/pecl-imlib2/Makefile
index 2fb3db9ef4a7..a4e0afb08ad4 100644
--- a/graphics/pecl-imlib2/Makefile
+++ b/graphics/pecl-imlib2/Makefile
@@ -13,12 +13,14 @@ DIST_SUBDIR= PECL
MAINTAINER= leeym@FreeBSD.org
COMMENT= PECL extension if imlib2
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2
USE_PHP= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
+IGNORE_WITH_PHP=5 55 56
# libImlib2 may or may not depend on X, however,
# imlib2 extension doesn't need X related functions in libImlib2
diff --git a/lang/php53-extensions/Makefile b/lang/php53-extensions/Makefile
index bb346a4f2b58..f19631193f25 100644
--- a/lang/php53-extensions/Makefile
+++ b/lang/php53-extensions/Makefile
@@ -11,6 +11,9 @@ EXTRACT_ONLY= # none
MAINTAINER= ports@FreeBSD.org
COMMENT= "meta-port" to install PHP extensions
+DEPRECATED= security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
PHP_DEFAULT= 53
IGNORE_WITH_PHP=5 52 55
USE_PHP_BUILD= yes
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 27382acbe7c4..9dfc854ea087 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -12,6 +12,9 @@ DISTNAME= php-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP Scripting Language
+DEPRECATED= security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USES= tar:bzip2 cpe
diff --git a/print/pecl-ps/Makefile b/print/pecl-ps/Makefile
index a95240e58994..2c128c2f94a1 100644
--- a/print/pecl-ps/Makefile
+++ b/print/pecl-ps/Makefile
@@ -14,13 +14,15 @@ DIST_SUBDIR= PECL
MAINTAINER= alan@fromorbit.com
COMMENT= PHP extension for pslib to generate postscript
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
LIB_DEPENDS= libps.so:${PORTSDIR}/print/pslib
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PORTNAME}
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
+IGNORE_WITH_PHP=5 55 56
post-patch:
@${REINPLACE_CMD} -e 's|-ldl|-lintl|g' ${WRKSRC}/config.m4
diff --git a/security/pecl-crack/Makefile b/security/pecl-crack/Makefile
index 0642eb6d4bd6..d3244d864ac1 100644
--- a/security/pecl-crack/Makefile
+++ b/security/pecl-crack/Makefile
@@ -13,6 +13,9 @@ DIST_SUBDIR= PECL
MAINTAINER= wmoran@collaborativefusion.com
COMMENT= PECL extension to cracklib
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
LIB_DEPENDS= libcrack.so:${PORTSDIR}/security/cracklib
USE_PHP= yes
@@ -20,8 +23,7 @@ USE_PHPIZE= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= crack
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
+IGNORE_WITH_PHP=5 55 56
WRKSRC= ${WRKDIR}/crack-0.4
diff --git a/www/pecl-amfext/Makefile b/www/pecl-amfext/Makefile
index d7b1c292e349..253fbcdbbf2d 100644
--- a/www/pecl-amfext/Makefile
+++ b/www/pecl-amfext/Makefile
@@ -12,11 +12,13 @@ DIST_SUBDIR= PECL
MAINTAINER= meritus@innervision.pl
COMMENT= Implements encoding and decoding of AMF and AMF3 messages
+DEPRECATED= requires php53, security EOL reached 14 Aug 2014
+EXPIRATION_DATE= 2015-04-15
+
+IGNORE_WITH_PHP=5 55 56
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= amf
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-amf
CPPFLAGS+= -I${LOCALBASE}/include/php/ext/standard