aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-12 16:28:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-12 16:28:08 +0000
commit28ec8183db21f76367e85c95645753c109b25cd2 (patch)
tree2f70b58a1174fca7408f7c4231493cc5f1360746
parent5ee4e29ba704d1f0fef82e21b25fb52bf2ff1ce6 (diff)
downloadports-28ec8183db21f76367e85c95645753c109b25cd2.tar.gz
ports-28ec8183db21f76367e85c95645753c109b25cd2.zip
Notes
-rw-r--r--security/rndpassw/Makefile9
-rw-r--r--security/rndpassw/distinfo5
-rw-r--r--security/rndpassw/files/patch-Makefile26
-rw-r--r--security/rndpassw/files/patch-src_rndpassw.c29
-rw-r--r--security/rndpassw/pkg-descr2
5 files changed, 10 insertions, 61 deletions
diff --git a/security/rndpassw/Makefile b/security/rndpassw/Makefile
index 5b6a276e2bd5..fbc02010dbc6 100644
--- a/security/rndpassw/Makefile
+++ b/security/rndpassw/Makefile
@@ -1,16 +1,19 @@
# $FreeBSD$
PORTNAME= rndpassw
-PORTVERSION= 0.2
+PORTVERSION= 0.2.2
CATEGORIES= security
-MASTER_SITES= SF
MAINTAINER= melanhit@gmail.com
COMMENT= CLI password generator
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= tar:bzip2
+USE_GITHUB= yes
+GH_ACCOUNT= melanhit
+
+USES= cmake:outsource
PLIST_FILES= bin/rndpassw \
man/man1/rndpassw.1.gz
diff --git a/security/rndpassw/distinfo b/security/rndpassw/distinfo
index dadcc0470b36..da1f13a9600a 100644
--- a/security/rndpassw/distinfo
+++ b/security/rndpassw/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rndpassw-0.2.tar.bz2) = 5b65072a311a7f325947113322d18078aa079263025c1db59c6db1f4363eece0
-SIZE (rndpassw-0.2.tar.bz2) = 4216
+TIMESTAMP = 1473213814
+SHA256 (melanhit-rndpassw-0.2.2_GH0.tar.gz) = 2657c42515e624e3f19694648bdcabeb8ef070fc367ecde716d6fabbb9b3584c
+SIZE (melanhit-rndpassw-0.2.2_GH0.tar.gz) = 4404
diff --git a/security/rndpassw/files/patch-Makefile b/security/rndpassw/files/patch-Makefile
deleted file mode 100644
index eaa7ed39bdc1..000000000000
--- a/security/rndpassw/files/patch-Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- Makefile.org 2014-02-21 17:59:00.973237401 +0800
-+++ Makefile 2014-02-21 17:59:53.848746216 +0800
-@@ -1,4 +1,4 @@
--PREFIX?=/usr/local
-+PREFIX?=$(DESTDIR)$(PREFIX)
-
- CC?= cc
- CFLAGS?=-O2 -fno-strict-aliasing -pipe
-@@ -18,11 +18,11 @@
- @rm -f $(PROG) $(PROG).o
-
- install: build
-- @install -d $(PREFIX)/bin
-- @install -d $(PREFIX)/man/man1
-- install -c $(PROG) $(PREFIX)/bin/$(PROG)
-- install -c doc/man/$(PROG).1 $(PREFIX)/man/man1/$(PROG).1
-+ @install -d $(DESTDIR)$(PREFIX)/bin
-+ @install -d $(DESTDIR)$(PREFIX)/man/man1
-+ install -c $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
-+ install -c doc/man/$(PROG).1 $(DESTDIR)$(PREFIX)/man/man1/$(PROG).1
-
- uninstall:
-- rm -f $(PREFIX)/bin/$(PROG)
-- rm -f $(PREFIX)/man/man1/$(PROG).1.gz
-+ rm -f $(DESTDIR)$(PREFIX)/bin/$(PROG)
-+ rm -f $(DESTDIR)$(PREFIX)/man/man1/$(PROG).1.gz
diff --git a/security/rndpassw/files/patch-src_rndpassw.c b/security/rndpassw/files/patch-src_rndpassw.c
deleted file mode 100644
index 5117ff8bb7f5..000000000000
--- a/security/rndpassw/files/patch-src_rndpassw.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/rndpassw.c.orig 2014-03-02 18:22:27.000000000 -0500
-+++ src/rndpassw.c 2014-08-30 13:24:58.742060993 -0400
-@@ -24,7 +24,7 @@
-
- int main(int argc, char **argv)
- {
-- flags_t flags = { 0 };
-+ flags_t flags = { 0, 0, 0, 0 };
- int passlen = -1, passcnt = -1;
- int opt, mixlen = 0, entlen, fd;
- unsigned i, y, baselen = 0;
-@@ -133,7 +133,7 @@
-
- entoff = entbuf = malloc(entlen);
- if(entbuf == NULL) {
-- fprintf(stderr, "Could not allocate %zd bytes\n", entlen);
-+ fprintf(stderr, "Could not allocate %zd bytes\n", (size_t)entlen);
- return (1);
- }
-
-@@ -148,7 +148,7 @@
- /* create and fill dictionary */
- mixbuf = malloc(mixlen);
- if(mixbuf == NULL) {
-- fprintf(stderr, "Could not allocate %zd bytes of memory\n", mixlen);
-+ fprintf(stderr, "Could not allocate %zd bytes of memory\n", (size_t)mixlen);
- return (1);
- }
-
diff --git a/security/rndpassw/pkg-descr b/security/rndpassw/pkg-descr
index 60cddce1e6df..73790c66ddc5 100644
--- a/security/rndpassw/pkg-descr
+++ b/security/rndpassw/pkg-descr
@@ -1,3 +1,3 @@
Command line password generator
-WWW: http://sourceforge.net/projects/rndpassw
+WWW: https://github.com/melanhit/rndpassw