aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-24 14:03:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-24 14:03:04 +0000
commit28f8ee4611d178cba9a652c35ccb813d2d507082 (patch)
treec5cf96d8d3d25f8817f9a7d91e2f1dda8b7ceca1
parent65e107ab6988c9b2d4d980917430d8ab0cfee665 (diff)
downloadports-28f8ee4611d178cba9a652c35ccb813d2d507082.tar.gz
ports-28f8ee4611d178cba9a652c35ccb813d2d507082.zip
- COPYTREE_* are now part of bsd.port.mk
PR: ports/100996 Submitted by: stass
Notes
Notes: svn path=/head/; revision=188171
-rw-r--r--archivers/ruby-bz2/Makefile7
-rw-r--r--audio/ruby-freedb/Makefile7
-rw-r--r--audio/ruby-mp3info/Makefile7
-rw-r--r--audio/ruby-musicbrainz/Makefile7
-rw-r--r--cad/gspiceui/Makefile7
-rw-r--r--databases/ruby-cdb/Makefile7
-rw-r--r--devel/cc65/Makefile7
-rw-r--r--devel/ocaml-cfg/Makefile7
-rw-r--r--devel/ocaml-lacaml/Makefile7
-rw-r--r--devel/ocaml-pcre/Makefile7
-rw-r--r--devel/ocaml-pomap/Makefile7
-rw-r--r--devel/ocaml-res/Makefile7
-rw-r--r--devel/ruby-fam/Makefile7
-rw-r--r--devel/ruby-robjectteam/Makefile7
-rw-r--r--devel/sdl12/Makefile7
-rw-r--r--games/cube/Makefile7
-rw-r--r--games/frozenbubble/Makefile7
-rw-r--r--graphics/ocaml-lablgl/Makefile7
-rw-r--r--graphics/ruby-imlib2/Makefile7
-rw-r--r--lang/Sather/Makefile7
-rw-r--r--lang/newlisp/Makefile7
-rw-r--r--lang/ocaml/Makefile7
-rw-r--r--lang/ruby18/Makefile7
-rw-r--r--math/fxt/Makefile7
-rw-r--r--net/ocaml-netclient/Makefile7
-rw-r--r--net/ruby-ldap/Makefile7
26 files changed, 0 insertions, 182 deletions
diff --git a/archivers/ruby-bz2/Makefile b/archivers/ruby-bz2/Makefile
index ab5b51d7c877..0d388e7e06a1 100644
--- a/archivers/ruby-bz2/Makefile
+++ b/archivers/ruby-bz2/Makefile
@@ -29,13 +29,6 @@ DOCS= Changes \
${RUBY_RD_FILES} \
${RUBY_RD_HTML_FILES}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-build:
diff --git a/audio/ruby-freedb/Makefile b/audio/ruby-freedb/Makefile
index da57766ae582..bb098c60b772 100644
--- a/audio/ruby-freedb/Makefile
+++ b/audio/ruby-freedb/Makefile
@@ -25,13 +25,6 @@ INSTALL_TARGET= site-install
DOCS= CHANGELOG README doc
EXAMPLES= examples/*.rb
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
diff --git a/audio/ruby-mp3info/Makefile b/audio/ruby-mp3info/Makefile
index 652cc03dac5b..613e3295e68e 100644
--- a/audio/ruby-mp3info/Makefile
+++ b/audio/ruby-mp3info/Makefile
@@ -26,13 +26,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX}
DOCS= CHANGELOG EXAMPLES README
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
diff --git a/audio/ruby-musicbrainz/Makefile b/audio/ruby-musicbrainz/Makefile
index ec1977cfbf6d..a8c7eaa51179 100644
--- a/audio/ruby-musicbrainz/Makefile
+++ b/audio/ruby-musicbrainz/Makefile
@@ -27,13 +27,6 @@ INSTALL_TARGET= site-install
DOCS= README TODO doc
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
diff --git a/cad/gspiceui/Makefile b/cad/gspiceui/Makefile
index 2e3ebba869a5..787c49bf9572 100644
--- a/cad/gspiceui/Makefile
+++ b/cad/gspiceui/Makefile
@@ -27,13 +27,6 @@ OPTIONS= NGSPICE "Use ng-spice as backend" on \
PORTDOCS= *
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-patch:
diff --git a/databases/ruby-cdb/Makefile b/databases/ruby-cdb/Makefile
index 42b519ea7608..40b9b57891a8 100644
--- a/databases/ruby-cdb/Makefile
+++ b/databases/ruby-cdb/Makefile
@@ -26,13 +26,6 @@ CDB_PORTDIR= ${PORTSDIR}/databases/cdb
INSTALL_TARGET= site-install
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-extract:
diff --git a/devel/cc65/Makefile b/devel/cc65/Makefile
index 84a5dca3bb7c..4b71bbe94c20 100644
--- a/devel/cc65/Makefile
+++ b/devel/cc65/Makefile
@@ -25,13 +25,6 @@ MAKEFILE= ${WRKSRC}/make/gcc.mak
SUB_FILES= pkg-message
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
diff --git a/devel/ocaml-cfg/Makefile b/devel/ocaml-cfg/Makefile
index 993f312324df..4429d9717d7b 100644
--- a/devel/ocaml-cfg/Makefile
+++ b/devel/ocaml-cfg/Makefile
@@ -25,13 +25,6 @@ DOCS= README
DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-extract:
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
index 2e3523ae2501..a6e80831c38a 100644
--- a/devel/ocaml-lacaml/Makefile
+++ b/devel/ocaml-lacaml/Makefile
@@ -32,13 +32,6 @@ DOCS= README TODO
DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-extract:
diff --git a/devel/ocaml-pcre/Makefile b/devel/ocaml-pcre/Makefile
index a31919e189bf..816b2f77d086 100644
--- a/devel/ocaml-pcre/Makefile
+++ b/devel/ocaml-pcre/Makefile
@@ -27,13 +27,6 @@ MAKE_ENV+= LIBDIRS="${LOCALBASE}/lib"
USE_GMAKE= yes
EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
diff --git a/devel/ocaml-pomap/Makefile b/devel/ocaml-pomap/Makefile
index 7a1d0b6526da..e7bfca5dab09 100644
--- a/devel/ocaml-pomap/Makefile
+++ b/devel/ocaml-pomap/Makefile
@@ -25,13 +25,6 @@ DOCS= README
DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-extract:
diff --git a/devel/ocaml-res/Makefile b/devel/ocaml-res/Makefile
index f08718d20f23..079e7f2ca5ba 100644
--- a/devel/ocaml-res/Makefile
+++ b/devel/ocaml-res/Makefile
@@ -25,13 +25,6 @@ DOCS= README
DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-extract:
diff --git a/devel/ruby-fam/Makefile b/devel/ruby-fam/Makefile
index db3f9d23fd87..31ea9b8226ac 100644
--- a/devel/ruby-fam/Makefile
+++ b/devel/ruby-fam/Makefile
@@ -26,13 +26,6 @@ INSTALL_TARGET= site-install
DOCS= README doc event_codes.txt
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
diff --git a/devel/ruby-robjectteam/Makefile b/devel/ruby-robjectteam/Makefile
index 9b3fa220ef87..b5f9a72af482 100644
--- a/devel/ruby-robjectteam/Makefile
+++ b/devel/ruby-robjectteam/Makefile
@@ -28,13 +28,6 @@ DOCSDIR= ${RUBY_MODDOCDIR}
PORTDOCS= *
.endif
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
do-install:
cd ${WRKSRC}; ${RUBY} install.rb
.if !defined(NOPORTDOCS)
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 83f124fd1cb4..9f89dda3ec8a 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -37,13 +37,6 @@ PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+=--disable-video-x11
.endif
-# XXX: exists until it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
EXAMPLES= test/*.c test/*.bmp test/*.dat test/*.xbm test/*.wav
DOCS= BUGS COPYING CREDITS README README-SDL.txt WhatsNew docs.html
diff --git a/games/cube/Makefile b/games/cube/Makefile
index ce1f4239f146..597f3262c4ad 100644
--- a/games/cube/Makefile
+++ b/games/cube/Makefile
@@ -36,13 +36,6 @@ SUB_FILES= cube_client cube_server
CUBE_DATA= ${PORTNAME}_${PORTVERSION:S/./_/g}_unix.tar.gz
CUBE_SRC= ${PORTNAME}_${PORTVERSION:S/./_/g}_src.zip
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED)
diff --git a/games/frozenbubble/Makefile b/games/frozenbubble/Makefile
index a513d75b5922..dd76d9020829 100644
--- a/games/frozenbubble/Makefile
+++ b/games/frozenbubble/Makefile
@@ -34,13 +34,6 @@ MAN6= frozen-bubble-editor.6 frozen-bubble.6
LEXECDIR= ${PREFIX}/libexec/${PORTNAME}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 600020
diff --git a/graphics/ocaml-lablgl/Makefile b/graphics/ocaml-lablgl/Makefile
index 19b21d6aca4d..03d66e87ce6f 100644
--- a/graphics/ocaml-lablgl/Makefile
+++ b/graphics/ocaml-lablgl/Makefile
@@ -30,13 +30,6 @@ PATTERN= [[:space:]]*(do|then)?[[:space:]]*)cp([[:space:]]
DOCSDIR= ${PREFIX}/share/doc/ocaml/lablgl
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/lablgl
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
post-extract:
diff --git a/graphics/ruby-imlib2/Makefile b/graphics/ruby-imlib2/Makefile
index 49cdde3afd79..5d993fc67550 100644
--- a/graphics/ruby-imlib2/Makefile
+++ b/graphics/ruby-imlib2/Makefile
@@ -31,13 +31,6 @@ DOCSDIR= ${RUBY_MODDOCDIR}
PORTDOCS= *
.endif
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
diff --git a/lang/Sather/Makefile b/lang/Sather/Makefile
index 9d427d34763d..a4d35e8acaa5 100644
--- a/lang/Sather/Makefile
+++ b/lang/Sather/Makefile
@@ -50,13 +50,6 @@ BROKEN= boehm-gc is broken on ia64
BC_DIR!= cd ${PORTSDIR}/devel/boehm-gc && ${MAKE} -V WRKSRC
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-extract:
#
# Precompiled binaries are for Linux only
diff --git a/lang/newlisp/Makefile b/lang/newlisp/Makefile
index a097319bf8df..609a2767689d 100644
--- a/lang/newlisp/Makefile
+++ b/lang/newlisp/Makefile
@@ -25,13 +25,6 @@ MAN1= newlisp.1
REINPLACE_ARGS= -i ""
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
MODULES= cgi ftp infix odbc pop3 postscript smtp stat unix \
xmlrpc-client zlib
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index a56b6e445ddc..905bddddb5cd 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -35,13 +35,6 @@ OPTIONS= X11 "Build with X11 support" on \
MODOPT= camlp4o camlp4r ocamlc ocamldep ocamldoc ocamllex ocamlopt
PATTERN= [[:space:]]*(do|then)?[[:space:]]*)(\$$\(CP\)|cp)([[:space:]]
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.include <bsd.port.pre.mk>
MAN1!= ${CAT} ${FILESDIR}/man1
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 571c34c2dfbd..f2c208efe7a2 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -126,13 +126,6 @@ EXTDOCS= bigdecimal/bigdecimal_*.html \
MAN1= ${RUBY_NAME}.1
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
# Macros to change variables in rbconfig.rb
RB_SET_CONF_VAR=${SH} -c '${REINPLACE_CMD} -E -e "s,(CONFIG\[\"$$0\"\][[:space:]]*=[[:space:]]*)(\(?)(.*)(\)?),\1\2$$1\4," ${WRKSRC}/rbconfig.rb' --
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index 1b948d9e76ca..0e08e000c886 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -23,13 +23,6 @@ USE_GMAKE= yes
MAKEFILE= makefile
MAKE_ENV= CXX="${CXX}"
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-patch:
@${REINPLACE_CMD} -E \
-e 's,^(FXT_CXXFLAGS),#\1,' \
diff --git a/net/ocaml-netclient/Makefile b/net/ocaml-netclient/Makefile
index 49f0b3d5539e..46df6bc25c81 100644
--- a/net/ocaml-netclient/Makefile
+++ b/net/ocaml-netclient/Makefile
@@ -29,13 +29,6 @@ EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
diff --git a/net/ruby-ldap/Makefile b/net/ruby-ldap/Makefile
index daa2e71e88b0..0e1ecc96969f 100644
--- a/net/ruby-ldap/Makefile
+++ b/net/ruby-ldap/Makefile
@@ -56,13 +56,6 @@ INSTALL_TARGET= site-install
DOCS_EN= ChangeLog FAQ README TODO
-# XXX: exists untill it will be committed to bsd.port.mk
-COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
- 2>&1) && \
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
- ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
- ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-
post-patch:
${RUBY} -i -pe 'gsub %r|/usr/local/openldap|, "${PREFIX}"' \
-e 'gsub /ruby-1\.6/, "${RUBY}"' ${WRKSRC}/test/test.sh