aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-03-10 18:16:02 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-03-10 18:16:02 +0000
commit290352f2a7159394d506ff843782fa012ca7f81a (patch)
treef0a41cf9bd7191d500b6c14934db074dbc2e6d61
parentff3ca68472c8562c0008b68c9244b523c7543619 (diff)
downloadports-290352f2a7159394d506ff843782fa012ca7f81a.tar.gz
ports-290352f2a7159394d506ff843782fa012ca7f81a.zip
*: Move manpages to share/man
Approved by: portmgr (blanket)
-rw-r--r--www/tdom/Makefile1
-rw-r--r--www/tdom/pkg-plist18
-rw-r--r--x11-clocks/osdclock/Makefile6
-rw-r--r--x11-clocks/xdaliclock-classic/Makefile4
-rw-r--r--x11-drivers/xf86-input-egalax/Makefile4
-rw-r--r--x11-drivers/xf86-input-egalax/pkg-plist2
6 files changed, 20 insertions, 15 deletions
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index db8b941a48d9..e9645ef2078a 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= tcl:tea
CONFIGURE_ARGS= --enable-threads --disable-tdomalloc
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
EXTRACT_AFTER_ARGS=--exclude 'expat*/*.c' --exclude 'expat*/[a-mo-z]*.h' \
--exclude 'domalloc*' --exclude win
diff --git a/www/tdom/pkg-plist b/www/tdom/pkg-plist
index 59589590356f..d6eb7a7bb60f 100644
--- a/www/tdom/pkg-plist
+++ b/www/tdom/pkg-plist
@@ -4,15 +4,15 @@ lib/tdom%%PORTVERSION%%/libtdomstub%%PORTVERSION%%.a
lib/tdom%%PORTVERSION%%/pkgIndex.tcl
lib/tdom%%PORTVERSION%%/tdom.tcl
lib/tdomConfig.sh
-man/mann/dom.n.gz
-man/mann/domDoc.n.gz
-man/mann/domNode.n.gz
-man/mann/expat.n.gz
-man/mann/expatapi.n.gz
-man/mann/pullparser.n.gz
-man/mann/schema.n.gz
-man/mann/tdomcmd.n.gz
-man/mann/tnc.n.gz
+share/man/mann/dom.n.gz
+share/man/mann/domDoc.n.gz
+share/man/mann/domNode.n.gz
+share/man/mann/expat.n.gz
+share/man/mann/expatapi.n.gz
+share/man/mann/pullparser.n.gz
+share/man/mann/schema.n.gz
+share/man/mann/tdomcmd.n.gz
+share/man/mann/tnc.n.gz
%%PORTDOCS%%%%DOCSDIR%%/html/category-index.html
%%PORTDOCS%%%%DOCSDIR%%/html/dom.html
%%PORTDOCS%%%%DOCSDIR%%/html/domDoc.html
diff --git a/x11-clocks/osdclock/Makefile b/x11-clocks/osdclock/Makefile
index ccfb7990f499..17b359cebe49 100644
--- a/x11-clocks/osdclock/Makefile
+++ b/x11-clocks/osdclock/Makefile
@@ -1,6 +1,6 @@
PORTNAME= osdclock
PORTVERSION= 0.5
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11-clocks
MASTER_SITES= http://leftorium.net/software/ \
LOCAL/novel
@@ -15,9 +15,9 @@ LIB_DEPENDS= libxosd.so:misc/xosd
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lpthread
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- PREFIX="${PREFIX}"
+ PREFIX="${PREFIX}" MANDIR="${PREFIX}/share/man"
-PLIST_FILES= bin/osd_clock man/man1/osd_clock.1.gz
+PLIST_FILES= bin/osd_clock share/man/man1/osd_clock.1.gz
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/osd_clock
diff --git a/x11-clocks/xdaliclock-classic/Makefile b/x11-clocks/xdaliclock-classic/Makefile
index 04ecf8c7a6a8..2c0b719707a6 100644
--- a/x11-clocks/xdaliclock-classic/Makefile
+++ b/x11-clocks/xdaliclock-classic/Makefile
@@ -1,5 +1,6 @@
PORTNAME= xdaliclock
PORTVERSION= 2.44
+PORTREVISION= 1
CATEGORIES= x11-clocks
MASTER_SITES= https://www.jwz.org/xdaliclock/
PKGNAMESUFFIX= -classic
@@ -12,11 +13,12 @@ USES= xorg
USE_XORG= ice sm x11 xext xt
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
PORTSCOUT= limit:^2\.44
CONFLICTS= xdaliclock
WRKSRC= ${WRKDIR}/${DISTNAME}/X11
PLIST_FILES= bin/xdaliclock \
- man/man1/${PORTNAME}.1.gz
+ share/man/man1/${PORTNAME}.1.gz
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-input-egalax/Makefile b/x11-drivers/xf86-input-egalax/Makefile
index 2a6170114159..4c54a5be581e 100644
--- a/x11-drivers/xf86-input-egalax/Makefile
+++ b/x11-drivers/xf86-input-egalax/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xf86-input-egalax
PORTVERSION= 0.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-drivers
MAINTAINER= glebius@FreeBSD.org
@@ -14,4 +14,6 @@ LICENSE= BSD2CLAUSE
USES= autoreconf xorg-cat:driver
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share/man
+
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-input-egalax/pkg-plist b/x11-drivers/xf86-input-egalax/pkg-plist
index 68ead3abf57f..60673731988b 100644
--- a/x11-drivers/xf86-input-egalax/pkg-plist
+++ b/x11-drivers/xf86-input-egalax/pkg-plist
@@ -1,2 +1,2 @@
lib/xorg/modules/input/egalax_drv.so
-man/man4/egalax.4x.gz
+share/man/man4/egalax.4x.gz