aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2025-02-19 13:35:40 +0000
committerMikael Urankar <mikael@FreeBSD.org>2025-03-05 17:51:28 +0000
commit292dda7ff99975ed275afc30432a0bf61b6c0e78 (patch)
treec5a79b995f7e15b255ee87420ac10a5f394e282a
parent942e4eb666ff86f08f699b17a812f98f77a6a754 (diff)
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/kweathercore/Makefile18
-rw-r--r--deskutils/kweathercore/distinfo3
-rw-r--r--deskutils/kweathercore/pkg-descr8
-rw-r--r--deskutils/kweathercore/pkg-plist83
5 files changed, 113 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 7ab96cd21d1f..8731d6e4de70 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -153,6 +153,7 @@
SUBDIR += kruler
SUBDIR += ktimetracker
SUBDIR += kuserfeedback
+ SUBDIR += kweathercore
SUBDIR += latte-dock
SUBDIR += lazycli
SUBDIR += libcprime
diff --git a/deskutils/kweathercore/Makefile b/deskutils/kweathercore/Makefile
new file mode 100644
index 000000000000..8cd2d0424595
--- /dev/null
+++ b/deskutils/kweathercore/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= kweathercore
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= deskutils kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Library to facilitate retrieval of weather information
+WWW= https://invent.kde.org/libraries/kweathercore
+
+LICENSE= LGPL20+
+LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.0-or-later.txt
+
+USES= cmake gettext kde:6 qt:6 tar:xz
+USE_KDE= holidays i18n \
+ ecm:build
+USE_QT= base positioning
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/kweathercore/distinfo b/deskutils/kweathercore/distinfo
new file mode 100644
index 000000000000..ec896b366504
--- /dev/null
+++ b/deskutils/kweathercore/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1739962654
+SHA256 (KDE/release-service/24.12.2/kweathercore-24.12.2.tar.xz) = e61d9a3b426b150d71ece164eee824eb65833a292d31b7204bb6a5f357bd82de
+SIZE (KDE/release-service/24.12.2/kweathercore-24.12.2.tar.xz) = 75832
diff --git a/deskutils/kweathercore/pkg-descr b/deskutils/kweathercore/pkg-descr
new file mode 100644
index 000000000000..10f2d6da837d
--- /dev/null
+++ b/deskutils/kweathercore/pkg-descr
@@ -0,0 +1,8 @@
+Get weather forecast and alerts anywhere on the earth easy.
+KWeatherCore provides you a highly abstracted library for things related to
+weather.
+
+Features:
+ - Get local weather forecast.
+ - Get weather of a location by name or coordinate.
+ - Weather alerts of a country (ToDo)
diff --git a/deskutils/kweathercore/pkg-plist b/deskutils/kweathercore/pkg-plist
new file mode 100644
index 000000000000..0d3077d82f29
--- /dev/null
+++ b/deskutils/kweathercore/pkg-plist
@@ -0,0 +1,83 @@
+include/KWeatherCore/KWeatherCore/CAPAlertInfo
+include/KWeatherCore/KWeatherCore/CAPAlertMessage
+include/KWeatherCore/KWeatherCore/CAPArea
+include/KWeatherCore/KWeatherCore/CAPNamedValue
+include/KWeatherCore/KWeatherCore/CAPParser
+include/KWeatherCore/KWeatherCore/CAPReference
+include/KWeatherCore/KWeatherCore/DailyWeatherForecast
+include/KWeatherCore/KWeatherCore/GeoTimezone
+include/KWeatherCore/KWeatherCore/HourlyWeatherForecast
+include/KWeatherCore/KWeatherCore/LocationQuery
+include/KWeatherCore/KWeatherCore/LocationQueryReply
+include/KWeatherCore/KWeatherCore/LocationQueryResult
+include/KWeatherCore/KWeatherCore/PendingWeatherForecast
+include/KWeatherCore/KWeatherCore/Reply
+include/KWeatherCore/KWeatherCore/WeatherForecast
+include/KWeatherCore/KWeatherCore/WeatherForecastSource
+include/KWeatherCore/kweathercore/capalertinfo.h
+include/KWeatherCore/kweathercore/capalertmessage.h
+include/KWeatherCore/kweathercore/caparea.h
+include/KWeatherCore/kweathercore/capnamedvalue.h
+include/KWeatherCore/kweathercore/capparser.h
+include/KWeatherCore/kweathercore/capreference.h
+include/KWeatherCore/kweathercore/dailyweatherforecast.h
+include/KWeatherCore/kweathercore/geotimezone.h
+include/KWeatherCore/kweathercore/hourlyweatherforecast.h
+include/KWeatherCore/kweathercore/kweathercore_export.h
+include/KWeatherCore/kweathercore/locationquery.h
+include/KWeatherCore/kweathercore/locationqueryreply.h
+include/KWeatherCore/kweathercore/locationqueryresult.h
+include/KWeatherCore/kweathercore/pendingweatherforecast.h
+include/KWeatherCore/kweathercore/reply.h
+include/KWeatherCore/kweathercore/weatherforecast.h
+include/KWeatherCore/kweathercore/weatherforecastsource.h
+include/kweathercore_version.h
+lib/cmake/KWeatherCore/KWeatherCoreConfig.cmake
+lib/cmake/KWeatherCore/KWeatherCoreConfigVersion.cmake
+lib/cmake/KWeatherCore/KWeatherCoreTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KWeatherCore/KWeatherCoreTargets.cmake
+lib/libKWeatherCore.so
+lib/libKWeatherCore.so.%%KDE_APPLICATIONS_VERSION%%
+lib/libKWeatherCore.so.6
+%%QT_MKSPECDIR%%/modules/qt_KWeatherCore.pri
+share/locale/ar/LC_MESSAGES/kweathercore6.mo
+share/locale/ast/LC_MESSAGES/kweathercore6.mo
+share/locale/az/LC_MESSAGES/kweathercore6.mo
+share/locale/bg/LC_MESSAGES/kweathercore6.mo
+share/locale/ca/LC_MESSAGES/kweathercore6.mo
+share/locale/ca@valencia/LC_MESSAGES/kweathercore6.mo
+share/locale/cs/LC_MESSAGES/kweathercore6.mo
+share/locale/de/LC_MESSAGES/kweathercore6.mo
+share/locale/el/LC_MESSAGES/kweathercore6.mo
+share/locale/en_GB/LC_MESSAGES/kweathercore6.mo
+share/locale/eo/LC_MESSAGES/kweathercore6.mo
+share/locale/es/LC_MESSAGES/kweathercore6.mo
+share/locale/eu/LC_MESSAGES/kweathercore6.mo
+share/locale/fi/LC_MESSAGES/kweathercore6.mo
+share/locale/fr/LC_MESSAGES/kweathercore6.mo
+share/locale/gl/LC_MESSAGES/kweathercore6.mo
+share/locale/he/LC_MESSAGES/kweathercore6.mo
+share/locale/hi/LC_MESSAGES/kweathercore6.mo
+share/locale/hu/LC_MESSAGES/kweathercore6.mo
+share/locale/ia/LC_MESSAGES/kweathercore6.mo
+share/locale/is/LC_MESSAGES/kweathercore6.mo
+share/locale/it/LC_MESSAGES/kweathercore6.mo
+share/locale/ja/LC_MESSAGES/kweathercore6.mo
+share/locale/ka/LC_MESSAGES/kweathercore6.mo
+share/locale/ko/LC_MESSAGES/kweathercore6.mo
+share/locale/lt/LC_MESSAGES/kweathercore6.mo
+share/locale/lv/LC_MESSAGES/kweathercore6.mo
+share/locale/nl/LC_MESSAGES/kweathercore6.mo
+share/locale/nn/LC_MESSAGES/kweathercore6.mo
+share/locale/pa/LC_MESSAGES/kweathercore6.mo
+share/locale/pl/LC_MESSAGES/kweathercore6.mo
+share/locale/pt/LC_MESSAGES/kweathercore6.mo
+share/locale/pt_BR/LC_MESSAGES/kweathercore6.mo
+share/locale/ru/LC_MESSAGES/kweathercore6.mo
+share/locale/sk/LC_MESSAGES/kweathercore6.mo
+share/locale/sl/LC_MESSAGES/kweathercore6.mo
+share/locale/sv/LC_MESSAGES/kweathercore6.mo
+share/locale/tr/LC_MESSAGES/kweathercore6.mo
+share/locale/uk/LC_MESSAGES/kweathercore6.mo
+share/locale/zh_CN/LC_MESSAGES/kweathercore6.mo
+share/locale/zh_TW/LC_MESSAGES/kweathercore6.mo