aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-08-14 16:40:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-08-14 16:40:46 +0000
commit2af0a31eb614acbd04021c12d6b5cedcb25492a4 (patch)
treed4e237c6dbf0d1b07f393f3d9658fd632949a211
parent96862160f07aa9ff87772303f4b7e0a79caa47b4 (diff)
downloadports-2af0a31eb614acbd04021c12d6b5cedcb25492a4.tar.gz
ports-2af0a31eb614acbd04021c12d6b5cedcb25492a4.zip
Notes
-rw-r--r--graphics/podofo/Makefile3
-rw-r--r--graphics/podofo/distinfo6
-rw-r--r--graphics/podofo/files/patch-CMakeLists.txt32
-rw-r--r--graphics/podofo/files/patch-src-CMakeLists.txt8
-rw-r--r--graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt2
5 files changed, 23 insertions, 28 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 0fe96bd9bb52..e41c179fe09e 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= podofo
-PORTVERSION= 0.9.5
-PORTREVISION= 1
+PORTVERSION= 0.9.6
CATEGORIES= graphics print
MASTER_SITES= SF
diff --git a/graphics/podofo/distinfo b/graphics/podofo/distinfo
index baa0a11b0d54..ea7f27a021a7 100644
--- a/graphics/podofo/distinfo
+++ b/graphics/podofo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494045852
-SHA256 (podofo-0.9.5.tar.gz) = 854981cb897ebc14bac854ea0f25305372261a48a205363fe1c61659ba7b5304
-SIZE (podofo-0.9.5.tar.gz) = 1160799
+TIMESTAMP = 1532975069
+SHA256 (podofo-0.9.6.tar.gz) = e9163650955ab8e4b9532e7aa43b841bac45701f7b0f9b793a98c8ca3ef14072
+SIZE (podofo-0.9.6.tar.gz) = 995898
diff --git a/graphics/podofo/files/patch-CMakeLists.txt b/graphics/podofo/files/patch-CMakeLists.txt
index 0434f209cd30..d4fa141f26d0 100644
--- a/graphics/podofo/files/patch-CMakeLists.txt
+++ b/graphics/podofo/files/patch-CMakeLists.txt
@@ -1,14 +1,6 @@
---- CMakeLists.txt.orig 2016-06-08 20:55:08 UTC
+--- CMakeLists.txt.orig 2018-07-08 10:33:27 UTC
+++ CMakeLists.txt
-@@ -16,7 +16,6 @@ SET(PODOFO_VERSION_PATCH "4" CACHE STRIN
- SET(PODOFO_SOVERSION "${PODOFO_VERSION_MAJOR}.${PODOFO_VERSION_MINOR}.${PODOFO_VERSION_PATCH}")
- SET(PODOFO_LIBVERSION "${PODOFO_SOVERSION}")
-
--
- #
- # Main includes
- #
-@@ -345,6 +344,7 @@ ELSE(LIBIDN_FOUND)
+@@ -339,6 +339,7 @@ ELSE(LIBIDN_FOUND)
MESSAGE("Libidn not found. AES-256 Encryption support will be disabled")
ENDIF(LIBIDN_FOUND)
@@ -16,7 +8,7 @@
FIND_PACKAGE(LIBJPEG)
IF(LIBJPEG_FOUND)
-@@ -354,7 +354,9 @@ IF(LIBJPEG_FOUND)
+@@ -348,7 +349,9 @@ IF(LIBJPEG_FOUND)
ELSE(LIBJPEG_FOUND)
MESSAGE("Libjpeg not found. JPEG support will be disabled")
ENDIF(LIBJPEG_FOUND)
@@ -26,7 +18,7 @@
FIND_PACKAGE(TIFF)
IF(TIFF_FOUND)
-@@ -364,7 +366,9 @@ IF(TIFF_FOUND)
+@@ -358,7 +361,9 @@ IF(TIFF_FOUND)
ELSE(TIFF_FOUND)
MESSAGE("Libtiff not found. TIFF support will be disabled")
ENDIF(TIFF_FOUND)
@@ -36,19 +28,23 @@
FIND_PACKAGE(PNG)
IF(PNG_FOUND)
-@@ -374,9 +378,11 @@ IF(PNG_FOUND)
- ELSE(PNG_FOUND)
+@@ -369,6 +374,7 @@ ELSE(PNG_FOUND)
MESSAGE("LibPng not found. PNG support will be disabled")
+ SET(PNG_LIBRARIES "")
ENDIF(PNG_FOUND)
+ENDIF(WANT_PNG)
+ FIND_PACKAGE(UNISTRING)
+
+@@ -384,6 +390,7 @@ ENDIF(UNISTRING_FOUND)
+
IF(NOT PODOFO_BUILD_LIB_ONLY)
+IF(WANT_CppUnit)
FIND_PACKAGE(CppUnit)
IF(CppUnit_FOUND)
-@@ -386,6 +392,7 @@ IF(CppUnit_FOUND)
+@@ -393,6 +400,7 @@ IF(CppUnit_FOUND)
ELSE(CppUnit_FOUND)
MESSAGE("Cppunit not found. No unit tests will be built.")
ENDIF(CppUnit_FOUND)
@@ -56,7 +52,7 @@
ENDIF(NOT PODOFO_BUILD_LIB_ONLY)
-@@ -426,6 +433,7 @@ ELSE(WANT_FONTCONFIG)
+@@ -433,6 +441,7 @@ ELSE(WANT_FONTCONFIG)
ENDIF(WANT_FONTCONFIG)
IF(NOT PODOFO_BUILD_LIB_ONLY)
@@ -64,7 +60,7 @@
FIND_PACKAGE(LUA)
IF(LUA_FOUND)
# If we have lua, we can build podofoimpose.
-@@ -437,6 +445,7 @@ IF(LUA_FOUND)
+@@ -444,6 +453,7 @@ IF(LUA_FOUND)
ELSE(LUA_FOUND)
MESSAGE("Lua not found - PoDoFoImpose and PoDoFoColor will be built without Lua support")
ENDIF(LUA_FOUND)
@@ -72,7 +68,7 @@
ENDIF(NOT PODOFO_BUILD_LIB_ONLY)
-@@ -510,7 +519,7 @@ SET(PODOFO_LIB
+@@ -530,7 +540,7 @@ ENDIF(WIN32 OR PODOFO_BUILD_STATIC)
#
# Setup directories we will need
#
diff --git a/graphics/podofo/files/patch-src-CMakeLists.txt b/graphics/podofo/files/patch-src-CMakeLists.txt
index 4aec29293c76..2da848249e58 100644
--- a/graphics/podofo/files/patch-src-CMakeLists.txt
+++ b/graphics/podofo/files/patch-src-CMakeLists.txt
@@ -1,7 +1,7 @@
---- src/CMakeLists.txt.orig 2016-04-21 20:19:17 UTC
+--- src/CMakeLists.txt.orig 2018-03-11 11:42:20 UTC
+++ src/CMakeLists.txt
-@@ -268,8 +268,8 @@ IF(PODOFO_BUILD_STATIC)
- ADD_LIBRARY(podofo_static STATIC ${PODOFO_BASE_SOURCES} ${PODOFO_DOC_SOURCES})
+@@ -263,8 +263,8 @@ IF(PODOFO_BUILD_STATIC)
+ ADD_LIBRARY(podofo_static STATIC ${PODOFO_BASE_SOURCES} ${PODOFO_DOC_SOURCES} ${PODOFO_HEADER_FILES})
TARGET_LINK_LIBRARIES(podofo_static ${PODOFO_LIB_DEPENDS})
SET_TARGET_PROPERTIES(podofo_static PROPERTIES
- VERSION "${PODOFO_LIBVERSION}"
@@ -11,7 +11,7 @@
CLEAN_DIRECT_OUTPUT 1
OUTPUT_NAME "podofo"
COMPILE_FLAGS "-DBUILDING_PODOFO"
-@@ -292,8 +292,8 @@ IF(PODOFO_BUILD_SHARED)
+@@ -287,8 +287,8 @@ IF(PODOFO_BUILD_SHARED)
# Visual Studio, since it produces invalid warnings about STL
# use.
SET_TARGET_PROPERTIES(podofo_shared PROPERTIES
diff --git a/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt b/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
index 213168ffbd8f..e67b8949b0f7 100644
--- a/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
+++ b/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
@@ -2,7 +2,7 @@ Prior to 3.12 cmake silently created an empty destination directory if the origi
--- test/TokenizerTest/CMakeLists.txt.orig 2007-09-16 09:33:38 UTC
+++ test/TokenizerTest/CMakeLists.txt
-@@ -7,5 +7,6 @@ ADD_DEPENDENCIES(TokenizerTest ${PODOFO_DEPEND_TARGET}
+@@ -7,5 +7,6 @@ ADD_DEPENDENCIES(TokenizerTest ${PODOFO_
ADD_CUSTOM_COMMAND(
TARGET TokenizerTest
POST_BUILD