aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 07:20:26 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 07:20:26 +0000
commit2bf52d522f6c9388af152255f0abe2897c94181d (patch)
tree73b578f3d650af69c826376a61c6b7cda12d66a7
parent3f88c858b13f4267f690c2a20415ea6c479909b9 (diff)
downloadports-2bf52d522f6c9388af152255f0abe2897c94181d.tar.gz
ports-2bf52d522f6c9388af152255f0abe2897c94181d.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/avahi-sharp/Makefile55
-rw-r--r--net/avahi-sharp/pkg-descr3
-rw-r--r--net/avahi-sharp/pkg-plist9
-rw-r--r--net/avahi/files/patch-avahi-sharp_Makefile.in16
5 files changed, 84 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 30376a00e419..42088f899f04 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -32,6 +32,7 @@
SUBDIR += asterisk-oh323
SUBDIR += atmsupport
SUBDIR += avahi
+ SUBDIR += avahi-sharp
SUBDIR += b2bua
SUBDIR += balance
SUBDIR += bbsnet
diff --git a/net/avahi-sharp/Makefile b/net/avahi-sharp/Makefile
new file mode 100644
index 000000000000..d74cd57e14e1
--- /dev/null
+++ b/net/avahi-sharp/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: avahi-sharp
+# Date Created: 20041011
+# Whom: Tom McLaughlin <tmclaugh@FreeBSD.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.2 2006/02/15 19:15:40 tmclau02 Exp $
+#
+
+PORTREVISION= 0
+CATEGORIES= net dns
+PKGNAMESUFFIX= -sharp
+
+MAINTAINER= bsd-sharp-list@forge.novell.com
+COMMENT= Mono bindings for Avahi service discovery
+
+LIB_DEPENDS= avahi-core:${PORTSDIR}/net/avahi
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
+
+MASTERDIR= ${.CURDIR}/../avahi
+BUILD_WRKSRC= ${WRKSRC}/avahi-sharp
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+AVAHI_SLAVE= yes
+
+USE_GNOME= gnomehack gnometarget
+CONFIGURE_ARGS= --with-distro=freebsd \
+ --with-dbus-system-address=unix:path=/var/run/dbus \
+ --disable-qt3 \
+ --disable-qt4 \
+ --disable-python \
+ --enable-mono \
+ --disable-monodoc \
+ --disable-doxygen-doc \
+ --disable-doxygen-dot \
+ --localstatedir=/var
+
+post-patch:
+ @${REINPLACE_CMD} 's|@CLIENT_DLNAME@|libavahi-client.so|g; \
+ s|@COMMON_DLNAME@|libavahi-common.so|g; \
+ s|@GLIB_DLNAME@|libavahi-glib.so|g' \
+ ${BUILD_WRKSRC}/avahi-sharp.dll.config.in
+ @${REINPLACE_CMD} 's|@prefix@|${PREFIX}|g; \
+ s|@libdir@|$${prefix}/lib|g; \
+ s|@PACKAGE_VERSION@|${PORTVERSION}|g' \
+ ${WRKSRC}/avahi-sharp.pc.in
+ @${CP} ${WRKSRC}/avahi-sharp.pc.in ${WRKSRC}/avahi-sharp.pc
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/avahi-sharp.pc ${PREFIX}/libdata/pkgconfig/
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-sharp/pkg-descr b/net/avahi-sharp/pkg-descr
new file mode 100644
index 000000000000..b3712a1ee0df
--- /dev/null
+++ b/net/avahi-sharp/pkg-descr
@@ -0,0 +1,3 @@
+The C# interface to Avahi service discovery.
+
+WWW: http://www.avahi.org/
diff --git a/net/avahi-sharp/pkg-plist b/net/avahi-sharp/pkg-plist
new file mode 100644
index 000000000000..b65dff562851
--- /dev/null
+++ b/net/avahi-sharp/pkg-plist
@@ -0,0 +1,9 @@
+lib/mono/avahi-sharp/avahi-sharp.dll
+lib/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll
+lib/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll.config
+lib/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5/avahi-sharp.dll.mdb
+lib/pkgconfig/avahi-sharp.pc
+@dirrm lib/mono/gac/avahi-sharp/1.0.0.0__4d116c78973743f5
+@dirrm lib/mono/gac/avahi-sharp
+@dirrm lib/mono/avahi-sharp
+
diff --git a/net/avahi/files/patch-avahi-sharp_Makefile.in b/net/avahi/files/patch-avahi-sharp_Makefile.in
new file mode 100644
index 000000000000..45c44adbea75
--- /dev/null
+++ b/net/avahi/files/patch-avahi-sharp_Makefile.in
@@ -0,0 +1,16 @@
+--- avahi-sharp/Makefile.in.orig Tue Feb 7 23:04:12 2006
++++ avahi-sharp/Makefile.in Tue Feb 7 23:25:30 2006
+@@ -573,10 +573,10 @@
+ $(ASSEMBLY): $(AVAHISOURCES)
+ mcs -keyfile:$(srcdir)/avahi.snk -target:library -out:$@ -debug $(AVAHISOURCES) -r:Mono.Posix
+
+ $(ASSEMBLY).config: $(ASSEMBLY).config.in
+- $(srcdir)/gencfg.sh $(top_builddir)/avahi-client/libavahi-client.la \
+- $(top_builddir)/avahi-common/libavahi-common.la \
+- $(top_builddir)/avahi-glib/libavahi-glib.la < $< > $@
++# $(srcdir)/gencfg.sh $(top_builddir)/avahi-client/libavahi-client.la \
++# $(top_builddir)/avahi-common/libavahi-common.la \
++# $(top_builddir)/avahi-glib/libavahi-glib.la < $< > $@
+
+ @HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@all: $(ASSEMBLY) $(ASSEMBLY).config
+