aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-05-04 06:37:02 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-05-04 06:54:24 +0000
commit2ccd6b5da7dfaddcdf0cbbafee469b133310410b (patch)
tree3e6adaf03cc6b1ff02394df9ca6355202ee43e8d
parente3d3a9cd2e074f636b62bd324c44351f56f50900 (diff)
downloadports-2ccd6b5da7dfaddcdf0cbbafee469b133310410b.tar.gz
ports-2ccd6b5da7dfaddcdf0cbbafee469b133310410b.zip
editors/lazarus-*: Fix issues with Qt5/Qt6
-rw-r--r--editors/lazarus-devel/Makefile2
-rw-r--r--editors/lazarus-devel/files/patch-lcl_interfaces_qt5_qtwidgets.pas11
-rw-r--r--editors/lazarus-devel/files/patch-lcl_interfaces_qt6_qtwidgets.pas11
-rw-r--r--editors/lazarus-qt5/Makefile2
-rw-r--r--editors/lazarus-qt6/Makefile2
-rw-r--r--editors/lazarus/Makefile2
-rw-r--r--editors/lazarus/files/patch-lcl_interfaces_qt5_qtwidgets.pas11
-rw-r--r--editors/lazarus/files/patch-lcl_interfaces_qt6_qtwidgets.pas14
8 files changed, 51 insertions, 4 deletions
diff --git a/editors/lazarus-devel/Makefile b/editors/lazarus-devel/Makefile
index 42aef8d1abbf..02c99c5d37ac 100644
--- a/editors/lazarus-devel/Makefile
+++ b/editors/lazarus-devel/Makefile
@@ -1,7 +1,7 @@
PORTNAME= lazarus
DISTVERSION= 3.3.1.20240503
PKGNAMESUFFIX?= -gtk2-devel
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= editors devel
DIST_SUBDIR= freepascal
diff --git a/editors/lazarus-devel/files/patch-lcl_interfaces_qt5_qtwidgets.pas b/editors/lazarus-devel/files/patch-lcl_interfaces_qt5_qtwidgets.pas
new file mode 100644
index 000000000000..2a6d1a08d233
--- /dev/null
+++ b/editors/lazarus-devel/files/patch-lcl_interfaces_qt5_qtwidgets.pas
@@ -0,0 +1,11 @@
+--- lcl/interfaces/qt5/qtwidgets.pas.orig 2024-05-04 05:19:24 UTC
++++ lcl/interfaces/qt5/qtwidgets.pas
+@@ -10213,7 +10213,7 @@ end;
+
+ procedure TQtTextEdit.setReadOnly(const AReadOnly: Boolean);
+ begin
+- {$IFDEF DARWIN} // issue #40246
++ {$IF DEFINED(DARWIN) OR DEFINED(FREEBSD)} // issue #40246
+ if AReadOnly <> QTextEdit_isReadOnly(QTextEditH(Widget)) then
+ {$ENDIF}
+ QTextEdit_setReadOnly(QTextEditH(Widget), AReadOnly);
diff --git a/editors/lazarus-devel/files/patch-lcl_interfaces_qt6_qtwidgets.pas b/editors/lazarus-devel/files/patch-lcl_interfaces_qt6_qtwidgets.pas
new file mode 100644
index 000000000000..c220646a5d25
--- /dev/null
+++ b/editors/lazarus-devel/files/patch-lcl_interfaces_qt6_qtwidgets.pas
@@ -0,0 +1,11 @@
+--- lcl/interfaces/qt6/qtwidgets.pas.orig 2024-05-04 04:27:27 UTC
++++ lcl/interfaces/qt6/qtwidgets.pas
+@@ -10245,7 +10245,7 @@ end;
+
+ procedure TQtTextEdit.setReadOnly(const AReadOnly: Boolean);
+ begin
+- {$IFDEF DARWIN} // issue #40246
++ {$IF DEFINED(DARWIN) OR DEFINED(FREEBSD)} // issue #40246
+ if AReadOnly <> QTextEdit_isReadOnly(QTextEditH(Widget)) then
+ {$ENDIF}
+ QTextEdit_setReadOnly(QTextEditH(Widget), AReadOnly);
diff --git a/editors/lazarus-qt5/Makefile b/editors/lazarus-qt5/Makefile
index bb76ab95d975..ec166591334a 100644
--- a/editors/lazarus-qt5/Makefile
+++ b/editors/lazarus-qt5/Makefile
@@ -1,4 +1,4 @@
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX?= -qt5
diff --git a/editors/lazarus-qt6/Makefile b/editors/lazarus-qt6/Makefile
index 73dcdd87498c..e9f76dc35150 100644
--- a/editors/lazarus-qt6/Makefile
+++ b/editors/lazarus-qt6/Makefile
@@ -1,4 +1,4 @@
-PORTREVISION= 1
+PORTREVISION= 2
PKGNAMESUFFIX?= -qt6
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 1572e5ad4273..b5c36f008e52 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -1,7 +1,7 @@
PORTNAME= lazarus
DISTVERSION= 3.2.0
PKGNAMESUFFIX?= -gtk2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= editors devel
DIST_SUBDIR= freepascal
diff --git a/editors/lazarus/files/patch-lcl_interfaces_qt5_qtwidgets.pas b/editors/lazarus/files/patch-lcl_interfaces_qt5_qtwidgets.pas
new file mode 100644
index 000000000000..584702005287
--- /dev/null
+++ b/editors/lazarus/files/patch-lcl_interfaces_qt5_qtwidgets.pas
@@ -0,0 +1,11 @@
+--- lcl/interfaces/qt5/qtwidgets.pas.orig 2024-05-04 04:39:55 UTC
++++ lcl/interfaces/qt5/qtwidgets.pas
+@@ -10213,7 +10213,7 @@ begin
+
+ procedure TQtTextEdit.setReadOnly(const AReadOnly: Boolean);
+ begin
+- {$IFDEF DARWIN} // issue #40246
++ {$IF DEFINED(DARWIN) OR DEFINED(FREEBSD)} // issue #40246
+ if AReadOnly <> QTextEdit_isReadOnly(QTextEditH(Widget)) then
+ {$ENDIF}
+ QTextEdit_setReadOnly(QTextEditH(Widget), AReadOnly);
diff --git a/editors/lazarus/files/patch-lcl_interfaces_qt6_qtwidgets.pas b/editors/lazarus/files/patch-lcl_interfaces_qt6_qtwidgets.pas
new file mode 100644
index 000000000000..462601cd0328
--- /dev/null
+++ b/editors/lazarus/files/patch-lcl_interfaces_qt6_qtwidgets.pas
@@ -0,0 +1,14 @@
+--- lcl/interfaces/qt6/qtwidgets.pas.orig 2024-05-04 05:06:13 UTC
++++ lcl/interfaces/qt6/qtwidgets.pas
+@@ -10243,7 +10243,10 @@ begin
+
+ procedure TQtTextEdit.setReadOnly(const AReadOnly: Boolean);
+ begin
+- QTextEdit_setReadOnly(QTextEditH(Widget), AReadOnly);
++ {$IF DEFINED(DARWIN) OR DEFINED(FREEBSD)} // issue #40246
++ if AReadOnly <> QTextEdit_isReadOnly(QTextEditH(Widget)) then
++ {$ENDIF}
++ QTextEdit_setReadOnly(QTextEditH(Widget), AReadOnly);
+ end;
+
+ procedure TQtTextEdit.setSelection(const AStart, ALength: Integer);