aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-16 07:47:47 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-16 07:47:47 +0000
commit2d33a4cf46400a329e99d21ec6e445ae7274618a (patch)
tree8099ec5dbc5fa9fd4bcfa7c84b84c4221949384b
parente4482bc1e25610f1148bac02da9b0490a1f5250c (diff)
downloadports-2d33a4cf46400a329e99d21ec6e445ae7274618a.tar.gz
ports-2d33a4cf46400a329e99d21ec6e445ae7274618a.zip
Notes
-rw-r--r--graphics/xfractint/Makefile30
-rw-r--r--graphics/xfractint/distinfo4
-rw-r--r--graphics/xfractint/files/patch-common__mpmath_c.c11
-rw-r--r--graphics/xfractint/files/patch-common__soi.c9
-rw-r--r--graphics/xfractint/files/patch-unix__fpu087.c22
-rw-r--r--graphics/xfractint/files/pre-1000034-libm-patch44
-rw-r--r--graphics/xfractint/pkg-descr4
-rw-r--r--graphics/xfractint/pkg-plist7
8 files changed, 68 insertions, 63 deletions
diff --git a/graphics/xfractint/Makefile b/graphics/xfractint/Makefile
index 10241762ad52..b06270efd72e 100644
--- a/graphics/xfractint/Makefile
+++ b/graphics/xfractint/Makefile
@@ -2,32 +2,36 @@
# $FreeBSD$
PORTNAME= xfractint
-PORTVERSION= 20.04p12
-PORTREVISION= 1
+PORTVERSION= 20.04p14
CATEGORIES= graphics
-MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
+MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
http://twegner.dyndns.org/fractint/ftp/current/linux/
MAINTAINER= onemda@gmail.com
-COMMENT= The Unix port of fractint
-
-BROKEN= No public distfiles
+COMMENT= Unix port of FractInt
USES= gmake
USE_XORG= x11 xft
ALL_TARGET= ${PORTNAME}
-DESKTOP_ENTRIES+="Xfracint" "${COMMENT}" "" "${PORTNAME}" "" "false"
+DESKTOP_ENTRIES= "Xfracint" "${COMMENT}" "" "${PORTNAME}" "" "false"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000034
+EXTRA_PATCHES= ${FILESDIR}/pre-1000034-libm-patch
+.endif
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/xfractint ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- @${INSTALL_MAN} ${WRKSRC}/unix/xfractint.man ${STAGEDIR}${PREFIX}/man/man1/${MAN1}
+ ${INSTALL_PROGRAM} ${WRKSRC}/xfractint ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/unix/xfractint.man \
+ ${STAGEDIR}${MANPREFIX}/man/man1/xfractint.1
@${MKDIR} ${STAGEDIR}${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/fractint.hlp ${STAGEDIR}${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/sstools.ini ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/fractint.hlp ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/sstools.ini ${STAGEDIR}${DATADIR}
.for dir in formulas ifs lsystem maps pars
- @cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/xfractint/distinfo b/graphics/xfractint/distinfo
index 0b7694fc5ccd..532787392469 100644
--- a/graphics/xfractint/distinfo
+++ b/graphics/xfractint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfractint-20.04p12.tar.gz) = e81affa9d3b3826f14502cedf1fc4a4dd41bcfa71ba32f8e4224748c5b9c69e0
-SIZE (xfractint-20.04p12.tar.gz) = 1335480
+SHA256 (xfractint-20.04p14.tar.gz) = 0e2856e596a44f5a8dbd4cb389683ead484776cdba4cce75c6c2a09f86c9b849
+SIZE (xfractint-20.04p14.tar.gz) = 1336285
diff --git a/graphics/xfractint/files/patch-common__mpmath_c.c b/graphics/xfractint/files/patch-common__mpmath_c.c
deleted file mode 100644
index a81264466a2e..000000000000
--- a/graphics/xfractint/files/patch-common__mpmath_c.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- common/mpmath_c.c.orig 2012-03-10 17:28:37.000000000 -0500
-+++ common/mpmath_c.c 2012-03-10 17:34:32.000000000 -0500
-@@ -220,7 +220,7 @@
- if(t.x < -690)
- e2x = 0.0;
- else
-- e2x = expl(t.x);
-+ e2x = exp(t.x);
- #ifdef XFRACT
- if (isnan(e2x) || isinf(e2x))
- e2x = 1.0;
diff --git a/graphics/xfractint/files/patch-common__soi.c b/graphics/xfractint/files/patch-common__soi.c
index 9f35b9f8ff35..2c3e5f00fddb 100644
--- a/graphics/xfractint/files/patch-common__soi.c
+++ b/graphics/xfractint/files/patch-common__soi.c
@@ -9,12 +9,3 @@
#include <malloc.h>
#endif
#include "port.h"
-@@ -25,7 +25,7 @@
- #define FABS(x) fabsl(x)
- /* the following needs to be changed back to frexpl once the portability
- issue has been addressed JCO */
--#ifndef XFRACT
-+#ifndef __FreeBSD__
- #define FREXP(x,y) frexpl(x,y)
- #else
- #define FREXP(x,y) frexp(x,y)
diff --git a/graphics/xfractint/files/patch-unix__fpu087.c b/graphics/xfractint/files/patch-unix__fpu087.c
deleted file mode 100644
index 28023b9df7ae..000000000000
--- a/graphics/xfractint/files/patch-unix__fpu087.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- unix/fpu087.c.orig 2012-03-10 17:28:49.000000000 -0500
-+++ unix/fpu087.c 2012-03-10 17:36:40.000000000 -0500
-@@ -86,8 +86,8 @@
- *Sinh = 1.0;
- *Cosh = 1.0;
- } else {
-- *Sinh = (double)sinhl(*Angle);
-- *Cosh = (double)coshl(*Angle);
-+ *Sinh = (double)sinh(*Angle);
-+ *Cosh = (double)cosh(*Angle);
- }
- if (isnan(*Sinh) || isinf(*Sinh))
- *Sinh = 1.0;
-@@ -119,7 +119,7 @@
- {
- LDBL pwr,y;
- y = x->y;
-- pwr = expl(x->x);
-+ pwr = exp(x->x);
- if (isnan(pwr) || isinf(pwr))
- pwr = 1.0;
- z->x = (double)(pwr*cosl(y));
diff --git a/graphics/xfractint/files/pre-1000034-libm-patch b/graphics/xfractint/files/pre-1000034-libm-patch
new file mode 100644
index 000000000000..5d2ad985bb3c
--- /dev/null
+++ b/graphics/xfractint/files/pre-1000034-libm-patch
@@ -0,0 +1,44 @@
+--- common/mpmath_c.c.orig 2012-03-10 17:28:37.000000000 -0500
++++ common/mpmath_c.c 2012-03-10 17:34:32.000000000 -0500
+@@ -220,7 +220,7 @@
+ if(t.x < -690)
+ e2x = 0.0;
+ else
+- e2x = expl(t.x);
++ e2x = exp(t.x);
+ #ifdef XFRACT
+ if (isnan(e2x) || isinf(e2x))
+ e2x = 1.0;
+--- common/soi.c.orig 2011-05-07 15:36:36.000000000 -0500
++++ common/soi.c 2012-03-10 17:08:47.000000000 -0500
+@@ -25,7 +25,7 @@
+ #define FABS(x) fabsl(x)
+ /* the following needs to be changed back to frexpl once the portability
+ issue has been addressed JCO */
+-#ifndef XFRACT
++#ifndef __FreeBSD__
+ #define FREXP(x,y) frexpl(x,y)
+ #else
+ #define FREXP(x,y) frexp(x,y)
+--- unix/fpu087.c.orig 2012-03-10 17:28:49.000000000 -0500
++++ unix/fpu087.c 2012-03-10 17:36:40.000000000 -0500
+@@ -86,8 +86,8 @@
+ *Sinh = 1.0;
+ *Cosh = 1.0;
+ } else {
+- *Sinh = (LDBL)sinhl(*Angle);
+- *Cosh = (LDBL)coshl(*Angle);
++ *Sinh = (LDBL)sinh(*Angle);
++ *Cosh = (LDBL)cosh(*Angle);
+ }
+ if (isnan(*Sinh) || isinf(*Sinh))
+ *Sinh = 1.0;
+@@ -119,7 +119,7 @@
+ {
+ LDBL pwr,y;
+ y = x->y;
+- pwr = expl(x->x);
++ pwr = exp(x->x);
+ if (isnan(pwr) || isinf(pwr))
+ pwr = 1.0;
+ z->x = (double)(pwr*cosl(y));
diff --git a/graphics/xfractint/pkg-descr b/graphics/xfractint/pkg-descr
index 482a0f699dac..0760fa576d5d 100644
--- a/graphics/xfractint/pkg-descr
+++ b/graphics/xfractint/pkg-descr
@@ -1,6 +1,4 @@
-Xfractint - The Unix port of fractint.
-
-Fractint is an IBM PC program to generate fractals, and was written by
+FractInt is an IBM PC program to generate fractals, and was written by
the Stone Soup Group.
The Unix port was done by Ken Shirriff and modified by Scott D. Boyd.
diff --git a/graphics/xfractint/pkg-plist b/graphics/xfractint/pkg-plist
index e4aa2496c1bf..40e9ab655385 100644
--- a/graphics/xfractint/pkg-plist
+++ b/graphics/xfractint/pkg-plist
@@ -1,7 +1,5 @@
bin/xfractint
-man/man1/xfractint.man.gz
-%%DATADIR%%/fractint.hlp
-%%DATADIR%%/sstools.ini
+man/man1/xfractint.1.gz
%%DATADIR%%/formulas/fract001.frm
%%DATADIR%%/formulas/fract002.frm
%%DATADIR%%/formulas/fract003.frm
@@ -13,6 +11,7 @@ man/man1/xfractint.man.gz
%%DATADIR%%/formulas/julitile.frm
%%DATADIR%%/formulas/new_if.frm
%%DATADIR%%/formulas/newton.frm
+%%DATADIR%%/fractint.hlp
%%DATADIR%%/ifs/fract205.ifs
%%DATADIR%%/ifs/fractint.ifs
%%DATADIR%%/lsystem/fract205.l
@@ -37,6 +36,7 @@ man/man1/xfractint.man.gz
%%DATADIR%%/maps/green.map
%%DATADIR%%/maps/grey.map
%%DATADIR%%/maps/grid.map
+%%DATADIR%%/maps/headach2.map
%%DATADIR%%/maps/headache.map
%%DATADIR%%/maps/landscap.map
%%DATADIR%%/maps/lyapunov.map
@@ -58,3 +58,4 @@ man/man1/xfractint.man.gz
%%DATADIR%%/pars/newphoen.par
%%DATADIR%%/pars/orbits.par
%%DATADIR%%/pars/phoenix.par
+%%DATADIR%%/sstools.ini