aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-04-13 11:56:12 +0000
committerRene Ladan <rene@FreeBSD.org>2014-04-13 11:56:12 +0000
commit2d38196849566d75dc35d462ab4c2e66fbab22dd (patch)
tree999300525230298129aeb87f7ae23772683eba3d
parent5ddb7da7f2ef9881b178779d17a50d6244d10957 (diff)
- Remove optional dependency on expired japanese/chasen
- Use modern LIB_DEPENDS - Use option helpers (aspell detection is broken upstream) - Stage support (untested) - Bump PORTREVISION - BROKEN: does not link (10.0 amd64): cc -DHAVE_PTHREAD -D_REENTRANT -O2 -pipe -fno-strict-aliasing -I/usr/local/include -DDPS_CONF_DIR=\"/prefix/dpsearch-4.53_2/etc/dpsearch\" -DDPS_VAR_DIR=\"/var/dpsearch\" -DDPS_SHARE_DIR=\"/prefix/dpsearch-4.53_2/share/dpsearch\" -o .libs/search.cgi search_cgi-search.o ./.libs/libdpsearch.so -L/usr/local/lib ./.libs/libdpcharset.so -lpthread -lm -lz -Wl,--rpath -Wl,/prefix/dpsearch-4.53_2/lib cc -DHAVE_PTHREAD -D_REENTRANT -O2 -pipe -fno-strict-aliasing -I/usr/local/include -DDPS_CONF_DIR=\"/prefix/dpsearch-4.53_2/etc/dpsearch\" -DDPS_VAR_DIR=\"/var/dpsearch\" -DDPS_SHARE_DIR=\"/prefix/dpsearch-4.53_2/share/dpsearch\" -o .libs/storedoc.cgi storedoc_cgi-storedoc.o ./.libs/libdpsearch.so -L/usr/local/lib ./.libs/libdpcharset.so -lpthread -lm -lz -Wl,--rpath -Wl,/prefix/dpsearch-4.53_2/lib ./.libs/libdpcharset.so: undefined reference to `dps_minimove_backward' ./.libs/libdpsearch.so: undefined reference to `DpsSQLLimit8' ./.libs/libdpsearch.so: undefined reference to `DpsSQLValue' ./.libs/libdpsearch.so: undefined reference to `DpsSQLResInit' ./.libs/libdpsearch.so: undefined reference to `DpsSQLLimit4' ./.libs/libdpsearch.so: undefined reference to `DpsSQLFree' ./.libs/libdpcharset.so: undefined reference to `dps_minimove_forward' ./.libs/libdpsearch.so: undefined reference to `DpsSQLNumRows' ./.libs/libdpsearch.so: undefined reference to `_DpsSQLQuery' cc: error: linker command failed with exit code 1 (use -v to see invocation)
Notes
Notes: svn path=/head/; revision=351205
-rw-r--r--www/dpsearch/Makefile90
1 files changed, 28 insertions, 62 deletions
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index e4d1fc20eca6..ccdf6de74908 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dpsearch
PORTVERSION= 4.53
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://dataparksearch.googlecode.com/files/ \
http://www.dataparksearch.org/
@@ -11,6 +11,8 @@ MASTER_SITES= http://dataparksearch.googlecode.com/files/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source search engine for Internet and Intranet sites
+BROKEN= Does not link
+
USE_LDCONFIG= yes
USES= gmake tar:bzip2
GNU_CONFIGURE= yes
@@ -23,7 +25,7 @@ CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc/dpsearch \
SUB_FILES= pkg-message
-OPTIONS_DEFINE= THREADS SSL CHINESE JAPANESE MECAB CHASEN APACHE IDN ASPELL \
+OPTIONS_DEFINE= THREADS SSL CHINESE JAPANESE MECAB APACHE IDN ASPELL \
EXTRACT DOCS
OPTIONS_DEFAULT= THREADS SSL PGSQL
OPTIONS_SINGLE= DB
@@ -31,84 +33,50 @@ OPTIONS_SINGLE_DB= PGSQL MYSQL SQLITE
CHINESE_DESC= Enable chinese charsets
JAPANESE_DESC= Enable japanese charsets
MECAB_DESC= Enable MeCab japanese analyzer
-CHASEN_DESC= Enable ChaSen japanese analyzer
EXTRACT_DESC= Enable libextractor support
-NO_STAGE= yes
.include <bsd.port.options.mk>
CONFIGURE_ENV+= PORTNAME="${PORTNAME}"
-.if ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+=--enable-pthreads
-CONFIGURE_ENV+= LIBS="-pthread"
-.else
-CONFIGURE_ARGS+=--disable-pthreads
-.endif
+THREADS_CONFIGURE_ENABLE= pthreads
+THREADS_CONFIGURE_ENV= LIBS="-pthread"
-.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
-.else
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+#ASPELL_CONFIGURE_WITH= aspell
+.if ! ${PORT_OPTIONS:MASPELL}
CONFIGURE_ARGS+=--without-aspell
.endif
-.if ${PORT_OPTIONS:MEXTRACT}
-LIB_DEPENDS+= extractor.3:${PORTSDIR}/textproc/libextractor
-.endif
+EXTRACT_LIB_DEPENDS= libextractor.so:${PORTSDIR}/textproc/libextractor
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
+SSL_CONFIGURE_WITH= openssl=${OPENSSLBASE}
-.if ${PORT_OPTIONS:MCHARSETS}
-CONFIGURE_ARGS+=--with-extra-charsets=all
-.endif
+CHARSETS_CONFIGURE_WITH= extra-charsets=all
-.if ${PORT_OPTIONS:MCHINESE}
-CONFIGURE_ARGS+=--with-extra-charsets=chinese
-.endif
+CHINESE_CONFIGURE_WITH= extra-charsets=chinese
-.if ${PORT_OPTIONS:MJAPANESE}
-CONFIGURE_ARGS+=--with-extra-charsets=japanese
-.endif
+JAPANESE_CONFIGURE_WITH= extra-charsets=japanese
-.if ${PORT_OPTIONS:MMECAB}
-LIB_DEPENDS+= mecab.1:${PORTSDIR}/japanese/mecab
-CONFIGURE_ARGS+=--enable-mecab
-.endif
+MECAB_LIB_DEPENDS= libmecab.so:${PORTSDIR}/japanese/mecab
+MECAB_CONFIGURE_ENABLE= mecab
-.if ${PORT_OPTIONS:MCHASEN}
-LIB_DEPENDS+= chasen.2:${PORTSDIR}/japanese/chasen
-CONFIGURE_ARGS+=--enable-chasen
-.endif
+IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
+IDN_CONFIGURE_ENABLE= idn
-.if ${PORT_OPTIONS:MIDN}
-LIB_DEPENDS+= idn.17:${PORTSDIR}/dns/libidn
-CONFIGURE_ARGS+=--enable-idn
-.endif
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE= 22+
-PLIST_SUB+= APACHE=""
-CONFIGURE_ARGS+=--enable-apache-module
-.else
-PLIST_SUB+= APACHE="@comment "
-.endif
+APACHE_USE= APACHE=22+
+APACHE_CONFIGURE_ENABLE= apache-module
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
-.endif
+PGSQL_USE= PGSQL=yes
+PGSQL_CONFIGURE_WITH= pgsql=${LOCALBASE}
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
-.endif
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_WITH= mysql=${LOCALBASE}
-.if ${PORT_OPTIONS:MSQLITE}
-LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
-CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
-.endif
+SQLITE_LIB_DEPENDS= libsqlite.so:${PORTSDIR}/databases/sqlite2
+SQLITE_CONFIGURE_WITH= sqlite=${LOCALBASE}
post-extract:
.if ! ${PORT_OPTIONS:MDOCS}
@@ -121,13 +89,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
pre-install:
- @${INSTALL} -d ${DATADIR}
+ @${INSTALL} -d ${STAGEDIR}${DATADIR}
post-install:
- @${CHMOD} 700 /var/dpsearch/cache
@${ECHO_CMD} '@exec ${CHMOD} 700 /var/dpsearch/cache' >> ${TMPPLIST}
@${CHOWN} -R ${WWWOWN}:${WWWGRP} /var/dpsearch/
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} /var/dpsearch/' >> ${TMPPLIST}
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>