aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-26 00:05:56 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-26 00:05:56 +0000
commit2d8f29c336be2679d17a44fed3a9a79b36351624 (patch)
treeb06fccc24bfbe595d6f425dab26991ac8375f69b
parente739b5952a47b52586e69600e67c31f0771490cb (diff)
downloadports-2d8f29c336be2679d17a44fed3a9a79b36351624.tar.gz
ports-2d8f29c336be2679d17a44fed3a9a79b36351624.zip
[new port] math/p5-Math-Derivative
PR: ports/74381 Submitted by: Fernan Aguero <fernan(at)iib.unsam.edu.ar>
Notes
Notes: svn path=/head/; revision=122444
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Derivative/Makefile23
-rw-r--r--math/p5-Math-Derivative/distinfo2
-rw-r--r--math/p5-Math-Derivative/pkg-descr7
-rw-r--r--math/p5-Math-Derivative/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 99fd446e3b84..6c88f362cd94 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -141,6 +141,7 @@
SUBDIR += p5-Math-BigIntFast
SUBDIR += p5-Math-Calc-Units
SUBDIR += p5-Math-Currency
+ SUBDIR += p5-Math-Derivative
SUBDIR += p5-Math-Expr
SUBDIR += p5-Math-FFT
SUBDIR += p5-Math-FixedPrecision
diff --git a/math/p5-Math-Derivative/Makefile b/math/p5-Math-Derivative/Makefile
new file mode 100644
index 000000000000..98eb7186501b
--- /dev/null
+++ b/math/p5-Math-Derivative/Makefile
@@ -0,0 +1,23 @@
+# vim:ts=8
+# New ports collection makefile for: p5-Math-Derivative
+# Date created: 25 November 2004
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Derivative
+PORTVERSION= 0.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Numeric 1st and 2nd order differentiation
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Derivative.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Derivative/distinfo b/math/p5-Math-Derivative/distinfo
new file mode 100644
index 000000000000..b648a71bf333
--- /dev/null
+++ b/math/p5-Math-Derivative/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-Derivative-0.01.tar.gz) = a359b1b4b545c03f4147594fc64420a2
+SIZE (Math-Derivative-0.01.tar.gz) = 1935
diff --git a/math/p5-Math-Derivative/pkg-descr b/math/p5-Math-Derivative/pkg-descr
new file mode 100644
index 000000000000..36a1e4b26110
--- /dev/null
+++ b/math/p5-Math-Derivative/pkg-descr
@@ -0,0 +1,7 @@
+This Perl package exports functions for performing numerical first
+(Derivative1) and second Derivative2) order differentiation on vectors
+of data. They both take references to two arrays containing the x and y
+ordinates of the data and return an array of the 1st or 2nd derivative
+at the given x ordinates. Derivative2 may optionally be given values to
+use for the first dervivative at the start and end points of the data -
+otherwiswe 'natural' values are used.
diff --git a/math/p5-Math-Derivative/pkg-plist b/math/p5-Math-Derivative/pkg-plist
new file mode 100644
index 000000000000..51810fba49cd
--- /dev/null
+++ b/math/p5-Math-Derivative/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Derivative/.packlist
+%%SITE_PERL%%/Math/Derivative.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Derivative
+@dirrm %%SITE_PERL%%/Math
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true