aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-19 20:10:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-19 20:10:22 +0000
commit2d9c3e114cec50448a04e4e2223353b8fd9c7590 (patch)
treeedbdeeb17d13aba263ecd6765bd522f3efd65e1e
parent6ddf7277bcebe16d81ca1d39c5cf09760896170d (diff)
downloadports-2d9c3e114cec50448a04e4e2223353b8fd9c7590.tar.gz
ports-2d9c3e114cec50448a04e4e2223353b8fd9c7590.zip
Notes
-rw-r--r--graphics/py-pyproj/Makefile22
-rw-r--r--graphics/py-pyproj/distinfo6
-rw-r--r--graphics/py-pyproj/pkg-plist57
3 files changed, 66 insertions, 19 deletions
diff --git a/graphics/py-pyproj/Makefile b/graphics/py-pyproj/Makefile
index 7f0b720ab379..50b242203d9e 100644
--- a/graphics/py-pyproj/Makefile
+++ b/graphics/py-pyproj/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pyproj
-PORTVERSION= 2.6.1
-PORTREVISION= 2
+PORTVERSION= 3.0.0
DISTVERSIONSUFFIX= .post1
CATEGORIES= graphics python geography
MASTER_SITES= CHEESESHOP
@@ -15,35 +14,26 @@ COMMENT= Cython wrapper to provide python interfaces to PROJ.4 functions
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= proj>=6.2.0:graphics/proj
+BUILD_DEPENDS= proj>=7.2.0,1:graphics/proj
LIB_DEPENDS= libproj.so:graphics/proj
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist concurrent cython distutils
MAKE_ENV= PROJ_DIR=${LOCALBASE}
-PORTDOCS= *
-PORTDOCS1= README.md docs/*
-PORTEXAMPLES= sample.out \
- test_awips221.py test_datadir.py \
- test_datum.py test_datum_shift.py test_doctest_wrapper.py \
- test_exception_logging.py test_geod.py test_pickle.py \
- test_transform.py test_transformer.py
-
OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/_proj.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pyproj/*.so
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC}/docs/ && \
- ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR} "! -name .buildinfo" )
+ cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/test/,} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/sample.out ${WRKSRC}/test/test_*.py ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/graphics/py-pyproj/distinfo b/graphics/py-pyproj/distinfo
index bb79cd3f6d6f..60ccbfed682c 100644
--- a/graphics/py-pyproj/distinfo
+++ b/graphics/py-pyproj/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1596961504
-SHA256 (pyproj-2.6.1.post1.tar.gz) = 4f5b02b4abbd41610397c635b275a8ee4a2b5bc72a75572b98ac6ae7befa471e
-SIZE (pyproj-2.6.1.post1.tar.gz) = 545482
+TIMESTAMP = 1608366160
+SHA256 (pyproj-3.0.0.post1.tar.gz) = a49581629cadd29e61fc061d153a4d62ff28b4063c71fe8ca881eeb98cd22017
+SIZE (pyproj-3.0.0.post1.tar.gz) = 663801
diff --git a/graphics/py-pyproj/pkg-plist b/graphics/py-pyproj/pkg-plist
new file mode 100644
index 000000000000..18d250d9a0e2
--- /dev/null
+++ b/graphics/py-pyproj/pkg-plist
@@ -0,0 +1,57 @@
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/advanced_examples.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/aoi.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/crs/coordinate_operation.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/crs/coordinate_system.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/crs/crs.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/crs/datum.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/crs/enums.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/crs/index.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/database.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/datadir.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/enums.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/exceptions.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/geod.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/global_context.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/index.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/list.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/network.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/proj.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/show_versions.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/sync.rst
+%%PORTDOCS%%%%DOCSDIR%%/api/transformer.rst
+%%PORTDOCS%%%%DOCSDIR%%/build_crs_cf.rst
+%%PORTDOCS%%%%DOCSDIR%%/build_crs.rst
+%%PORTDOCS%%%%DOCSDIR%%/cli.rst
+%%PORTDOCS%%%%DOCSDIR%%/conf.py
+%%PORTDOCS%%%%DOCSDIR%%/crs_compatibility.rst
+%%PORTDOCS%%%%DOCSDIR%%/examples.rst
+%%PORTDOCS%%%%DOCSDIR%%/gotchas.rst
+%%PORTDOCS%%%%DOCSDIR%%/history.rst
+%%PORTDOCS%%%%DOCSDIR%%/index.rst
+%%PORTDOCS%%%%DOCSDIR%%/installation.rst
+%%PORTDOCS%%%%DOCSDIR%%/make.bat
+%%PORTDOCS%%%%DOCSDIR%%/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/optimize_transformations.rst
+%%PORTDOCS%%%%DOCSDIR%%/past_versions.rst
+%%PORTDOCS%%%%DOCSDIR%%/transformation_grids.rst
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_aoi.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_awips221.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_cli.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_database.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_datadir.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_datum_shift.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_datum.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_doctest_wrapper.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_exception_logging.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_geod.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_list.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_network.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_pickle.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_proj.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_show_versions.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_sync.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_transform.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_transformer.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_utils.py