aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-10 19:36:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-10 19:36:07 +0000
commit2ed06dd321ec98201a05242f26d9a58541f51883 (patch)
tree8dfa695b7e9e0cbb169cfc99f23505a8023c9907
parent34f2a44a04797487c8c52912ea9fea2d9555c47b (diff)
downloadports-2ed06dd321ec98201a05242f26d9a58541f51883.tar.gz
ports-2ed06dd321ec98201a05242f26d9a58541f51883.zip
Notes
-rw-r--r--science/coordgenlibs/Makefile15
-rw-r--r--science/coordgenlibs/distinfo6
-rw-r--r--science/coordgenlibs/pkg-plist1
3 files changed, 17 insertions, 5 deletions
diff --git a/science/coordgenlibs/Makefile b/science/coordgenlibs/Makefile
index e9dae5f2cf35..a749f6d06478 100644
--- a/science/coordgenlibs/Makefile
+++ b/science/coordgenlibs/Makefile
@@ -2,7 +2,8 @@
PORTNAME= coordgenlibs
DISTVERSIONPREFIX= v
-DISTVERSION= 1.4.0
+DISTVERSION= 1.4.0-6
+DISTVERSIONSUFFIX= -g95e2367
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -19,6 +20,16 @@ USE_GITHUB= yes
GH_ACCOUNT= schrodinger
USE_LDCONFIG= yes
-CMAKE_ARGS= -Dmaeparser_DIR=${LOCALBASE}/lib/cmake
+DATADIR= ${LOCALBASE}/share/coordgen
+
+CMAKE_ON= COORDGEN_USE_MAEPARSER
+CMAKE_OFF= COORDGEN_BUILD_TESTS COORDGEN_BUILD_EXAMPLE
+
+post-patch: # see https://github.com/schrodinger/coordgenlibs/issues/64
+ @${REINPLACE_CMD} 's|return getTempFileProjDir() + suffix;|return "${DATADIR}/templates.mae";|' ${WRKSRC}/sketcherMinimizer.cpp
+
+post-install: # see https://github.com/schrodinger/coordgenlibs/issues/64
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/templates.mae ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/science/coordgenlibs/distinfo b/science/coordgenlibs/distinfo
index b3ea782aea71..60d94a698b52 100644
--- a/science/coordgenlibs/distinfo
+++ b/science/coordgenlibs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1584429626
-SHA256 (schrodinger-coordgenlibs-v1.4.0_GH0.tar.gz) = 2c739be72d04958c158e16c8402ad0dd2171859da6486096ba1b691c18d286e7
-SIZE (schrodinger-coordgenlibs-v1.4.0_GH0.tar.gz) = 154413
+TIMESTAMP = 1589134573
+SHA256 (schrodinger-coordgenlibs-v1.4.0-6-g95e2367_GH0.tar.gz) = 8ca75cabe12db8d15c9333c15a99feee39b32eef96e3adc9abf17c9947671ad9
+SIZE (schrodinger-coordgenlibs-v1.4.0-6-g95e2367_GH0.tar.gz) = 155048
diff --git a/science/coordgenlibs/pkg-plist b/science/coordgenlibs/pkg-plist
index a7cc634a311e..eeca2f51cfbc 100644
--- a/science/coordgenlibs/pkg-plist
+++ b/science/coordgenlibs/pkg-plist
@@ -23,3 +23,4 @@ lib/cmake/coordgen-config.cmake
lib/libcoordgen.so
lib/libcoordgen.so.1
lib/libcoordgen.so.1.4.0
+%%DATADIR%%/templates.mae