aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-05-04 11:12:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-05-04 11:12:24 +0000
commit2ee431d8aca6e97417c5d14eaf50e7da5d2d249d (patch)
tree5f40043624ad42bb9fa06292c2d37a4aa4be902d
parent748d7f291a420935859239bc4d1b326404a67c38 (diff)
downloadports-2ee431d8aca6e97417c5d14eaf50e7da5d2d249d.tar.gz
ports-2ee431d8aca6e97417c5d14eaf50e7da5d2d249d.zip
Notes
-rw-r--r--emulators/vice/Makefile1
-rw-r--r--emulators/vice/files/patch-src__rs232drv_rs232.h11
-rw-r--r--graphics/swftools/Makefile1
3 files changed, 13 insertions, 0 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 377e69cd865a..91e95b50b9e9 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -34,6 +34,7 @@ USE_XORG= xpm ice sm xext xv xt x11 xmu xxf86vm
USE_XORG+= xrender xinerama xi xrandr xcursor xcomposite xdamage xfixes
HAS_CONFIGURE= yes
MAKE_ENV+= MAKEINFOFLAGS="--no-split"
+CFLAGS+= -fcommon
CONFIGURE_ARGS+= --enable-ipv6 \
--enable-external-ffmpeg \
--enable-x64 \
diff --git a/emulators/vice/files/patch-src__rs232drv_rs232.h b/emulators/vice/files/patch-src__rs232drv_rs232.h
new file mode 100644
index 000000000000..7beeff33d6b6
--- /dev/null
+++ b/emulators/vice/files/patch-src__rs232drv_rs232.h
@@ -0,0 +1,11 @@
+--- src/rs232drv/rs232.h.orig 2019-11-21 00:03:29 UTC
++++ src/rs232drv/rs232.h
+@@ -78,7 +78,7 @@ extern int rs232_cmdline_options_init(void);
+ #define RS232_NUM_DEVICES 4
+
+ extern char *rs232_devfile[RS232_NUM_DEVICES];
+-int rs232_useip232[RS232_NUM_DEVICES];
++extern int rs232_useip232[RS232_NUM_DEVICES];
+
+ /* the "ip232" protocol used by tcpser
+
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index b33f88c4b6ae..4e2d29691901 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -29,6 +29,7 @@ LMAN1= as3compile.1 font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 \
swfextract.1 swfrender.1 swfstrings.1 wav2swf.1
CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -fcommon
LDFLAGS+= -L${LOCALBASE}/lib
BINFILES= as3compile font2swf gif2swf jpeg2swf pdf2swf png2swf \