aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-07-02 10:43:19 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-07-02 10:43:19 +0000
commit304e31afd7891381d4415066a2c5c6896fbda4f2 (patch)
tree7b624f21a0153727b172feacc131b1b2618c8914
parente2b37e808bc4cbdd0619f9b6f55ff968a7be9600 (diff)
downloadports-304e31afd7891381d4415066a2c5c6896fbda4f2.tar.gz
ports-304e31afd7891381d4415066a2c5c6896fbda4f2.zip
Notes
-rw-r--r--editors/openoffice-1.1-devel/Makefile54
-rw-r--r--editors/openoffice-1.1-devel/distinfo6
-rw-r--r--editors/openoffice-1.1-devel/files/moz-patch5
-rw-r--r--editors/openoffice-1.1-devel/files/patch-odfilter+prj+build.lst13
-rw-r--r--editors/openoffice-1.1-devel/files/patch-sndfile+makefile.mk21
-rw-r--r--editors/openoffice-1.1-devel/files/patch-vcl+util+makefile.mk22
-rw-r--r--editors/openoffice.org-1.1-devel/Makefile54
-rw-r--r--editors/openoffice.org-1.1-devel/distinfo6
-rw-r--r--editors/openoffice.org-1.1-devel/files/moz-patch5
-rw-r--r--editors/openoffice.org-1.1-devel/files/patch-odfilter+prj+build.lst13
-rw-r--r--editors/openoffice.org-1.1-devel/files/patch-sndfile+makefile.mk21
-rw-r--r--editors/openoffice.org-1.1-devel/files/patch-vcl+util+makefile.mk22
12 files changed, 100 insertions, 142 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 5f7da978b309..1f13428c13e4 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -22,19 +22,19 @@ DISTFILES+= OOo_${RELEASE_NR}m${MILESTONE}_source.tar.bz2 gpc231.tar.Z:gpc
EXTRACT_ONLY= OOo_${RELEASE_NR}m${MILESTONE}_source.tar.bz2
MAINTAINER= openoffice@FreeBSD.org
-COMMENT?= Integrated wordprocessor/dbase/spreadheet/drawing/chart/browser
+COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
NO_LATEST_LINK= yes
-USE_GNOME= gtk20
MOZILLA_PROJECT= cws_srx645_mozooo.20040203.tar.gz
MOZILLA_VERSION= 1.0
MOZILLA_SOURCE= mozilla-source-${MOZILLA_VERSION}.tar.gz
.if !defined(WITHOUT_MOZILLA)
DISTFILES+= ${MOZILLA_PROJECT}:moz ${MOZILLA_SOURCE}:mozsrc
-USE_GNOME+= orbit gtk12
+USE_GNOME= orbit
.endif
+USE_XLIB= yes
USE_PERL5= yes
USE_BISON= yes
USE_GMAKE= yes
@@ -43,7 +43,7 @@ USE_BZIP2= yes
.if !defined(WITHOUT_JAVA)
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.4
JAVA_BUILD= jdk
.endif
@@ -58,9 +58,7 @@ LANG_EXT?= 01
LANG_CONFIGURE_ARG?= ENUS
L10NHELP?= helpcontent_01_unix.tgz
-.if defined(L10NHELP)
DISTFILES+= ${L10NHELP}:help
-.endif
.if defined(ALL_LOCALIZED_LANGS)
DISTFILES+= helpcontent_01_unix.tgz:help helpcontent_07_unix.tgz:help3 \
helpcontent_31_unix.tgz:help helpcontent_33_unix.tgz:help \
@@ -84,8 +82,8 @@ L10NHELPS= helpcontent_01_unix.tgz helpcontent_07_unix.tgz \
CODELINE= 645
RELEASE_NR= 1.1.4
-MILESTONE= 55
-SNAPDATE= 20050615
+MILESTONE= 56
+SNAPDATE= 20050630
INSTALLATION_BASEDIR= OpenOffice.org${RELEASE_NR}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org1.1
@@ -112,23 +110,13 @@ CXX= g++32
.endif
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
- gcp:${PORTSDIR}/sysutils/coreutils \
- xmkmf:${X_IMAKE_PORT} \
- ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
-.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
-.endif
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
+ gcp:${PORTSDIR}/sysutils/coreutils
.if defined(WITHOUT_JAVA)
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
.else
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
.endif
GNU_CONFIGURE= yes
-#USE_AUTOCONF_VER= 259
WRKSRC= ${WRKDIR}
CONFIGURE_WRKSRC= ${WRKSRC}/config_office
ANT?= ${LOCALBASE}/bin/ant
@@ -137,10 +125,8 @@ UNZIP?= ${PREFIX}/bin/unzip
PKGMESSAGE= ${WRKDIR}/pkg-message
NUMOFPROCESSES?= 1
-.if !defined(DISPLAY)
DISPLAYHACK=localhost:1001
-.endif
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --enable-pasf
.include <${FILESDIR}/Makefile.knobs>
@@ -168,15 +154,10 @@ post-extract:
@cd ${WRKDIR} ; ${CAT} ${DISTDIR}/${DIST_SUBDIR}/gpc231.tar.Z | ${TAR} xfz -
@${CP} ${WRKDIR}/gpc231/gpc.c ${WRKSRC}/external/gpc/
@${CP} ${WRKDIR}/gpc231/gpc.h ${WRKSRC}/external/gpc/
-.if defined(L10NHELP)
- @${ECHO_MSG} "===> Extracting L10NHELP sub project"
@${MKDIR} ${WRKDIR}/L10NHELP
@cd ${WRKDIR}/L10NHELP ; \
${CAT} ${DISTDIR}/${DIST_SUBDIR}/${L10NHELP} | ${GZIP_CMD} -d | ${TAR} xf -
-.endif
.if defined(ALL_LOCALIZED_LANGS)
- @${ECHO_MSG} "===> Extracting All available L10NHELPs"
- @${MKDIR} ${WRKDIR}/L10NHELP
@cd ${WRKDIR}/L10NHELP ; \
for helpfile in ${L10NHELPS}; do \
${CAT} ${DISTDIR}/${DIST_SUBDIR}/$$helpfile | ${GZIP_CMD} -d | ${TAR} xf - ; \
@@ -198,29 +179,12 @@ do-build:
.if !defined(WITHOUT_MOZILLA)
@cd ${WRKSRC}/moz.runtime ; ${SETENV} "BUILD_MOZAB=TRUE" ${TCSH} -c 'source ../FreeBSDEnv.Set ; build.pl ; dmake zip' ; ${CP} unxfbsd.pro/zipped/FREEBSD*.zip ../moz/zipped
.endif
-.if defined(L10NHELP) || defined(ALL_LOCALIZED_LANGS)
@${MKDIR} ${WRKSRC}/solver/${CODELINE}/unxfbsd.pro/pck
@${CP} ${WRKDIR}/L10NHELP/*.zip ${WRKSRC}/solver/${CODELINE}/unxfbsd.pro/pck
-.endif
-.if !defined(DISPLAY)
- #
- # This is a UGLY hack to not have to specify a X-Display.
- #
- ${X11BASE}/bin/Xvfb :1001 -screen 0 800x600x24 > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
- @sleep 5
.if (${NUMOFPROCESSES}>1)
@cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c "source FreeBSDEnv.Set ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all"
.else
- cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c "source FreeBSDEnv.Set ; dmake"
-.endif
- @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
- @${RM} -f ${WRKDIR}/.Xvfb.pid
-.else
-.if (${NUMOFPROCESSES}>1)
- @cd ${WRKSRC} ; DISPLAY=${DISPLAY} ; ${TCSH} -c "source FreeBSDEnv.Set ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all"
-.else
- @cd ${WRKSRC} ; DISPLAY=${DISPLAY} ; ${TCSH} -c "source FreeBSDEnv.Set ; dmake"
-.endif
+ @cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c "source FreeBSDEnv.Set ; dmake"
.endif
do-install:
diff --git a/editors/openoffice-1.1-devel/distinfo b/editors/openoffice-1.1-devel/distinfo
index 77b2f17356ae..6751705d4067 100644
--- a/editors/openoffice-1.1-devel/distinfo
+++ b/editors/openoffice-1.1-devel/distinfo
@@ -1,5 +1,5 @@
-MD5 (openoffice.org1.1/OOo_1.1.4m55_source.tar.bz2) = b7a8a3dcaf7fa13f6470a6e988a6506f
-SIZE (openoffice.org1.1/OOo_1.1.4m55_source.tar.bz2) = 201811678
+MD5 (openoffice.org1.1/OOo_1.1.5m56_source.tar.bz2) = 5582117d68d96177d64c02f8493c61f4
+SIZE (openoffice.org1.1/OOo_1.1.5m56_source.tar.bz2) = 200183575
MD5 (openoffice.org1.1/gpc231.tar.Z) = fdb06fdb5a4670b172f9fb738b717be9
SIZE (openoffice.org1.1/gpc231.tar.Z) = 27917
MD5 (openoffice.org1.1/cws_srx645_mozooo.20040203.tar.gz) = 1239aad43c65d6808b6261ea9d60fb67
@@ -8,6 +8,8 @@ MD5 (openoffice.org1.1/mozilla-source-1.0.tar.gz) = 35a7524c2fbb773e23449179c5cb
SIZE (openoffice.org1.1/mozilla-source-1.0.tar.gz) = 39881558
MD5 (openoffice.org1.1/helpcontent_01_unix.tgz) = 7da2aff674c2c84aba8b21ac2ab16bb6
SIZE (openoffice.org1.1/helpcontent_01_unix.tgz) = 12052480
+MD5 (openoffice.org1.1/helpcontent_01_unix.tgz) = 7da2aff674c2c84aba8b21ac2ab16bb6
+SIZE (openoffice.org1.1/helpcontent_01_unix.tgz) = 12052480
MD5 (openoffice.org1.1/helpcontent_07_unix.tgz) = e3ab37cbf2407d909953f06467b27611
SIZE (openoffice.org1.1/helpcontent_07_unix.tgz) = 13820401
MD5 (openoffice.org1.1/helpcontent_31_unix.tgz) = c7e618e2d9b8bd25cae12954ef2548c9
diff --git a/editors/openoffice-1.1-devel/files/moz-patch b/editors/openoffice-1.1-devel/files/moz-patch
index 818bc154943d..5da4ae43ef25 100644
--- a/editors/openoffice-1.1-devel/files/moz-patch
+++ b/editors/openoffice-1.1-devel/files/moz-patch
@@ -23,7 +23,7 @@ this functionality is not used at all.
--- moz/mozilla-source-1.0.patch.org Tue Feb 10 19:44:34 2004
+++ moz/mozilla-source-1.0.patch Sat Mar 19 12:51:35 2005
-@@ -4471,14 +4471,15 @@
+@@ -4471,14 +4471,16 @@
return NS_OK;
}
@@ -31,13 +31,14 @@ this functionality is not used at all.
+--- misc/build/mozilla/.mozconfig Tue Jul 22 21:52:27 2003
+++ misc/build/mozilla/.mozconfig Mon Jul 28 15:07:20 2003
-@@ -0,0 +1,8 @@
-+@@ -0,0 +1,9 @@
++@@ -0,0 +1,10 @@
+ac_add_options --disable-tests
+ac_add_options --disable-xprint
+ac_add_options --without-system-zlib
+ac_add_options --enable-ldap
+ac_add_options --disable-debug
++ac_add_options --disable-freetype2
+++ac_add_options --enable-default-toolkit=xlib
+ac_add_options --enable-optimize
+ac_add_options --enable-crypto
+ac_add_options --enable-strip
diff --git a/editors/openoffice-1.1-devel/files/patch-odfilter+prj+build.lst b/editors/openoffice-1.1-devel/files/patch-odfilter+prj+build.lst
new file mode 100644
index 000000000000..9e02c5438c2b
--- /dev/null
+++ b/editors/openoffice-1.1-devel/files/patch-odfilter+prj+build.lst
@@ -0,0 +1,13 @@
+Index: odfilter/prj/build.lst
+===================================================================
+RCS file: /cvs/xml/odfilter/prj/build.lst,v
+retrieving revision 1.1
+diff -u -r1.1 build.lst
+--- odfilter/prj/build.lst 6 Jun 2005 12:36:50 -0000 1.1
++++ odfilter/prj/build.lst 1 Jul 2005 10:49:28 -0000
+@@ -1,4 +1,4 @@
+-xod odfilter : offapi goodies comphelper NULL
++xod odfilter : offapi goodies comphelper xmloff NULL
+ xod odfilter usr1 - all xod_mkout NULL
+ xod odfilter\prj get - all xod_prj NULL
+ xod odfilter\source nmake - all xod_transform NULL
diff --git a/editors/openoffice-1.1-devel/files/patch-sndfile+makefile.mk b/editors/openoffice-1.1-devel/files/patch-sndfile+makefile.mk
new file mode 100644
index 000000000000..3be2aa82cd99
--- /dev/null
+++ b/editors/openoffice-1.1-devel/files/patch-sndfile+makefile.mk
@@ -0,0 +1,21 @@
+Issutracker : #iXXXXX#
+CWS : N/A
+Author :
+Description :
+
+--- sndfile/makefile.mk Wed Jun 1 01:31:45 2005
++++ sndfile/makefile.mk Fri Jul 1 09:17:49 2005
+@@ -81,8 +81,12 @@
+ CONFIGURE_DIR=
+
+ CONFIGURE_ACTION=./configure --with-pic
+-.IF "$(COM)" == "GCC" && "$(OS)" != "MACOSX" && "$(OS)" != "FREEBSD"
++.IF "$(COM)" == "GCC"
++.IF "$(OS)" != "MACOSX"
++.IF "$(OS)" != "FREEBSD"
+ CONFIGURE_FLAGS=LDFLAGS=-Wl,-noinhibit-exec
++.ENDIF
++.ENDIF
+ .ENDIF
+
+ BUILD_DIR=$(CONFIGURE_DIR)
diff --git a/editors/openoffice-1.1-devel/files/patch-vcl+util+makefile.mk b/editors/openoffice-1.1-devel/files/patch-vcl+util+makefile.mk
deleted file mode 100644
index 42d341934719..000000000000
--- a/editors/openoffice-1.1-devel/files/patch-vcl+util+makefile.mk
+++ /dev/null
@@ -1,22 +0,0 @@
-Issutracker : #iXXXXX#
-CWS : N/A
-Author : NAKATA Maho <maho@openoffice.org> (JCA)
-Description : another ENABLE_PASF issue, somehow strange though,
-only FreeBSD 4.11-RELEASE needs this patch(?)
-
-Index: vcl/util/makefile.mk
-===================================================================
-RCS file: /cvs/gsl/vcl/util/makefile.mk,v
-retrieving revision 1.47.10.5
-diff -u -r1.47.10.5 makefile.mk
---- vcl/util/makefile.mk 29 Apr 2005 14:28:18 -0000 1.47.10.5
-+++ vcl/util/makefile.mk 13 May 2005 08:51:12 -0000
-@@ -310,7 +310,7 @@
- .ENDIF # "$(OS)"=="SOLARIS"
- .ENDIF # "$(GUIBASE)"=="unx"
-
--.IF "$(ENABLE_PASF)" != ""
-+.IF "$(ENABLE_PASF)" == "YES"
- .IF "$(OS)"=="MACOSX"
- SHL1STDLIBS += -framework CoreAudio -framework AudioToolbox
- .ENDIF
diff --git a/editors/openoffice.org-1.1-devel/Makefile b/editors/openoffice.org-1.1-devel/Makefile
index 5f7da978b309..1f13428c13e4 100644
--- a/editors/openoffice.org-1.1-devel/Makefile
+++ b/editors/openoffice.org-1.1-devel/Makefile
@@ -22,19 +22,19 @@ DISTFILES+= OOo_${RELEASE_NR}m${MILESTONE}_source.tar.bz2 gpc231.tar.Z:gpc
EXTRACT_ONLY= OOo_${RELEASE_NR}m${MILESTONE}_source.tar.bz2
MAINTAINER= openoffice@FreeBSD.org
-COMMENT?= Integrated wordprocessor/dbase/spreadheet/drawing/chart/browser
+COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
NO_LATEST_LINK= yes
-USE_GNOME= gtk20
MOZILLA_PROJECT= cws_srx645_mozooo.20040203.tar.gz
MOZILLA_VERSION= 1.0
MOZILLA_SOURCE= mozilla-source-${MOZILLA_VERSION}.tar.gz
.if !defined(WITHOUT_MOZILLA)
DISTFILES+= ${MOZILLA_PROJECT}:moz ${MOZILLA_SOURCE}:mozsrc
-USE_GNOME+= orbit gtk12
+USE_GNOME= orbit
.endif
+USE_XLIB= yes
USE_PERL5= yes
USE_BISON= yes
USE_GMAKE= yes
@@ -43,7 +43,7 @@ USE_BZIP2= yes
.if !defined(WITHOUT_JAVA)
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.4
JAVA_BUILD= jdk
.endif
@@ -58,9 +58,7 @@ LANG_EXT?= 01
LANG_CONFIGURE_ARG?= ENUS
L10NHELP?= helpcontent_01_unix.tgz
-.if defined(L10NHELP)
DISTFILES+= ${L10NHELP}:help
-.endif
.if defined(ALL_LOCALIZED_LANGS)
DISTFILES+= helpcontent_01_unix.tgz:help helpcontent_07_unix.tgz:help3 \
helpcontent_31_unix.tgz:help helpcontent_33_unix.tgz:help \
@@ -84,8 +82,8 @@ L10NHELPS= helpcontent_01_unix.tgz helpcontent_07_unix.tgz \
CODELINE= 645
RELEASE_NR= 1.1.4
-MILESTONE= 55
-SNAPDATE= 20050615
+MILESTONE= 56
+SNAPDATE= 20050630
INSTALLATION_BASEDIR= OpenOffice.org${RELEASE_NR}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org1.1
@@ -112,23 +110,13 @@ CXX= g++32
.endif
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
- gcp:${PORTSDIR}/sysutils/coreutils \
- xmkmf:${X_IMAKE_PORT} \
- ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
-.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
-.endif
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
+ gcp:${PORTSDIR}/sysutils/coreutils
.if defined(WITHOUT_JAVA)
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
.else
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
.endif
GNU_CONFIGURE= yes
-#USE_AUTOCONF_VER= 259
WRKSRC= ${WRKDIR}
CONFIGURE_WRKSRC= ${WRKSRC}/config_office
ANT?= ${LOCALBASE}/bin/ant
@@ -137,10 +125,8 @@ UNZIP?= ${PREFIX}/bin/unzip
PKGMESSAGE= ${WRKDIR}/pkg-message
NUMOFPROCESSES?= 1
-.if !defined(DISPLAY)
DISPLAYHACK=localhost:1001
-.endif
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --enable-pasf
.include <${FILESDIR}/Makefile.knobs>
@@ -168,15 +154,10 @@ post-extract:
@cd ${WRKDIR} ; ${CAT} ${DISTDIR}/${DIST_SUBDIR}/gpc231.tar.Z | ${TAR} xfz -
@${CP} ${WRKDIR}/gpc231/gpc.c ${WRKSRC}/external/gpc/
@${CP} ${WRKDIR}/gpc231/gpc.h ${WRKSRC}/external/gpc/
-.if defined(L10NHELP)
- @${ECHO_MSG} "===> Extracting L10NHELP sub project"
@${MKDIR} ${WRKDIR}/L10NHELP
@cd ${WRKDIR}/L10NHELP ; \
${CAT} ${DISTDIR}/${DIST_SUBDIR}/${L10NHELP} | ${GZIP_CMD} -d | ${TAR} xf -
-.endif
.if defined(ALL_LOCALIZED_LANGS)
- @${ECHO_MSG} "===> Extracting All available L10NHELPs"
- @${MKDIR} ${WRKDIR}/L10NHELP
@cd ${WRKDIR}/L10NHELP ; \
for helpfile in ${L10NHELPS}; do \
${CAT} ${DISTDIR}/${DIST_SUBDIR}/$$helpfile | ${GZIP_CMD} -d | ${TAR} xf - ; \
@@ -198,29 +179,12 @@ do-build:
.if !defined(WITHOUT_MOZILLA)
@cd ${WRKSRC}/moz.runtime ; ${SETENV} "BUILD_MOZAB=TRUE" ${TCSH} -c 'source ../FreeBSDEnv.Set ; build.pl ; dmake zip' ; ${CP} unxfbsd.pro/zipped/FREEBSD*.zip ../moz/zipped
.endif
-.if defined(L10NHELP) || defined(ALL_LOCALIZED_LANGS)
@${MKDIR} ${WRKSRC}/solver/${CODELINE}/unxfbsd.pro/pck
@${CP} ${WRKDIR}/L10NHELP/*.zip ${WRKSRC}/solver/${CODELINE}/unxfbsd.pro/pck
-.endif
-.if !defined(DISPLAY)
- #
- # This is a UGLY hack to not have to specify a X-Display.
- #
- ${X11BASE}/bin/Xvfb :1001 -screen 0 800x600x24 > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
- @sleep 5
.if (${NUMOFPROCESSES}>1)
@cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c "source FreeBSDEnv.Set ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all"
.else
- cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c "source FreeBSDEnv.Set ; dmake"
-.endif
- @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
- @${RM} -f ${WRKDIR}/.Xvfb.pid
-.else
-.if (${NUMOFPROCESSES}>1)
- @cd ${WRKSRC} ; DISPLAY=${DISPLAY} ; ${TCSH} -c "source FreeBSDEnv.Set ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all"
-.else
- @cd ${WRKSRC} ; DISPLAY=${DISPLAY} ; ${TCSH} -c "source FreeBSDEnv.Set ; dmake"
-.endif
+ @cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c "source FreeBSDEnv.Set ; dmake"
.endif
do-install:
diff --git a/editors/openoffice.org-1.1-devel/distinfo b/editors/openoffice.org-1.1-devel/distinfo
index 77b2f17356ae..6751705d4067 100644
--- a/editors/openoffice.org-1.1-devel/distinfo
+++ b/editors/openoffice.org-1.1-devel/distinfo
@@ -1,5 +1,5 @@
-MD5 (openoffice.org1.1/OOo_1.1.4m55_source.tar.bz2) = b7a8a3dcaf7fa13f6470a6e988a6506f
-SIZE (openoffice.org1.1/OOo_1.1.4m55_source.tar.bz2) = 201811678
+MD5 (openoffice.org1.1/OOo_1.1.5m56_source.tar.bz2) = 5582117d68d96177d64c02f8493c61f4
+SIZE (openoffice.org1.1/OOo_1.1.5m56_source.tar.bz2) = 200183575
MD5 (openoffice.org1.1/gpc231.tar.Z) = fdb06fdb5a4670b172f9fb738b717be9
SIZE (openoffice.org1.1/gpc231.tar.Z) = 27917
MD5 (openoffice.org1.1/cws_srx645_mozooo.20040203.tar.gz) = 1239aad43c65d6808b6261ea9d60fb67
@@ -8,6 +8,8 @@ MD5 (openoffice.org1.1/mozilla-source-1.0.tar.gz) = 35a7524c2fbb773e23449179c5cb
SIZE (openoffice.org1.1/mozilla-source-1.0.tar.gz) = 39881558
MD5 (openoffice.org1.1/helpcontent_01_unix.tgz) = 7da2aff674c2c84aba8b21ac2ab16bb6
SIZE (openoffice.org1.1/helpcontent_01_unix.tgz) = 12052480
+MD5 (openoffice.org1.1/helpcontent_01_unix.tgz) = 7da2aff674c2c84aba8b21ac2ab16bb6
+SIZE (openoffice.org1.1/helpcontent_01_unix.tgz) = 12052480
MD5 (openoffice.org1.1/helpcontent_07_unix.tgz) = e3ab37cbf2407d909953f06467b27611
SIZE (openoffice.org1.1/helpcontent_07_unix.tgz) = 13820401
MD5 (openoffice.org1.1/helpcontent_31_unix.tgz) = c7e618e2d9b8bd25cae12954ef2548c9
diff --git a/editors/openoffice.org-1.1-devel/files/moz-patch b/editors/openoffice.org-1.1-devel/files/moz-patch
index 818bc154943d..5da4ae43ef25 100644
--- a/editors/openoffice.org-1.1-devel/files/moz-patch
+++ b/editors/openoffice.org-1.1-devel/files/moz-patch
@@ -23,7 +23,7 @@ this functionality is not used at all.
--- moz/mozilla-source-1.0.patch.org Tue Feb 10 19:44:34 2004
+++ moz/mozilla-source-1.0.patch Sat Mar 19 12:51:35 2005
-@@ -4471,14 +4471,15 @@
+@@ -4471,14 +4471,16 @@
return NS_OK;
}
@@ -31,13 +31,14 @@ this functionality is not used at all.
+--- misc/build/mozilla/.mozconfig Tue Jul 22 21:52:27 2003
+++ misc/build/mozilla/.mozconfig Mon Jul 28 15:07:20 2003
-@@ -0,0 +1,8 @@
-+@@ -0,0 +1,9 @@
++@@ -0,0 +1,10 @@
+ac_add_options --disable-tests
+ac_add_options --disable-xprint
+ac_add_options --without-system-zlib
+ac_add_options --enable-ldap
+ac_add_options --disable-debug
++ac_add_options --disable-freetype2
+++ac_add_options --enable-default-toolkit=xlib
+ac_add_options --enable-optimize
+ac_add_options --enable-crypto
+ac_add_options --enable-strip
diff --git a/editors/openoffice.org-1.1-devel/files/patch-odfilter+prj+build.lst b/editors/openoffice.org-1.1-devel/files/patch-odfilter+prj+build.lst
new file mode 100644
index 000000000000..9e02c5438c2b
--- /dev/null
+++ b/editors/openoffice.org-1.1-devel/files/patch-odfilter+prj+build.lst
@@ -0,0 +1,13 @@
+Index: odfilter/prj/build.lst
+===================================================================
+RCS file: /cvs/xml/odfilter/prj/build.lst,v
+retrieving revision 1.1
+diff -u -r1.1 build.lst
+--- odfilter/prj/build.lst 6 Jun 2005 12:36:50 -0000 1.1
++++ odfilter/prj/build.lst 1 Jul 2005 10:49:28 -0000
+@@ -1,4 +1,4 @@
+-xod odfilter : offapi goodies comphelper NULL
++xod odfilter : offapi goodies comphelper xmloff NULL
+ xod odfilter usr1 - all xod_mkout NULL
+ xod odfilter\prj get - all xod_prj NULL
+ xod odfilter\source nmake - all xod_transform NULL
diff --git a/editors/openoffice.org-1.1-devel/files/patch-sndfile+makefile.mk b/editors/openoffice.org-1.1-devel/files/patch-sndfile+makefile.mk
new file mode 100644
index 000000000000..3be2aa82cd99
--- /dev/null
+++ b/editors/openoffice.org-1.1-devel/files/patch-sndfile+makefile.mk
@@ -0,0 +1,21 @@
+Issutracker : #iXXXXX#
+CWS : N/A
+Author :
+Description :
+
+--- sndfile/makefile.mk Wed Jun 1 01:31:45 2005
++++ sndfile/makefile.mk Fri Jul 1 09:17:49 2005
+@@ -81,8 +81,12 @@
+ CONFIGURE_DIR=
+
+ CONFIGURE_ACTION=./configure --with-pic
+-.IF "$(COM)" == "GCC" && "$(OS)" != "MACOSX" && "$(OS)" != "FREEBSD"
++.IF "$(COM)" == "GCC"
++.IF "$(OS)" != "MACOSX"
++.IF "$(OS)" != "FREEBSD"
+ CONFIGURE_FLAGS=LDFLAGS=-Wl,-noinhibit-exec
++.ENDIF
++.ENDIF
+ .ENDIF
+
+ BUILD_DIR=$(CONFIGURE_DIR)
diff --git a/editors/openoffice.org-1.1-devel/files/patch-vcl+util+makefile.mk b/editors/openoffice.org-1.1-devel/files/patch-vcl+util+makefile.mk
deleted file mode 100644
index 42d341934719..000000000000
--- a/editors/openoffice.org-1.1-devel/files/patch-vcl+util+makefile.mk
+++ /dev/null
@@ -1,22 +0,0 @@
-Issutracker : #iXXXXX#
-CWS : N/A
-Author : NAKATA Maho <maho@openoffice.org> (JCA)
-Description : another ENABLE_PASF issue, somehow strange though,
-only FreeBSD 4.11-RELEASE needs this patch(?)
-
-Index: vcl/util/makefile.mk
-===================================================================
-RCS file: /cvs/gsl/vcl/util/makefile.mk,v
-retrieving revision 1.47.10.5
-diff -u -r1.47.10.5 makefile.mk
---- vcl/util/makefile.mk 29 Apr 2005 14:28:18 -0000 1.47.10.5
-+++ vcl/util/makefile.mk 13 May 2005 08:51:12 -0000
-@@ -310,7 +310,7 @@
- .ENDIF # "$(OS)"=="SOLARIS"
- .ENDIF # "$(GUIBASE)"=="unx"
-
--.IF "$(ENABLE_PASF)" != ""
-+.IF "$(ENABLE_PASF)" == "YES"
- .IF "$(OS)"=="MACOSX"
- SHL1STDLIBS += -framework CoreAudio -framework AudioToolbox
- .ENDIF