aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2025-01-04 09:54:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2025-01-04 09:54:36 +0000
commit3223c498f42382fde416b7809e842aee917710b7 (patch)
treead70dd2ccf7ac106c626ced65eb368c4c56ae169
parentc25abe164af03748c8c2aad20498db94b3fb4aa8 (diff)
biology/py-scikit-bio: Broken where OpenMP isn't available
Reported by: fallout
-rw-r--r--biology/py-scikit-bio/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/biology/py-scikit-bio/Makefile b/biology/py-scikit-bio/Makefile
index 953b2c60e41b..03efdcfe9af3 100644
--- a/biology/py-scikit-bio/Makefile
+++ b/biology/py-scikit-bio/Makefile
@@ -12,6 +12,9 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN_aarch64= fails to build: invalid conversion between vector type '__m64' (vector of 1 'long long' value) and integer type 'int' of different size, see https://github.com/biocore/scikit-bio/issues/1816
+.if !exists(/usr/include/omp.h)
+BROKEN= requires OpenMP support that is missing on this architecture
+.endif
BUILD_DEPENDS= ${PYNUMPY} \
${PY_SETUPTOOLS} \