aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-05-28 07:37:30 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-05-28 07:37:30 +0000
commit324bc55fe4821b53c43ea4feb526c8f817d189bf (patch)
tree889ff53f1d2ce16f29fad362023993c1da15a810
parent32a64b1beefb046e80ce04f2b8fded9d00c7355e (diff)
downloadports-324bc55fe4821b53c43ea4feb526c8f817d189bf.tar.gz
ports-324bc55fe4821b53c43ea4feb526c8f817d189bf.zip
Notes
-rw-r--r--comms/xnecview/Makefile3
-rw-r--r--comms/xnecview/distinfo6
-rw-r--r--comms/xnecview/files/patch-Makefile17
-rw-r--r--comms/xnecview/files/patch-parse_output.c14
-rw-r--r--comms/xnecview/files/patch-xwin.c37
5 files changed, 8 insertions, 69 deletions
diff --git a/comms/xnecview/Makefile b/comms/xnecview/Makefile
index c7052fb346a4..faefcae34822 100644
--- a/comms/xnecview/Makefile
+++ b/comms/xnecview/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= xnecview
-PORTVERSION= 1.34
-PORTREVISION= 1
+PORTVERSION= 1.35
CATEGORIES= comms hamradio
MASTER_SITES= http://wwwhome.cs.utwente.nl/%7Eptdeboer/ham/xnecview/
EXTRACT_SUFX= .tgz
diff --git a/comms/xnecview/distinfo b/comms/xnecview/distinfo
index 443620bb1735..2ffbab3268fb 100644
--- a/comms/xnecview/distinfo
+++ b/comms/xnecview/distinfo
@@ -1,3 +1,3 @@
-MD5 (xnecview-1.34.tgz) = e496c0b04bd908911bb675bfc28c6c53
-SHA256 (xnecview-1.34.tgz) = 987ab674c5be33a6a017f2a6962352bfed75b2a0371c6dfa81b7cb2b01ea9803
-SIZE (xnecview-1.34.tgz) = 76863
+MD5 (xnecview-1.35.tgz) = 3e9a6d0cd82b04d8c8ac14d234cfb6e0
+SHA256 (xnecview-1.35.tgz) = 41351bb0aad3c5ff1b13240c40a6f50fcbac04988b5347a4f40e0f9e33c7eb44
+SIZE (xnecview-1.35.tgz) = 77971
diff --git a/comms/xnecview/files/patch-Makefile b/comms/xnecview/files/patch-Makefile
index 85c6b11c1fa7..be9d4cb1df37 100644
--- a/comms/xnecview/files/patch-Makefile
+++ b/comms/xnecview/files/patch-Makefile
@@ -1,21 +1,12 @@
---- Makefile.orig Fri Dec 27 23:23:23 2002
-+++ Makefile Sun Mar 19 06:56:59 2006
-@@ -4,14 +4,15 @@
-
-
- CC = gcc
--CFLAGS = -O2 -g -Wall `gtk-config --cflags`
-+CFLAGS = -O2 -g -Wall `pkg-config --cflags gtk+-2.0`
-
- LD = $(CC)
--LDFLAGS = `gtk-config --libs` -lm
-+LDFLAGS = `pkg-config --libs gtk+-2.0` -lm
+--- Makefile.orig Fri May 26 21:40:46 2006
++++ Makefile Fri May 26 21:42:42 2006
+@@ -11,7 +11,8 @@
ifeq ($(PNG),yes)
CFLAGS += -DHAVE_LIBPNG
-LDFLAGS += -lpng
+CFLAGS += `pkg-config --cflags ${LOCALBASE}/libdata/pkgconfig/libpng12.pc`
-+LDFLAGS += `pkg-config --libs ${LOCALBASE}/libdata/pkgconfig/libpng12.pc`
++LDFLAGS += `pkg-config --libs ${LOCALBASE}/libdata/pkgconfig/libpng12.pc`
endif
SRCS = xnecview.c xwin.c parse_input.c parse_output.c draw.c draw_opaque.c freqplot.c postscript.c icon.xbm
diff --git a/comms/xnecview/files/patch-parse_output.c b/comms/xnecview/files/patch-parse_output.c
deleted file mode 100644
index 627330f4eab3..000000000000
--- a/comms/xnecview/files/patch-parse_output.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- parse_output.c.orig Fri Mar 17 20:32:22 2006
-+++ parse_output.c Fri Mar 17 20:30:42 2006
-@@ -749,9 +749,9 @@
- EXPAND_IF_NECESSARY(numneco,maxfreqs,neco)
-
- /* search for the frequency and read it */
-- do fgets(s,200,f); while (!feof(f) && !strstr(s,"FREQUENCY="));
-+ do fgets(s,200,f); while (!feof(f) && !strstr(s,"FREQUENCY : "));
- if (feof(f)) break;
-- p = strchr(s,'=');
-+ p = strchr(s,':');
- freq = atof(p+1);
-
- /* find the right place in the neco array (data is sorted by frequency) */
diff --git a/comms/xnecview/files/patch-xwin.c b/comms/xnecview/files/patch-xwin.c
deleted file mode 100644
index ac537c6b581c..000000000000
--- a/comms/xnecview/files/patch-xwin.c
+++ /dev/null
@@ -1,37 +0,0 @@
---- xwin.c.orig Wed Sep 10 22:55:30 2003
-+++ xwin.c Tue Mar 21 07:05:23 2006
-@@ -13,6 +13,7 @@
- #include <math.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <gtk/gtk.h>
- #include <gdk/gdkx.h>
- #include <gdk/gdkkeysyms.h>
-@@ -261,7 +262,7 @@
- f=fopen(filename,"w");
- if (!f) return 1;
-
-- image = gdk_image_get(gbackg, 0, 0, width, height);
-+ image = gdk_image_get(w, 0, 0, width, height);
- if (!image) {
- fclose(f);
- return 1;
-@@ -1378,7 +1379,7 @@
-
- gtk_widget_grab_focus(gdraw1);
-
-- gtk_accel_group_attach(acc, GTK_OBJECT(win1));
-+ gtk_window_add_accel_group(GTK_WINDOW(win1), acc);
-
- ggc = gdk_gc_new(w->window);
-
-@@ -1478,7 +1479,7 @@
-
- gtk_widget_grab_focus(gdraw2);
-
-- gtk_accel_group_attach(acc, GTK_OBJECT(win2));
-+ gtk_window_add_accel_group(GTK_WINDOW(win2), acc);
-
- ggc2 = gdk_gc_new(w->window);
-