aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-11-13 18:10:04 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-11-13 18:10:04 +0000
commit347ad18ece277c53151a64fbf5ed8e0403cdac9a (patch)
tree3c71e2a0053545f4ff0860557fe8b5e19a9e727c
parentc821cc2415fd498f8a22758187365d104425ccc9 (diff)
downloadports-347ad18ece277c53151a64fbf5ed8e0403cdac9a.tar.gz
ports-347ad18ece277c53151a64fbf5ed8e0403cdac9a.zip
Notes
-rw-r--r--news/Makefile1
-rw-r--r--news/p5-NewsLib/Makefile35
-rw-r--r--news/p5-NewsLib/distinfo2
-rw-r--r--news/p5-NewsLib/pkg-descr18
-rw-r--r--news/p5-NewsLib/pkg-plist14
5 files changed, 70 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index 31d6f1c7eaa5..5498d2ed839f 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -63,6 +63,7 @@
SUBDIR += p5-NNTPClient
SUBDIR += p5-News-Article
SUBDIR += p5-News-Newsrc
+ SUBDIR += p5-NewsLib
SUBDIR += p5-POE-Component-Client-NNTP
SUBDIR += pan2
SUBDIR += papercut
diff --git a/news/p5-NewsLib/Makefile b/news/p5-NewsLib/Makefile
new file mode 100644
index 000000000000..8e8e10cf4df8
--- /dev/null
+++ b/news/p5-NewsLib/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-NewsLib
+# Date created: 13 November 2004
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= NewsLib
+PORTVERSION= 0.84
+CATEGORIES= news perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= News
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME:L}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A library of perl modules for managing Network News services
+
+BUILD_DEPENDS= ${SITE_PERL}/News/Article.pm:${PORTSDIR}/news/p5-News-Article \
+ ${SITE_PERL}/Net/NNTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::NNTP::Auth.3 \
+ Net::NNTP::Client.3 \
+ Net::NNTP::Functions.3 \
+ Net::NNTP::Proxy.3 \
+ News::Article::Cancel.3 \
+ News::Article::Clean.3 \
+ News::Article::Ref.3 \
+ News::Article::Response.3 \
+ News::NNTPAuth.3
+
+.include <bsd.port.mk>
diff --git a/news/p5-NewsLib/distinfo b/news/p5-NewsLib/distinfo
new file mode 100644
index 000000000000..767e9f75c49c
--- /dev/null
+++ b/news/p5-NewsLib/distinfo
@@ -0,0 +1,2 @@
+MD5 (newslib-0.84.tar.gz) = 1c2dfdde1e78ced70868330b8cf79bf3
+SIZE (newslib-0.84.tar.gz) = 33688
diff --git a/news/p5-NewsLib/pkg-descr b/news/p5-NewsLib/pkg-descr
new file mode 100644
index 000000000000..3796174c564a
--- /dev/null
+++ b/news/p5-NewsLib/pkg-descr
@@ -0,0 +1,18 @@
+NewsLib - a News Library for Perl
+=================================
+
+NewsLib is a library of perl modules for managing Network News services.
+It's meant to be used for code-reuse and sharing when writing news-based
+applications. It currently includes:
+
+News::Article::Response Create responses to News::Article articles
+News::Article::Ref Reference functions for news articles
+News::Article::Clean Subroutines to clean News::Article headers
+News::Article::Cancel Generate accurate cancel messages
+News::NNTPAuth Deprecated for Net::NNTP::Auth
+Net::NNTP::Auth A standard NNTP authentication method
+Net::NNTP::Proxy A news server in perl
+Net::NNTP::Client Simulate an entire NNTP client
+Net::NNTP::Functions Code to implement NNTP-standard functions
+
+WWW: http://search.cpan.org/dist/newslib/
diff --git a/news/p5-NewsLib/pkg-plist b/news/p5-NewsLib/pkg-plist
new file mode 100644
index 000000000000..58fb3826d728
--- /dev/null
+++ b/news/p5-NewsLib/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/NewsLib/.packlist
+%%SITE_PERL%%/News/NNTPAuth.pm
+%%SITE_PERL%%/News/Article/Cancel.pm
+%%SITE_PERL%%/News/Article/Ref.pm
+%%SITE_PERL%%/News/Article/Clean.pm
+%%SITE_PERL%%/News/Article/Response.pm
+%%SITE_PERL%%/Net/NNTP/Auth.pm
+%%SITE_PERL%%/Net/NNTP/Proxy.pm
+%%SITE_PERL%%/Net/NNTP/Client.pm
+%%SITE_PERL%%/Net/NNTP/Functions.pm
+@dirrm %%SITE_PERL%%/News/Article
+@unexec rmdir %D/%%SITE_PERL%%/News 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/NNTP
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/NewsLib